Switching

IMPORTANT MODERATION NOTICE

This community is currently under full moderation, meaning  all posts will be reviewed before appearing in the community. Please expect a brief delay—there is no need to post multiple times. If your post is rejected, you'll receive an email outlining the reason(s). We've implemented full moderation to control spam. Thank you for your patience and participation.



Expand all | Collapse all

LACP between EX4200 and Cisco Cat2950

Jump to Best Answer
  • 1.  LACP between EX4200 and Cisco Cat2950

    Posted 07-08-2008 02:16

    Hi,

     

    JUNOS is quit new for me, so i have to throw my Cisco experience away now Smiley Sad

     

    I'm playing around with some new Ex's and try to setup LACP between 2950 and EX4200.

    I have tried almost all possible commands, but i'm not sure about the EX commands i've used.

     

    Is there somebody with more experience then me, who already succeeded on LCAP ?

     

    Commands used on Cisco:

     

     interface Port-channel1
     description === LACP Trunk to Juniper ===
     switchport trunk native vlan 2
     switchport mode trunk
     no ip address

    !

     interface FastEthernet0/22
     description === LACP Trunk uplink to Juniper ===
     switchport trunk native vlan 2
     switchport mode trunk
     no ip address
     channel-group 1 mode active
     channel-protocol lacp
    !
    interface FastEthernet0/23
     description === LACP Trunk uplink to Juniper ===
     switchport trunk native vlan 2
     switchport mode trunk
     no ip address
     channel-group 1 mode active
     channel-protocol lacp

     

    Commands used on the EX:

    chassis {
        aggregated-devices {
            ethernet {
                device-count 1;
            }
        }
    }

     

    ge-0/0/14 {
            ether-options {
                no-auto-negotiation;
                802.3ad ae0;
            }
        }
        ge-0/0/15 {
            ether-options {
                no-auto-negotiation;
                802.3ad ae0;

     ae0 {
            description "LACP to Cat2950";
            traceoptions {
                flag all;
            }
            aggregated-ether-options {
                minimum-links 1;
                link-speed 100m;
                lacp {
                    passive;
                    periodic fast;
                }
            }
            unit 0 {
                family ethernet-switching {
                    port-mode trunk;
                    vlan {
                        members [ Servers Transit Users ];
                    }
                    native-vlan-id Users;
                }
            }
        }

     

     

    gr

    william

     

     

     



  • 2.  RE: LACP between EX4200 and Cisco Cat2950

    Posted 07-08-2008 05:19

    Hi Wide,

     

    Here is an example of LACP config , hope this will help.

     

    http://kb.juniper.net/KB10927

       

     

     

    Message Edited by KB_Fan on 12-29-2008 03:15 PM


  • 3.  RE: LACP between EX4200 and Cisco Cat2950

    Posted 07-08-2008 05:41

    Hi Sylvain,

     

    thx for the quick reply.

    This document describe very good the necessary steps to taken.

    That looks the same as what i did, so i will try again but starting from scratch with the whole config on the EX.

     

     

    Keep you informd

    william

     

     



  • 4.  RE: LACP between EX4200 and Cisco Cat2950

    Posted 07-08-2008 09:27

    Hi Sylvain,

     

    still the same problem.

    I've tried with several options:

    -passive on EX, active Cisco, otherway

    -a new ae, with min options

    -other native vlan

     

    Cisco debugging state:

    00:03:32: %EC-5-L3DONTBNDL3: Fa0/23 suspended: LACP currently not enabled on the remote port.

     

    Next that i will try is to use another Cisco switch

     

     

    gr

    william



  • 5.  RE: LACP between EX4200 and Cisco Cat2950

    Posted 07-11-2008 15:23

    Hi Please try with "periodic fast" and check if it works 

     

    ae0 {
            description "LACP to Cat2950";
            traceoptions {
                flag all;
            }
            aggregated-ether-options {
                minimum-links 1;
               link-speed 100m;
                lacp {
                    active; ## changed from passive
                    periodic fast;
                }
            }

     

     

    Thanks

    - Kiran Meda 



  • 6.  RE: LACP between EX4200 and Cisco Cat2950

    Posted 07-18-2008 05:34

    It's a bad idea to have auto-neg mismatch between equipement.

    => force speed / duplex setting on both side or leave auto-neg.


    #set
    #1g
    #to
    #link-speed
    #also


  • 7.  RE: LACP between EX4200 and Cisco Cat2950

    Posted 07-18-2008 06:05

    Hi Kiran,

    the periodic fast was something that i've already tested, same result.

     

     

    Hi Christien,

     

    i've played around with auto-neg and fixed speed/duplex, and this on both Cisco/juniper.
    Always the same result.

     

    I had not the time this week (and also next week) to make some tests again.
    But next i will do is test with another type of Cisco device.

     

    keep you informad, and thx again for the assistance

    william



  • 8.  RE: LACP between EX4200 and Cisco Cat2950

    Posted 08-11-2008 04:47

    Hi,

     i started today again with some new tests.

    I've changed the Cisco 2950 by a Cisco 3750, and again the same result.

    I've tried several options (passive-passive, active-active, active-passive)

    I'm getting always on the Cisco a message "00:15:39: %EC-5-L3DONTBNDL2: Fa1/0/22 suspended: LACP currently not enabled on the remote port."

     

    It looks that LCAP between Cisco and Juniper is not so easy.

     

    Anyone other idea's ?

     

     

     

    interface Port-channel1
     description === LACP Trunk to Juniper ===
     switchport trunk encapsulation dot1q
     switchport trunk native vlan 2
     switchport mode trunk
     
    interface FastEthernet1/0/22
     description === LACP Trunk uplink to Juniper ===
     switchport trunk encapsulation dot1q
     switchport trunk native vlan 2
     switchport mode trunk
     channel-protocol lacp
     channel-group 1 mode passive
    !
    interface FastEthernet1/0/23
     description === LACP Trunk uplink to Juniper ===
     switchport trunk encapsulation dot1q
     switchport trunk native vlan 2
     switchport mode trunk
     channel-protocol lacp
     channel-group 1 mode passive
     
     
     
    set chassis aggregated-devices ethernet device-count 1

    set interfaces ge-0/0/14 ether-options 802.3ad ae0
    set interfaces ge-0/0/15 ether-options 802.3ad ae0

    set interfaces ae0 description "LACP to Cat2950"
    set interfaces ae0 traceoptions flag all
    set interfaces ae0 aggregated-ether-options minimum-links 1
    set interfaces ae0 aggregated-ether-options link-speed 100m
    set interfaces ae0 aggregated-ether-options lacp active
    set interfaces ae0 aggregated-ether-options lacp periodic fast
    set interfaces ae0 unit 0 family ethernet-switching port-mode trunk
    set interfaces ae0 unit 0 family ethernet-switching vlan members Servers
    set interfaces ae0 unit 0 family ethernet-switching vlan members Transit
    set interfaces ae0 unit 0 family ethernet-switching vlan members Users
    set interfaces ae0 unit 0 family ethernet-switching native-vlan-id Users

     



  • 9.  RE: LACP between EX4200 and Cisco Cat2950
    Best Answer

    Posted 08-12-2008 05:18

     

    Hi,

     

    the problem is solved.

    You need to put the next command in, even  if the remote switch has Fastethernet interfaces.

    " set interfaces ae0 aggregated-ether-options link-speed 1g"

     

    If somebody is interested in the full config from Cisco / Juniper, pls let me know.

     

    Thanks for the help

     

    kind regards

    william


    #same
    #can
    #config
    #got
    #Cisco/Juniper
    #you
    #your
    #to
    #i
    #also
    #me?
    #with
    #Hi
    #have
    #issue
    #full
    #try
    #send
    #IT
    #wide
    #will
    #of


  • 10.  RE: LACP between EX4200 and Cisco Cat2950

    Posted 12-04-2008 13:14
    hi could you paste the cisco and juniper config for this? thanks


  • 11.  RE: LACP between EX4200 and Cisco Cat2950

    Posted 12-09-2008 01:51

    Hi,

     

    hereby you can find the working configs

     

    kind regards

    william

    Attachment(s)



  • 12.  RE: LACP between EX4200 and Cisco Cat2950

    Posted 01-19-2009 09:25

    Just for completeness, this breaks very differently in a VC config.  LACP on the VC unbundles the port as you saw, but the lower-layer remains up.  As a result, the gear on the other end of the link stays with the lower-layer protocol UP - ie, the Cisco side doesn't see the interface go down.

     

    This wasn't service impacting for us due to having a redundant path that was okay.  But in many other configurations, this would break everything.  I can't imagine that this is not a JUNOS bug - no one would want this behavior 🙂



  • 13.  RE: LACP between EX4200 and Cisco Cat2950

    Posted 08-03-2011 02:03

    Hi William,

     

    Can you please send the Cisco/Juniper both ends configuration to implement LAG/Ether Channel?

     

    In fact I am trying to set up the same. I will share you my results also.

     

    Regards,

     

    Praveen Neti.



  • 14.  RE: LACP between EX4200 and Cisco Cat2950

    Posted 08-05-2011 13:05

    Its never a good idea to use fixed speed on ae interfaces..

     

    What advantage that if you are bundling 2*1Gig links and defining AE0 speed 1 G.

     

    Remove speed configuration from either side.

     

    I could see 100m configured from your first Junos config and LACP ACTIVE on Cisco side remove both of these.

     

    your current output of show interfaces ae0 would give you the speed of 1G.

     

    Where in by leaving it by default it should show 2 Gig and your AE0 should also remain up.

     

    In case required you may disable flow-control on both side.

     

    Hope this helps.