View Only
last person joined: 2 days ago 

Ask questions and share experiences about vMX.
Expand all | Collapse all

vMX FPC empty

  • 1.  vMX FPC empty

    Posted 09-19-2017 08:14

    Hello World,


    So I got pretty motivated about Juniper SP (tired of the same ol' Cisco rhetoric about upward mobility in the workplace, etc ---- figured I'd pursue something I'm a bit more passionate about) ... 


    At any rate, I started down the path of building out a generic Juniper SP topology in ESXi 5.5U3 - after obtaining the latest vMX images from Juniper site. In my case, I beleive 17.3R1. 


    They made it easy of course, consolidating everything to two OVA files, one for VCP and VFP. Imported them no problem, however when issuing "show chassis fpc" or "show interfaces terse" ... I see nothing. It's as if they don't exist. I've been careful to allocate recommended resources, following multiple sources for requirements, but still no joy. 


    What gives???



  • 2.  RE: vMX FPC empty

    Posted 09-23-2017 22:25



    Looks like communication issues between vCP and vFP.

    Can you try steps given in the link below?









  • 3.  RE: vMX FPC empty

    Posted 09-26-2017 13:08

    Hi Rushi,

          I did perform those steps and I am able to ping routing-instance __juniper_private1__ but I am still not having any physical ports showing up. When I do show chassis fpc I get 
    0 present 

    1...11 false

    and when I do show chassis fpc pic-status i get:

    slot 0 present virtual FPC

  • 4.  RE: vMX FPC empty

    Posted 09-27-2017 01:06

    Hi Bhoomi


    Please can you confirm the resources that you have allocated to VCP and VFP, and that the FPC is configured as Lite mode (if this is a lab)



  • 5.  RE: vMX FPC empty

    Posted 09-27-2017 20:51



    I am having the exact same issue as Bhoomi. I used the ping syntax on the link you provided and ping was good....


    root> ping routing-instance __juniper_private1__
    PING ( 56 data bytes
    64 bytes from icmp_seq=0 ttl=64 time=0.273 ms
    64 bytes from icmp_seq=1 ttl=64 time=0.606 ms

     However, I also cannot see the ge- interfaces. I tried lite-mode, but that didn't work either. I have plenty of resources, I'm running on a Dell Blade Chassis, the Dell m1000e series blade. In my case I've allocated no less than 4 x CPUs and at least 8-10 GB of memory ---- but still cannot see interfaces. 


    I just don't get it. This is really bothering me because I desparately want to incorporate vMX into my Service Provider lab topology. 




    Somebody help me figure this out ... if you do ... I'll call you the coolest engineer in the world for 10 more years ---- em hem --- if I remember in 10 years that is 🙂

  • 6.  RE: vMX FPC empty

    Posted 09-28-2017 01:54



    Please can you post details on how you have the vSwitches/vNICs configured for VCP and VFP (but as you have a working ping from VCP I'm assuming they are OK).


    If you login to the VFP console are you seeing any errors, also see /var/log



  • 7.  RE: vMX FPC empty

    Posted 09-28-2017 09:40



    I'm both a systems/network engineer, so pretty savvy on the Virtual side as well. To answer your question, I used the default number of vNICs automatically assigned, I believe two on each VM, and made sure 100% sure to trunk the vSwitch, set it to promiscuous, and put the 2nd vNIC on same VLAN. I've tried destroying VMs, and re-importing over and over ---- never seems to work. Seems like others have the same issue when I Google-Fu. 

    Is there an absolutely functional combination of ESXi/vMX that you're aware of? For example ESXi 5.5U3 and vMX 14.1, etc?


    I feel like everything is there, just some minor detail is snagging me here. Sheesh 😕

  • 8.  RE: vMX FPC empty
    Best Answer

    Posted 09-28-2017 10:27

    Hi Jesse,


    You need to have two vNICs on the VCP and VFP as follows

    vNIC1 - management (fxp0)

    vNIC2 - internal (used for VCP-VFP comms)


    Subsequent NICs on the VFP are data interfaces

    vNIC3 - ge-0/0/0

    vNIC4 - ge-0/0/1



    Usually the NIC1 would either map to your management network, or create a new vSwitch for management and assign the NICs to that.


    The NIC2 (internal network) should map to a dedicated vSwitch that links NIC2 on the VCP to NIC2 on the VFP only (one required per vMX instance).


    Now if you have not assigned a 3rd NIC to the VFP, then it does not have a data interface so the virtual VFP will not start all the required processes and you will not see the ge-0/0/* in Junos.


    Hope that helps





  • 9.  RE: vMX FPC empty

    Posted 10-04-2017 11:48

    Giving you credit for solution --- lol --- although I figured out before seeing your post. 


    My issue wasn't entirely related to NIC allocation, so much as it was just waiting a while for FPC to come up. 


    Interesting behavior in that when you first boot and run  > sho interfaces terse ... you don't see any ge- interfaces, however after about 2-4 more minutes, I checked again and boom! they are present. 


    At any rate. I now have created 6 healthy instances of vMX 17.x on ESXi 5.5 with no problem (for those inquisitive minds wondering if there are compatibility issues with the above - nope, they play nice together.)


    I now have an awesome hetergeneous CCIE-SP/JNCIE-SP lab, with the ability to emulate many topologies. Onwards to MP-BGP! Later.





  • 10.  RE: vMX FPC empty

    Posted 09-04-2019 11:14



    I am also facing the similar problem like you faced earlier. It seems the connection between VCP and VFP is absolutely fine however still I am unable to see ge-0/0/* interfaces.


    root@PE1> ping routing-instance __juniper_private1_
    ping: invalid routing instance `__juniper_private1_'

    root@PE1> ping routing-instance __juniper_private1__
    PING ( 56 data bytes
    64 bytes from icmp_seq=0 ttl=64 time=0.252 ms
    64 bytes from icmp_seq=1 ttl=64 time=0.055 ms
    64 bytes from icmp_seq=2 ttl=64 time=0.165 ms
    64 bytes from icmp_seq=3 ttl=64 time=0.150 ms
    64 bytes from icmp_seq=4 ttl=64 time=0.553 ms
    64 bytes from icmp_seq=5 ttl=64 time=0.166 ms
    --- ping statistics ---
    6 packets transmitted, 6 packets received, 0% packet loss
    round-trip min/avg/max/stddev = 0.055/0.224/0.553/0.158 ms



    root@PE1> show interfaces terse | match ge-



    Apprecaite any help on this matter...


    I m using laptop with 32GB RAM and Corei7 Vpro 8th Gen.





  • 11.  RE: vMX FPC empty

    Posted 09-05-2019 12:04

    Hi Raju

    What is the Junos version and the adapter type which you are using?





  • 12.  RE: vMX FPC empty

    Posted 10-21-2019 04:43

    i face a related issue during hosting the VCP and vFPC for VMX-vCP_18.4R2.7

    as when i made show chassiss fpc

    lab> show chassis fpc
    Temp CPU Utilization (%) CPU Utilization (%) Memory Utilization (%)
    Slot State (C) Total Interrupt 1min 5min 15min DRAM (MB) Heap Buffer
    0 Present Testing
    1 Empty
    2 Empty
    3 Empty
    4 Empty
    5 Empty
    6 Empty
    7 Empty
    8 Empty
    9 Empty
    10 Empty
    11 Empty


    the FPC is stucked in present state


    i've assigned a memory of 4Gbps and 4 memory for each of vCP and vFPC


    mapped network adapter 3 with ext-br

    and network adapter 4 with int-br


    i've made a ping for

    ping routing-instance __juniper_private1__


    successfully ping

  • 13.  RE: vMX FPC empty

    Posted 05-09-2022 11:29
    Sorry for reviving this topic,


    VCP & VFP

    Memory: 32g
    HDD: 130
    Adapter: 4x1G / 2x25G / 2x40G

    For example: when I add 2x25G FPC it starts perfectly online but when I add 2x40G plus FPC 0 it is empty, I will leave an image to better appreciate what I say.

    fpc its empty

    when add 2x40G or 2x25G, either one works

    Jose Zambrano

  • 14.  RE: vMX FPC empty

    Posted 10-04-2017 12:41
    Cool, glad it’s sorted, and nice lab 🙂

    Yeah it takes a few minutes for the VFP to spin everything up. On boot the VFP syncs the virtualised TRIO forwarding plane (RIOT) binaries/code from the VCP and then it all must load up.