SRX

 View Only
last person joined: 2 days ago 

Ask questions and share experiences about the SRX Series, vSRX, and cSRX.
  • 1.  VLAN/ARP problem after upgrade

    Posted 02-14-2024 17:56

    Greetings. We have SRX 3xx device with Junos 21.4R3-S4.9. It has VLANs and irb interfaces configured like this:

    ge-0/0/0 {
        unit 0 {
            family ethernet-switching {
                interface-mode trunk;
                vlan {
                    members [ VLAN-A VLAN-B VLAN-C ];
                }
            }
        }
    }
    ge-0/0/1 {
        unit 0 {
            family ethernet-switching {
                interface-mode trunk;
                vlan {
                    members [ VLAN-A VLAN-B VLAN-C ];
                }
            }
        }
    }
    
    irb {
        unit 10 {
            family inet {
                address 10.249.10.1/24;
            }
        }
        unit 20 {
            family inet {
                address 10.249.20.1/24;
            }
        }
        unit 30 {
            family inet {
                address 10.249.30.1/24;
            }
        }
    }
    
    VLAN-A {
        vlan-id 10;
        l3-interface irb.10;
    }
    VLAN-B {
        vlan-id 20;
        l3-interface irb.20;
    }
    VLAN-C {
        vlan-id 30;
        l3-interface irb.30;
    }

    After upgrade to 21.4R3-S5.4 (also tried 22.2R3-S2.8) we face the following issue: some hosts inside the same VLAN can't see each other anymore. SRX seems to have both hosts MAC addresses in its ARP table. Some of them seem to be reacheable by ping, while other are flapping - sometimes you can ping them, but mostly you can't. On host's side it looks like it has no reply to its ARP requests.

    The issue is immediately solved once I downgrade the firmware. My attempts to find relevant PRs and release notes were unsuccessful. Do you have any suggestions?



    ------------------------------
    VLADIMIR STREMBITSKY
    ------------------------------


  • 2.  RE: VLAN/ARP problem after upgrade

    Posted 02-14-2024 18:17

    I have reported this same issue with 21.4.R3-S5. This caused us some real major issues as the fault comes and goes. It was causing 5-10 minute outages in both of our DC's so we had to rollback. New SW is meant to be released in the next few days. I have the same issue simulated in the lab so i have been providing Juniper traces. They will have a fix out shortly. Juniper support have been great sorting this fault out for us. 

    PR number 1768050

    https://prsearch.juniper.net/problemreport/PR1768050



    ------------------------------
    Steven Waite
    ------------------------------