Screen OS

 View Only
last person joined: 11 months ago 

This is a legacy community with limited Juniper monitoring.
  • 1.  SSG-20 sudden crash - cannot reboot device

    Posted 09-14-2014 20:50

    Dear Juniper community,


    My SSG-20 got to crash suddenly a few days ago after several years of uninterrupted service.


    System Information:

    SSG-20-SH, 256 MB RAM module, No PIM card installed, Bootloader 1.3.2, screenOS 6.3.0r16a0. Manufacturing date 20080903.


    Visible Symptoms:

    • Console port

    shows below message immediatly and repeatedly as soon as I plug the SSG's power cord :


    "Juniper Networks SSG20 Boot Loader Version 1.3.2 (Checksum:"

    "Juniper Networks SSG20 Boot Loader Version 1.3.2 (Checksum:"

    "Juniper Networks SSG20 Boot Loader Version 1.3.2 (Checksum:"


    • LED status:

    Ethernet ports all blinking green

    Power led permanent green.

    Status led blinking red


    • Other

    Fan not running (not sure if it should at this stage)



    1. I have triied to interrupt the message through console port -->  no success yet (Key sequence)
    2. Hardware Reset button action makes power led turn to permanent red until I release the the button again (it never turns green). I applied the reset sequence but nothing happens --> message continues to display without interruption
    3. I replaced the RAM Module (identical size and brand module) --> Same problem !
    4. Plug as USB key to try to trigger any action --> no change
    5. I tried to startup without RAM Module installed --> No change, still same message !
    6. Tried with and without fan plugged --> No change !



    After browsing for days all possible forums, JTAC KB, Google a.s.o, I didn't find any similar case in the community except one in China for which the replacement of RAM Module helped fix the problem. But as stated above I've tried this solution but without success. I' have the feeling my case is an orphan case in the Juniper world 😞


    Does anyone in the community faced same or similar issue ? Any idea on how to interrupt this sequence, any suggestion on how to fix it ?


    Thanks for all suggestions,





  • 2.  RE: SSG-20 sudden crash - cannot reboot device
    Best Answer

    Posted 09-14-2014 21:56


    I believe the flash card on the SSG-20 cannot be removed. So, if swapping out the RAM did not help, replacement is the only option.


    Since you do not have a support contract, you can either renew the contract or scrap the box 😞

  • 3.  RE: SSG-20 sudden crash - cannot reboot device

    Posted 12-25-2014 00:02


    I have the same problem  on my SSG20. There is no change when I removed the DIMM Memory, same error appears continiously. 

    I was considering to replace the memory which is removable but I saw your entry. You replaced the memory but it did not help. 

    It seems the router is in an unrecoverable status. 

    Have you found out any way to get back your device or did you throw it to waste?