SRX

 View Only
last person joined: yesterday 

Ask questions and share experiences about the SRX Series.
  • 1.  SRX550 cluster could not be established

    Posted 08-09-2022 06:32
    Hello All,
    I have a problem with finish setup cluster on two SRX550 devices (firmware version 12.3X48-D105.4).
    I did everything according to this manual:
    CEC Juniper Community
    Juniper remove preview
    CEC Juniper Community
    View this on Juniper >


    but for some reason the cluster not established.
    Node0 and Node1 can't "see" each other.

    Firmware version is the same on both devices. (also on alternate media internal)
    Licenses also the same on both devices.

    I already tried:
    - change the cables
    - change the fabric ports from 0/0/2 to 0/0/5.
    - reboot two devices simultanously.
    - copy configuration and manually paste to node1.
    - load factory default on both devices and configure again from begining
    - delete all default config before start configuration cluster (on both devices).

    I have no idea what can I do more.
    Could someone look at my config and advise what could be wrong please?


    ====================== Configuration
    Device A:
    root@deviceA> show configuration | display set
    set version 12.3X48-D105.4
    set groups node0 system host-name DeviceA
    set groups node0 interfaces fxp0 unit 0 family inet address 10.10.10.7/26
    set groups node1 system host-name DeviceB
    set groups node1 interfaces fxp0 unit 0 family inet address 10.10.10.8/26
    set apply-groups "${node}"
    set system root-authentication encrypted-password "****************"
    set chassis cluster reth-count 2
    set chassis cluster redundancy-group 0 node 0 priority 100
    set chassis cluster redundancy-group 0 node 1 priority 1
    set chassis cluster redundancy-group 1 node 0 priority 100
    set chassis cluster redundancy-group 1 node 1 priority 1
    set interfaces fab0 fabric-options member-interfaces ge-0/0/5
    set interfaces fab1 fabric-options member-interfaces ge-9/0/5
    {primary:node0}
    root@deviceA>


    Device B:
    root> show configuration | display set
    set version 12.3X48-D105.4
    set system root-authentication encrypted-password "****************"
    {primary:node1}
    root>





    ====================== Cluster status
    Device A:
    root@DeviceA> show chassis cluster status
    Monitor Failure codes:
    CS Cold Sync monitoring FL Fabric Connection monitoring
    GR GRES monitoring HW Hardware monitoring
    IF Interface monitoring IP IP monitoring
    LB Loopback monitoring MB Mbuf monitoring
    NH Nexthop monitoring NP NPC monitoring
    SP SPU monitoring SM Schedule monitoring
    CF Config Sync monitoring RE Relinquish monitoring

    Cluster ID: 1
    Node Priority Status Preempt Manual Monitor-failures

    Redundancy group: 0 , Failover count: 1
    node0 100 primary no no None
    node1 0 lost n/a n/a n/a

    Redundancy group: 1 , Failover count: 1
    node0 0 primary no no CS
    node1 0 lost n/a n/a n/a

    {primary:node0}

    Device B:
    root> show chassis cluster status
    Monitor Failure codes:
    CS Cold Sync monitoring FL Fabric Connection monitoring
    GR GRES monitoring HW Hardware monitoring
    IF Interface monitoring IP IP monitoring
    LB Loopback monitoring MB Mbuf monitoring
    NH Nexthop monitoring NP NPC monitoring
    SP SPU monitoring SM Schedule monitoring
    CF Config Sync monitoring RE Relinquish monitoring

    Cluster ID: 1
    Node Priority Status Preempt Manual Monitor-failures

    Redundancy group: 0 , Failover count: 1
    node0 0 lost n/a n/a n/a
    node1 1 primary no no None

    {primary:node1}





    ====================== Cluster Interfaces:
    Device A:
    root@DeviceA> show chassis cluster interfaces
    Control link status: Down

    Control interfaces:
    Index Interface Monitored-Status Internal-SA
    0 fxp1 Down Disabled

    Fabric link status: Down

    Fabric interfaces:
    Name Child-interface Status
    (Physical/Monitored)
    fab0 ge-0/0/2 Up / Down
    fab0

    Redundant-pseudo-interface Information:
    Name Status Redundancy-group
    lo0 Up 0

    {primary:node0}
    root@DeviceA>


    Device B:
    root> show chassis cluster interfaces
    Control link status: Down

    Control interfaces:
    Index Interface Monitored-Status Internal-SA
    0 fxp1 Down Disabled

    Fabric link status: Down

    Fabric interfaces:
    Name Child-interface Status
    (Physical/Monitored)
    fab1
    fab1

    Redundant-pseudo-interface Information:
    Name Status Redundancy-group
    lo0 Up 0

    {primary:node1}
    root>





    ====================== Cluster statistics:
    Device A
    root@DeviceA> show chassis cluster statistics
    Control link statistics:
    Control link 0:
    Heartbeat packets sent: 373
    Heartbeat packets received: 0
    Heartbeat packet errors: 0
    Fabric link statistics:
    Child link 0
    Probes sent: 487
    Probes received: 0
    Child link 1
    Probes sent: 0
    Probes received: 0

    Device B:
    root> show chassis cluster statistics
    Control link statistics:
    Control link 0:
    Heartbeat packets sent: 3763
    Heartbeat packets received: 0
    Heartbeat packet errors: 0
    Fabric link statistics:
    Child link 0
    Probes sent: 0
    Probes received: 0
    Child link 1
    Probes sent: 0
    Probes received: 0




  • 2.  RE: SRX550 cluster could not be established

    Posted 08-09-2022 09:37
    Hi,

    Are u sure you follow the guide? First connect the Control Link (direct connect)...Make sure control link is up. ..Then do command set chassis cluster cluster-id 1 node x reboot on both node manually. Then both will be reboot and form cluster.


    After it form cluster then u ca continue configure fabric link (direct connect). So finish simple as that.


  • 3.  RE: SRX550 cluster could not be established

    Posted 08-19-2022 06:18
    Hi,
    thanks for the answer but unfortunately it doesn't help.
    I also tried to install other software (junos-srxsme-12.3X48-D65.1-domestic.tgz) and that doesn't help either.
    Anyone have any idea?
    Thank you in advance.


  • 4.  RE: SRX550 cluster could not be established

    Posted 08-19-2022 06:39
    Hi,


    First make sure your control link is up. If not up then check your SFP and cable. If u confirm control link is up but cluster not establish then u look like miss step.


    Thanks


  • 5.  RE: SRX550 cluster could not be established

    Posted 08-22-2022 13:46
    Checked my SRX550 cluster, and the only thing I see missing from your config here is the set chassis cluster control-link-recovery statement.  
    I assume you have link on both the control and fab ports.  

    Run this command to check the control plane.  Should look like this.

    SRX550-0> show chassis cluster control-plane statistics
    Control link statistics:
    Control link 0:
    Heartbeat packets sent: 25859109
    Heartbeat packets received: 25864676
    Heartbeat packet errors: 0
    Fabric link statistics:
    Child link 0
    Probes sent: 51792110
    Probes received: 51791421
    Child link 1
    Probes sent: 0
    Probes received: 0




  • 6.  RE: SRX550 cluster could not be established

    Posted 08-31-2022 07:20
    Edited by 4m8 08-31-2022 07:58
    Hi,
    thank you for checks.
    I tried again and again and finally I have established cluster but something is still wrong.
    Only one thing I changed - delete configuration 0/0/2 interface on both devices before start cluster setup.
    After that, cluster still not stablished but next day I noticed that cluster is established...

    So, current status is:
    cluster is established but after every reboot, node1 have a 'lost' status and I have to wait about 1 hour to see node1 with a 'secondary' status.

    after reboot:
    Cluster ID: 1
    Node Priority Status Preempt Manual Monitor-failures

    Redundancy group: 0 , Failover count: 1
    node0 100 primary no no None
    node1 0 lost n/a n/a n/a

    Redundancy group: 1 , Failover count: 1
    node0 0 primary no no None
    node1 0 lost n/a n/a n/a

    1 hour later:
    Cluster ID: 1
    Node Priority Status Preempt Manual Monitor-failures

    Redundancy group: 0 , Failover count: 1
    node0 100 primary no no None
    node1 0 secondary no no CF

    Redundancy group: 1 , Failover count: 1
    node0 100 primary no no None
    node1 0 secondary no no CF


    It's very weird  for me.
    I'll be grateful for every suggesstion what may be wrong.




  • 7.  RE: SRX550 cluster could not be established

    Posted 08-31-2022 09:02
    OK I just found the solution :)
    after add this command, cluster establish immediately after reboot:

    set chassis cluster redundancy-group 1 preempt