View Only
last person joined: 4 days ago 

Ask questions and share experiences about the SRX Series, vSRX, and cSRX.
  • 1.  SRX340 and SRX-MP-1SFP-GE

    Posted 01-25-2017 09:20



    Is the SRX-MP-1SFP-GE compatible with the SRX340?  I've been trying one but am getting some very strange issues, the SRX sees the module and identifies it correctly (as a 1xGE High Perf SFP mPIM) but I've been having issues with other copper interfaces and other SFPs in the chassis once it is added to the system.






  • 2.  RE: SRX340 and SRX-MP-1SFP-GE
    Best Answer

    Posted 01-25-2017 10:43

    Hi benj5,


    Cannot find anything conclusive but I would not expect it to be supported when looking at the following:


    1. SRX-MP-1SFP-GE is only listed as an accessory for SRX550 and SRX650 in the official price list.

    2. Not able to add a SRX-MP-1SFP-GE mPIM module to a SRX340 in the official Juniper configuration tool. On the VDSL, serial or the T1/E1 module.

    3. SRX-MP-1SFP-GE is not mentioned in the SRX300 series datasheet.


    and as the last thought: Why at all use the SFP mPIM on a SRX340 which has 8 built-in SFP ports?


    My guess is that the support was not properly removed from the Junos codebase and never tested what would happen if a module was inserted.


    Best suggestion: Use one of the built-in ports instead 🙂


  • 3.  RE: SRX340 and SRX-MP-1SFP-GE

    Posted 01-25-2017 12:58
    Same with me - I tried to use this MPIM, just as an experiment. At first it was working (show chassis hardware and show interfaces), but after that flowd and chassisd started core-dumping repeatedly, causing the whole box to become unresponsive. Removed the MPIM and everything went back to normal.
    So the jonashauge's guess is very exact - the codebase hasn't been tested with this module (as it is officially unsupported)

  • 4.  RE: SRX340 and SRX-MP-1SFP-GE

    Posted 01-26-2017 02:03

    Thanks for the replies. I'd seen the SRX300 didn't actually list the module (but only after I'd tried it) but as you say couldn't actually find anything definitive about support for it.  It would have been nice if the firewall would have rejected it instead of recognising and causing a load of issues!


    Anyway yes I'm switching to the built in port.  We were only looking to continute using the mPIM for historic / cable labelling / paperwork reasons.