SRX

 View Only
last person joined: 20 hours ago 

Ask questions and share experiences about the SRX Series, vSRX, and cSRX.
  • 1.  SRX300 - PPPoE - pp0 over trunk with irb interfaces

    Posted 10-29-2023 08:57

    Hi

    I want to configure physical interface ge-0/0/5 (and ge-0/0/4 in the future) as a "interface-mode" trunk under irb interface because I need to underlaying-interface for pp0.

    interfaces {
        ge-0/0/1 {
            unit 0 {
                family ethernet-switching {
                    interface-mode access;
                    vlan {
                        members vlan35;
                    }
                }
            }
        }
        ge-0/0/5 {
            unit 0 {
                family ethernet-switching {
                    interface-mode trunk;
                    vlan {
                        members [ vlan35 vlan838 vlan839 ];
                    }
                }
            }
        }
        irb {
            unit 35 {
                family inet {
                    address 172.26.1.254/24;
                }
            }
            unit 100 {
                encapsulation ppp-over-ether;
            }
        }
        pp0 {
            traceoptions {
                flag all;
            }
            unit 0 {
                ppp-options {
                    pap {
                        local-name ## SECRET-DATA
                        local-password ## SECRET-DATA
                        passive;
                    }
                }
                pppoe-options {
                    underlying-interface irb.100;
                    idle-timeout 0;
                    auto-reconnect 10;
                    client;
                }
                family inet {
                    mtu 1492;
                    negotiate-address;
                }
            }
        }
    }
    
    vlans {
        V100 {
            vlan-id-list [ 35 838 839 ];
            interface irb.100;
        }
        vlan35 {
            vlan-id 35;
            l3-interface irb.35;
        }
        vlan838 {
            vlan-id 838;
        }
        vlan839 {
            vlan-id 839;
        }
    }
    protocols {
        l2-learning {
            global-mode switching;
        }
        rstp {
            interface all;
        }
    }
    

    After commit I'm receiving:

    'vlan3'

    l2ald: Duplicate vlan-id exist for vlan V100-vlan-0035



    ------------------------------
    Best regards
    Marek
    ------------------------------



  • 2.  RE: SRX300 - PPPoE - pp0 over trunk with irb interfaces

    Posted 11-14-2023 06:26

    Hi

    I have found in the kb

    On SRX300  on the IRB interface, the following features are not supported:

    -Encapsulations (Ether CCC, VLAN CCC, VPLS, PPPoE, and so on) on VLAN interfaces

    ==========================================================================

    interfaces {
        ge-0/0/1 {
            unit 0 {
                family inet {
                    address 172.26.1.254/24;
                }
            }
        }
        ge-0/0/5 {
            traceoptions {
                flag all;
            }
            vlan-tagging;
            unit 35 {
                encapsulation ppp-over-ether;
                vlan-id 35;
            }
        }
        pp0 {
            unit 35 {
                ppp-options {
                    pap {
                        local-name  ## SECRET-DATA
                        local-password  ## SECRET-DATA
                        passive;
                    }
                }
                pppoe-options {
                    underlying-interface ge-0/0/5.35;
                    idle-timeout 0;
                    auto-reconnect 10;
                    client;
                }
                keepalives;
                family inet {
                    mtu 1492;
                    negotiate-address;
                }
            }
        }
    }
    routing-options {
        static {
            route 0.0.0.0/0 {
                next-hop pp0.35;
                metric 0;
            }
        }
    }

    My configuration is  working  but every 7 minute srx send PADT Termination signal. Here is log. I don't know why ???

    Nov 14 00:58:15 pppoed_ifl_msg_handler pp0.35 ifl 81 op 2 flag 0xc018
    Nov 14 00:58:15 In Parse TLV: opts 0x0 0xa ge-0/0/5.35 (null) (null)
    Nov 14 00:58:15 pppoed_change_ifl_options: ifname pp0.35
    Nov 14 00:58:15 pppoed_change_ifl_options: pp0.35 session mode client 
    Nov 14 00:58:15 pppoed_change_ifl_options: pp0.35 session up, kernsync false
    Nov 14 00:58:15 pppoed_change_ifl_options: pp0.35 session id=4134 (current 4134)
    Nov 14 00:58:15 pppoed_change_ifl_options: pp0.35 credit scale 0 max 65535 ppp max payload 1492
    Nov 14 00:58:15 pppoed_change_ifl_options: pp0.35 credits disabled, interval 0, scale 0
    Nov 14 00:58:15 pppoed_change_ifl_options: pp0.35 credit interval set to 0
    Nov 14 00:58:15 pppoed_change_ifl_options: pp0.35 session id=4134
    Nov 14 00:58:15 pppoed_change_ifl: ifname pp0.35
    Nov 14 00:58:15 Bringing session down for pp0.35
    Nov 14 00:58:15 Sent PADT on pp0.35
    Nov 14 00:58:15 pppoe_ifl_params_change: ifl pp0.35, ifl sid 4134, param sid 4134
    Nov 14 00:58:15 pppoed_ifl_msg_handler pp0.35 ifl 81 op 2 flag 0xc018
    Nov 14 00:58:15 In Parse TLV: opts 0x0 0xa ge-0/0/5.35 (null) (null)
    Nov 14 00:58:15 pppoed_change_ifl_options: ifname pp0.35
    Nov 14 00:58:15 pppoed_change_ifl_options: pp0.35 session mode client 
    Nov 14 00:58:15 pppoed_change_ifl_options: pp0.35 session down, kernsync false
    Nov 14 00:58:15 pppoed_change_ifl_options: pp0.35 session id=0 (current 0)
    Nov 14 00:58:15 pppoed_change_ifl_options: pp0.35 credit scale 0 max 65535 ppp max payload 1492
    Nov 14 00:58:15 pppoed_change_ifl_options: pp0.35 credits disabled, interval 0, scale 0
    Nov 14 00:58:15 pppoed_change_ifl_options: pp0.35 credit interval set to 0
    Nov 14 00:58:15 pppoed_change_ifl_options: pp0.35 session id=0
    Nov 14 00:58:15 pppoed_change_ifl: ifname pp0.35
    Nov 14 00:58:18 pppoed_ifl_msg_handler pp0.35 ifl 81 op 2 flag 0xc011
    Nov 14 00:58:18 In Parse TLV: opts 0x0 0xa ge-0/0/5.35 (null) (null)
    Nov 14 00:58:18 pppoed_change_ifl_options: ifname pp0.35
    Nov 14 00:58:18 pppoed_change_ifl_options: pp0.35 session mode client 
    Nov 14 00:58:18 pppoed_change_ifl_options: pp0.35 session down, kernsync false
    Nov 14 00:58:18 pppoed_change_ifl_options: pp0.35 session id=0 (current 0)
    Nov 14 00:58:18 pppoed_change_ifl_options: pp0.35 credit scale 0 max 65535 ppp max payload 1492
    Nov 14 00:58:18 pppoed_change_ifl_options: pp0.35 credits disabled, interval 0, scale 0
    Nov 14 00:58:18 pppoed_change_ifl_options: pp0.35 credit interval set to 0
    Nov 14 00:58:18 pppoed_change_ifl_options: pp0.35 session id=0
    Nov 14 00:58:18 pppoed_change_ifl: ifname pp0.35
    Nov 14 00:58:18 pppoed_ifl_msg_handler pp0.35 ifl 81 op 2 flag 0xc011
    Nov 14 00:58:18 In Parse TLV: opts 0x0 0xa ge-0/0/5.35 (null) (null)
    Nov 14 00:58:18 pppoed_change_ifl_options: ifname pp0.35
    Nov 14 00:58:18 pppoed_change_ifl_options: pp0.35 session mode client 
    Nov 14 00:58:18 pppoed_change_ifl_options: pp0.35 session down, kernsync false
    Nov 14 00:58:18 pppoed_change_ifl_options: pp0.35 session id=0 (current 0)
    Nov 14 00:58:18 pppoed_change_ifl_options: pp0.35 credit scale 0 max 65535 ppp max payload 1492
    Nov 14 00:58:18 pppoed_change_ifl_options: pp0.35 credits disabled, interval 0, scale 0
    Nov 14 00:58:18 pppoed_change_ifl_options: pp0.35 credit interval set to 0
    Nov 14 00:58:18 pppoed_change_ifl_options: pp0.35 session id=0
    Nov 14 00:58:18 pppoed_change_ifl: ifname pp0.35
    Nov 14 00:58:31 ***Discovery Init: pp0.35
    Nov 14 00:58:31 allocated 1510 bytes at 0x4b5000
    Nov 14 00:58:31 *totlen=0x6 tp->len=0x2 ntohs(tplen)=0x2 tot=0x6 MAX_L=0x1502
    Nov 14 00:58:31 *totlen=0xa tp->len=0x0 ntohs(tplen)=0x0 tot=0xa MAX_L=0x1502
    Nov 14 00:58:31 *totlen=0xe tp->len=0x0 ntohs(tplen)=0x0 tot=0xe MAX_L=0x1502
    Nov 14 00:58:31 IO send ... PADI for pp0.35
    Nov 14 00:58:32 Discovery Input: PADO packet received on uifl (idx 80)
    Nov 14 00:58:32 Received AC name kra_bng4_re0 configured AC name  on uifl (idx 80)
    Nov 14 00:58:32 code: 7 outlen=0x22 pt->len: 0xc
    Nov 14 00:58:32 *totlen=0x32 tp->len=0xc ntohs(tplen)=0xc tot=0x32 MAX_L=0x1502
    Nov 14 00:58:32 code: 7 outlen=0x32 pt->len: 0x10
    Nov 14 00:58:32 *totlen=0x46 tp->len=0x10 ntohs(tplen)=0x10 tot=0x46 MAX_L=0x1502
    Nov 14 00:58:32 *totlen=0x4a tp->len=0x0 ntohs(tplen)=0x0 tot=0x4a MAX_L=0x1502
    Nov 14 00:58:32 IO send ... PADR for pp0.35
    Nov 14 00:58:32 Discovery Input: PADO packet received on uifl (idx 80)
    Nov 14 00:58:32 Discovery Input: PADS packet received on uifl (idx 80)
    Nov 14 00:58:32 pppoed_client_discovery_input: params.remote_mac=d0:07:ca:86:cf:c3 params.confirmed_mtu=0
    Nov 14 00:58:32 pppoe_ifl_params_change: ifl pp0.35, ifl sid 6085, param sid 6085
    Nov 14 00:58:32 pppoed_ifl_msg_handler pp0.35 ifl 81 op 2 flag 0xc011
    Nov 14 00:58:32 pppoed_change_ifl: ifname pp0.35
    Nov 14 00:58:32 pppoed_ifl_msg_handler pp0.35 ifl 81 op 2 flag 0xc011
    Nov 14 00:58:32 In Parse TLV: opts 0x0 0xa ge-0/0/5.35 (null) (null)
    Nov 14 00:58:32 pppoed_change_ifl_options: ifname pp0.35
    Nov 14 00:58:32 pppoed_change_ifl_options: pp0.35 session mode client 
    Nov 14 00:58:32 pppoed_change_ifl_options: pp0.35 session up, kernsync false
    Nov 14 00:58:32 pppoed_change_ifl_options: pp0.35 session id=6085 (current 6085)
    Nov 14 00:58:32 pppoed_change_ifl_options: pp0.35 credit scale 0 max 65535 ppp max payload 1492
    Nov 14 00:58:32 pppoed_change_ifl_options: pp0.35 credits disabled, interval 0, scale 0
    Nov 14 00:58:32 pppoed_change_ifl_options: pp0.35 credit interval set to 0
    Nov 14 00:58:32 pppoed_change_ifl_options: pp0.35 session id=6085
    Nov 14 00:58:32 pppoed_change_ifl: ifname pp0.35
    Nov 14 00:58:32 pppoed_ifl_msg_handler pp0.35 ifl 81 op 2 flag 0xc011
    Nov 14 00:58:32 In Parse TLV: opts 0x0 0xa ge-0/0/5.35 (null) (null)
    Nov 14 00:58:32 pppoed_change_ifl_options: ifname pp0.35
    Nov 14 00:58:32 pppoed_change_ifl_options: pp0.35 session mode client 
    Nov 14 00:58:32 pppoed_change_ifl_options: pp0.35 session up, kernsync false
    Nov 14 00:58:32 pppoed_change_ifl_options: pp0.35 session id=6085 (current 6085)
    Nov 14 00:58:32 pppoed_change_ifl_options: pp0.35 credit scale 0 max 65535 ppp max payload 1492
    Nov 14 00:58:32 pppoed_change_ifl_options: pp0.35 credits disabled, interval 0, scale 0
    Nov 14 00:58:32 pppoed_change_ifl_options: pp0.35 credit interval set to 0
    Nov 14 00:58:32 pppoed_change_ifl_options: pp0.35 session id=6085
    Nov 14 00:58:32 pppoed_change_ifl: ifname pp0.35
    Nov 14 00:58:32 pppoed_ifl_msg_handler pp0.35 ifl 81 op 2 flag 0xc010
    Nov 14 00:58:32 In Parse TLV: opts 0x0 0xa ge-0/0/5.35 (null) (null)
    Nov 14 00:58:32 pppoed_change_ifl_options: ifname pp0.35
    Nov 14 00:58:32 pppoed_change_ifl_options: pp0.35 session mode client 
    Nov 14 00:58:32 pppoed_change_ifl_options: pp0.35 session up, kernsync false
    Nov 14 00:58:32 pppoed_change_ifl_options: pp0.35 session id=6085 (current 6085)
    Nov 14 00:58:32 pppoed_change_ifl_options: pp0.35 credit scale 0 max 65535 ppp max payload 1492
    Nov 14 00:58:32 pppoed_change_ifl_options: pp0.35 credits disabled, interval 0, scale 0
    Nov 14 00:58:32 pppoed_change_ifl_options: pp0.35 credit interval set to 0
    Nov 14 00:58:32 pppoed_change_ifl_options: pp0.35 session id=6085
    Nov 14 00:58:32 pppoed_change_ifl: ifname pp0.35
    Nov 14 00:58:41 Discovery Input: PADO packet received on uifl (idx 80)
    Nov 14 00:58:41 Discovery Input: PADO packet received on uifl (idx 80)
    

    Do you have any idea ? 

    Best regards Marek



    ------------------------------
    Best regards
    Marek
    ------------------------------



  • 3.  RE: SRX300 - PPPoE - pp0 over trunk with irb interfaces

    Posted 12-09-2023 16:39

    Solved :)



    ------------------------------
    Best regards
    Marek
    ------------------------------