SRX

 View Only
last person joined: 5 days ago 

Ask questions and share experiences about the SRX Series, vSRX, and cSRX.
  • 1.  srx300 ENDS UP IN cpu:0-Trap cause = 3 (TLB miss (store) - kernel mode) AFTER REBOOT

    Posted 06-09-2023 15:08

    Hi All,

    My SRX300 all the time goes in Panic.  unable to get CLI or SHELL command mode.

    below is log details.

    loader> reboot
    Resetting...

    SPI stage 1 bootloader (Build time: May  3 2016 - 23:48:30)
    early_board_init: Board type: SRX_300

    U-Boot 2013.07-JNPR-3.1 (Build time: May 03 2016 - 23:48:31)

    SRX_300 board revision major:1, minor:12, serial #: CV2918AF0150
    OCTEON CN7020-AAP pass 1.2, Core clock: 1200 MHz, IO clock: 600 MHz, DDR clock: 667 MHz (1334 Mhz DDR)
    Base DRAM address used by u-boot: 0x10fc00000, size: 0x400000
    DRAM: 4 GiB
    Clearing DRAM...... done
    Using default environment

    SF: Detected MX25L6405D with page size 256 Bytes, erase size 64 KiB, total 8 MiB
    Found valid SPI bootloader at offset: 0x90000, size: 1481840 bytes


    U-Boot 2013.07-JNPR-3.1 (Build time: May 03 2016 - 23:50:19)

    Using DRAM size from environment: 4096 MBytes
    checkboard siege
    SATA0: not available
    SATA1: not available
    SATA BIST STATUS = 0x0
    SRX_300 board revision major:1, minor:12, serial #: CV2918AF0150
    OCTEON CN7020-AAP pass 1.2, Core clock: 1200 MHz, IO clock: 600 MHz, DDR clock: 667 MHz (1334 Mhz DDR)
    Base DRAM address used by u-boot: 0x10f000000, size: 0x1000000
    DRAM: 4 GiB
    Clearing DRAM...... done
    SF: Detected MX25L6405D with page size 256 Bytes, erase size 64 KiB, total 8 MiB
    PCIe: Port 0 link active, 1 lanes, speed gen2
    PCIe: Link timeout on port 1, probably the slot is empty
    PCIe: Port 2 not in PCIe mode, skipping
    Net:   octeth0
    Interface 0 has 1 ports (SGMII)
    Type the command 'usb start' to scan for USB storage devices.

    Boot Media: eUSB usb
    Found TPM SLB9660 TT 1.2 by Infineon
    TPM initialized
    Hit any key to stop autoboot:  0
    SF: Detected MX25L6405D with page size 256 Bytes, erase size 64 KiB, total 8 MiB
    SF: 1048576 bytes @ 0x200000 Read: OK
    ## Starting application at 0x8f0000a0 ...
    Consoles: U-Boot console
    Found compatible API, ver. 3.1
    USB1:
    Starting the controller
    USB XHCI 1.00
    scanning bus 1 for devices... 2 USB Device(s) found
    USB0:
    Starting the controller
    USB XHCI 1.00
    scanning bus 0 for devices... 1 USB Device(s) found
           scanning usb for storage devices... 1 Storage Device(s) found

    FreeBSD/MIPS U-Boot bootstrap loader, Revision 2.11
    (builder@monarth, Sun Jul 26 18:59:02 PDT 2020)
    Memory: 4096MB
    SF: Detected MX25L6405D with page size 256 Bytes, erase size 64 KiB, total 8 MiB
    [12]Booting from eUSB slice 2
    Loading /boot/defaults/loader.conf
    /kernel data=0xb817f4+0x151638 syms=[0x4+0x9de30+0x4+0xeb463]


    Hit [Enter] to boot immediately, or space bar for command prompt.
    Booting [/kernel]...
    Kernel entry at 0x801000c0 ...
    init regular console
    Primary ICache: Sets 16 Size 128 Asso 39
    Primary DCache: Sets 8 Size 128 Asso 32
    Secondary DCache: Sets 1024 Size 128 Asso 4
    CIU_FUSE 0x3/0x3
    GDB: debug ports: uart
    GDB: current port: uart
    KDB: debugger backends: ddb gdb
    KDB: current backend: ddb
    kld_map_v: 0x8ff80000, kld_map_p: 0x0
    Running in PARTITIONED TLB MODE
    Copyright (c) 1996-2016, Juniper Networks, Inc.
    All rights reserved.
    Copyright (c) 1992-2007 The FreeBSD Project.
    Copyright (c) 1979, 1980, 1983, 1986, 1988, 1989, 1991, 1992, 1993, 1994
            The Regents of the University of California. All rights reserved.
    FreeBSD is a registered trademark of The FreeBSD Foundation.
    JUNOS 15.1X49-D60.7 #0: 2016-09-13 22:27:47 UTC
        builder@svl-junos-p003:/volume/build/junos/15.1/service/15.1X49-D60.7/obj/octeon/junos/bsd/kernels/JSRXNLE/kernel
    can't re-use a leaf (debug)!
    JUNOS 15.1X49-D60.7 #0: 2016-09-13 22:27:47 UTC
        builder@svl-junos-p003:/volume/build/junos/15.1/service/15.1X49-D60.7/obj/octeon/junos/bsd/kernels/JSRXNLE/kernel
    real memory  = 4294967296 (4194304K bytes)
    avail memory = 2621882368 (2500MB)
    FreeBSD/SMP: Multiprocessor System Detected: 2 CPUs
    Security policy loaded: JUNOS MAC/runasnonroot (mac_runasnonroot)
    Security policy loaded: Junos MAC/veriexec (mac_veriexec)
    Security policy loaded: JUNOS MAC/pcap (mac_pcap)
    MAC/veriexec fingerprint module loaded: SHA256
    MAC/veriexec fingerprint module loaded: SHA1
    netisr_init: !debug_mpsafenet, forcing maxthreads from 2 to 1
    cpu0 on motherboard
    : CAVIUM's OCTEON 70XX/71XX CPU Rev. 0.2 with no FPU implemented
            L1 Cache: I size 78kb(128 line), D size 32kb(128 line), thirty two way.
            L2 Cache: Size 512kb, 4 way
    obio0 on motherboard
    uart0: <Octeon-16550 channel 0> on obio0
    uart0: console (9600,n,8,1)
    twsi0 on obio0
    set clock 0x58
    xhci0: <Cavium Octeon 7xxx xHCI Host Driver> on obio0
    usb0: <USB bus for xHCI Controller> on xhci0
    usb0: USB revision 3.0
    uhub0: vendor 0x0000 XHCI root hub, class 9/0, rev 3.00/1.00, addr 1
    uhub0: 2 ports with 2 removable, self powered
    xhci1: <Cavium Octeon 7xxx xHCI Host Driver> on obio0
    usb1: <USB bus for xHCI Controller> on xhci1
    usb1: USB revision 3.0
    uhub1: vendor 0x0000 XHCI root hub, class 9/0, rev 3.00/1.00, addr 1
    uhub1: 2 ports with 2 removable, self powered
    cpld0 on obio0
    pcib0: <Cavium on-chip PCIe HOST bridge> on obio0
    Disabling Octeon big bar support
    pcib0: Initialized controller
    pci0: <PCI bus> on pcib0
    pci0: <network, ethernet> at device 0.0 (no driver attached)
    pci0: <network, ethernet> at device 0.1 (no driver attached)
    gblmem0 on obio0
    octpkt0: <Octeon RGMII> on obio0
    cfi0: <Macronix MX25L64 - 8MB> on obio0
    cfi1: <Macronix MX25L64 - 8MB> on obio0
    umass0: ATP Electronics ATP CG eUSB, rev 2.00/11.00, addr 2
    Timecounter "mips" frequency 1200000000 Hz quality 0
    Registered AMT tunnel Encap with UDP Tunnel!
     Loading Redundant LT driver
    ###PCB Group initialized for udppcbgroup
    ###PCB Group initialized for tcppcbgroup
    Kernel thread "wkupdaemon" (pid 47) exited prematurely.
    da0 at umass-sim0 bus 0 target 0 lun 0
    da0: <ATP ATP CG eUSB 1100> Fixed Direct Access SCSI-4 device
    da0: 40.000MB/s transfers
    da0: 7672MB (15712256 512 byte sectors: 255H 63S/T 978C)
    Trying to mount root from ufs:/dev/da0s2a
    WARNING: / was not properly dismounted
    MFSINIT: Initialising MFSROOT
    WARNING: / was not properly dismounted
    Ignoring watchdog timeout during boot/reboot
    Ignoring watchdog timeout during boot/reboot
    xhci_process_cmd_event+0x124 (0xc6e3d400,0xc6ee6020,0x28901902,0x13c0301) ra 0x801891bc sz 64
    xhci_scan_ring_event+0xd8 (0xc6e3d400,0xc6ee6020,0x28901902,0x13c0301) ra 0x80189b40 sz 64
    xhci_intr+0x2a0 (0xc6e3d400,0xc6ee6020,0x28901902,0x13c0301) ra 0x8077771c sz 32
    mips_handle_this_interrupt+0x8c (0xc6e3d400,0xc6ee6020,0x28901902,0x13c0301) ra 0x807777a8 sz 40
    mips_handle_interrupts+0x58 (0xc6e3d400,0xc6ee6020,0x28901902,0x13c0301) ra 0x80777bcc sz 48
    mips_interrupt+0x224 (0xc6e3d400,0xc6ee6020,0x28901902,0x13c0301) ra 0x80a58214 sz 32
    MipsKernIntr+0x140 (0x80b20000,0x80d9ffe0,0xffff8010,0x7d) ra 0x8077562c sz 368
    cpu_idle+0x10 (0x80b20000,0x80d9ffe0,0xffff8010,0x7d) ra 0x801e6054 sz 24
    idle_proc+0x118 (0x80b20000,0x80d9ffe0,0xffff8010,0x7d) ra 0x801e47c8 sz 40
    fork_exit+0x230 (0x80b20000,0x80d9ffe0,0xffff8010,0x7d) ra 0x80a58ea0 sz 40
    MipsNMIException+0x34 (0x80b20000,0x80d9ffe0,0xffff8010,0x7d) ra 0 sz 0
    pid 21, process: idle: cpu0
    cpu:0-Trap cause = 3 (TLB miss (store) - kernel mode)
    badvaddr = 0x1010, pc = 0x80187fd4, ra = 0x801891bc, sr = 0x508008a3
    [thread pid 21 tid 100009 ]
    Stopped at      xhci_process_cmd_event+0x124:   sw      zero,16(s0)
    db>

    Appreciate your help on this.



    ------------------------------
    PRACHI GADEKAR
    ------------------------------


  • 2.  RE: srx300 ENDS UP IN cpu:0-Trap cause = 3 (TLB miss (store) - kernel mode) AFTER REBOOT

    Posted 06-10-2023 05:58
    Edited by spuluka 06-10-2023 05:58

    The Junos installation is corrupt or there is a hardware issue.  You can attempt to get a fresh install of Junos if you can get to a loader prompt using this.

    https://www.juniper.net/documentation/software/junos-security/junos-security10.2/junos-security-admin-guide/topic-installing-software-boot-loader-usb.html

    If you are having trouble getting a clean loader prompt more options are listed in this kb.

    https://www.juniper.net/documentation/software/junos-security/junos-security10.2/junos-security-admin-guide/section-srx-series-tftp-loader.html#topic-accessing-uboot-prompt



    ------------------------------
    Steve Puluka BSEET - Juniper Ambassador
    IP Architect - DQE Communications Pittsburgh, PA (Metro Ethernet & ISP - Retired)
    http://puluka.com/home
    ------------------------------



  • 3.  RE: srx300 ENDS UP IN cpu:0-Trap cause = 3 (TLB miss (store) - kernel mode) AFTER REBOOT

    Posted 06-15-2023 14:36

    Hi Steve,

    I really appreciate your prompt response and detail procedure to install Junos.

    From the log, I was able to see, Junos-srxsme-15.1X49-D60.7-domestic.tgz is there on device and hence I tried to use same package to install using USB and TFTP server.

    Every time, SRX 300 starts installation and get stuck at below line. and then device goes to db> prompt.

    cpu:0-Trap cause = 3 (TLB miss (store) - kernel mode)

    none of the time, installation finishes completely. Is any other release need to try e.g.19.1? 

    One more observation is that when device boots from eUSB slice 2 , it gets kernel and ends up with same error cpu:0..., but if boots from other slice such as 1,3,4, device gives message can't load /Kernel.

    i welcome all experts on this community for suggestion to fix the issue.



    ------------------------------
    PRACHI GADEKAR
    ------------------------------