vMX

 View Only
last person joined: one month ago 

Ask questions and share experiences about vMX.
  • 1.  GNS3: BGP established, was exchanging routes with vMX but not to vCisco3725

    Posted 09-01-2022 08:44

    Hi I have established BGP session between two routers, in this lab the 

    I am having an issue getting my Juniper vMX to advertise routes between another vMX and a Cisco.  I was wondering if anyone could take a look and see what may or may not be missing, it's a very straight forward BGP configuration. The BGP sessions are established, but the routes ( which I have not created a policy permit/reject ) assuming implicit permit is in place.  

    I was exchanging routes between the two Junipers but I just lost this behavior somehow

    Junos vMX 1:  AS25540 , 10.1.1.100 is Local-AS behind this router.  Link to Cisco: 192.0.0.0/24  Link to Juniper 192.1.1.0/24

    config:

    root@vMX1# show | display set 
    set version 20.4R3.8
    set system host-name vMX1
    set system root-authentication encrypted-password "$6$Rmx5FGhj$uG8WRXgG8eu6zRd/90anr2vTWKjlsZ5.j7y7MUEPu0w8I36s7pLZXqVWUHRTk0pzzQJzkedn9yD/Wt5LJvvpk0"
    set system syslog file messages any notice
    set system syslog file messages authorization info
    set system syslog file interactive-commands interactive-commands any
    set system processes dhcp-service traceoptions file dhcp_logfile
    set system processes dhcp-service traceoptions file size 10m
    set system processes dhcp-service traceoptions level all
    set system processes dhcp-service traceoptions flag packet
    set interfaces ge-0/0/0 unit 0 family inet address 192.0.0.1/24
    set interfaces ge-0/0/1 unit 0 family inet address 10.1.1.1/24
    set interfaces ge-0/0/6 unit 0 family inet address 192.1.1.2/24
    set interfaces fxp0 unit 0 family inet dhcp vendor-id Juniper-vmx-VM63077605C5
    set interfaces fxp0 unit 0 family inet6 dhcpv6-client client-type stateful
    set interfaces fxp0 unit 0 family inet6 dhcpv6-client client-ia-type ia-na
    set interfaces fxp0 unit 0 family inet6 dhcpv6-client client-identifier duid-type duid-ll
    set interfaces fxp0 unit 0 family inet6 dhcpv6-client vendor-id Juniper:vmx:VM63077605C5
    set policy-options policy-statement BGP0 term 1 from protocol bgp
    set policy-options policy-statement BGP0 term 1 then accept
    set policy-options policy-statement BGP1 term 1 from protocol bgp
    set policy-options policy-statement BGP1 term 1 then accept
    set policy-options policy-statement BGP1 then accept
    set policy-options policy-statement BGP2 term 1 from protocol bgp
    set policy-options policy-statement BGP2 term 1 then accept
    set routing-options autonomous-system 25540
    set protocols router-advertisement interface fxp0.0
    set protocols bgp family inet unicast loops 2
    set protocols bgp group BGP1 type external
    set protocols bgp group BGP1 import BGP1
    set protocols bgp group BGP1 export BGP1
    set protocols bgp group BGP1 peer-as 5511
    set protocols bgp group BGP1 neighbor 192.0.0.100 peer-as 5511
    set protocols bgp group BGP0 type internal
    set protocols bgp group BGP0 export BGP0
    set protocols bgp group BGP0 peer-as 25540
    set protocols bgp group BGP0 neighbor 10.1.1.100 peer-as 25540
    set protocols bgp group BGP2 type external
    set protocols bgp group BGP2 export BGP2
    set protocols bgp group BGP2 peer-as 5512
    set protocols bgp group BGP2 neighbor 192.1.1.1 peer-as 5512
    set protocols bgp traceoptions file bgpflow
    set protocols bgp traceoptions flag update send
    set protocols bgp traceoptions flag update receive
    set protocols bgp multihop
    set protocols bgp accept-remote-nexthop
    set protocols bgp advertise-peer-as
    set protocols bgp advertise-bgp-static
    
    [edit]
    



       >show bgp sum

                      4          2          0          0          0          0
    
    Peer                     AS      InPkt     OutPkt    OutQ   Flaps Last Up/Dwn State|#Active/Received/Accepted/Damped...
    
    10.1.1.100            25540        187        207       0       0     1:32:21 Establ
    
      inet.0: 0/0/0/0
    
    192.0.0.100            5511        186        205       0       0     1:31:17 Establ
    
      inet.0: 0/1/1/0
    
    192.1.1.1              5512        237        235       0       0     1:44:29 Establ
    
      inet.0: 2/3/3/0


    > show route

    root# run show route 
    
    inet.0: 9 destinations, 10 routes (6 active, 0 holddown, 3 hidden)
    + = Active Route, - = Last Active, * = Both
    
    10.1.1.0/24        *[Direct/0] 02:50:26
                        >  via ge-0/0/1.0
    10.1.1.1/32        *[Local/0] 02:50:26
                           Local via ge-0/0/1.0
    10.3.3.3/32        *[BGP/170] 02:50:25, localpref 100
                          AS path: 5512 I, validation-state: unverified
                        >  to 192.1.1.1 via ge-0/0/6.0
    10.5.5.0/24        *[BGP/170] 02:49:20, localpref 100
                          AS path: 5512 I, validation-state: unverified
                        >  to 192.1.1.1 via ge-0/0/6.0
    192.1.1.0/24       *[Direct/0] 02:50:26
                        >  via ge-0/0/6.0
                        [BGP/170] 02:50:25, localpref 100
                          AS path: 5512 I, validation-state: unverified
                        >  to 192.1.1.1 via ge-0/0/6.0
    192.1.1.2/32       *[Local/0] 02:50:26
                           Local via ge-0/0/6.0
    
    inet6.0: 2 destinations, 2 routes (2 active, 0 holddown, 0 hidden)
    



    for some reason 192.0.0.0/24 is not in the routing table?

    Cisco AS511: 192.0.0.100

    5511#show ip bgp sum
    BGP router identifier 192.0.0.100, local AS number 5511
    BGP table version is 2, main routing table version 2
    1 network entries using 120 bytes of memory
    1 path entries using 52 bytes of memory
    2/1 BGP path/bestpath attribute entries using 248 bytes of memory
    0 BGP route-map cache entries using 0 bytes of memory
    0 BGP filter-list cache entries using 0 bytes of memory
    BGP using 420 total bytes of memory
    BGP activity 1/0 prefixes, 1/0 paths, scan interval 60 secs
    
    Neighbor        V    AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd
    10.1.1.100      4 25540       0       0        0    0    0 never    Active
    192.0.0.1       4 25540     392     352        2    0    0 02:38:56        0
    5511#
    


    show run | s bgp

    5511#show run | s bgp
    router bgp 5511
     bgp router-id 192.0.0.100
     bgp log-neighbor-changes
     neighbor 10.1.1.100 remote-as 25540
     neighbor 10.1.1.100 ebgp-multihop 2
     neighbor 192.0.0.1 remote-as 25540
     neighbor 192.0.0.1 ebgp-multihop 255
     !
     address-family ipv4
      redistribute connected
      neighbor 10.1.1.100 activate
      neighbor 192.0.0.1 activate
      neighbor 192.0.0.1 default-originate
      neighbor 192.0.0.1 route-map AS255400-IN in
      neighbor 192.0.0.1 route-map AS255400-IN out
      no auto-summary
      no synchronization
      network 192.0.0.0
     exit-address-family
    5511#
    



    Can anybody help with this simple lab or point out the error?  The full routing table is not being exchanged between the routers, a partial table is exchanged between the Junipers

    from the second Juniper vMX

    vMX2# run show route 
    
    inet.0: 9 destinations, 10 routes (6 active, 0 holddown, 3 hidden)
    + = Active Route, - = Last Active, * = Both
    
    10.1.1.0/24        *[Direct/0] 02:50:26
                        >  via ge-0/0/1.0
    10.1.1.1/32        *[Local/0] 02:50:26
                           Local via ge-0/0/1.0
    10.3.3.3/32        *[BGP/170] 02:50:25, localpref 100
                          AS path: 5512 I, validation-state: unverified
                        >  to 192.1.1.1 via ge-0/0/6.0
    10.5.5.0/24        *[BGP/170] 02:49:20, localpref 100
                          AS path: 5512 I, validation-state: unverified
                        >  to 192.1.1.1 via ge-0/0/6.0
    192.1.1.0/24       *[Direct/0] 02:50:26
                        >  via ge-0/0/6.0
                        [BGP/170] 02:50:25, localpref 100
                          AS path: 5512 I, validation-state: unverified
                        >  to 192.1.1.1 via ge-0/0/6.0
    192.1.1.2/32       *[Local/0] 02:50:26
                           Local via ge-0/0/6.0
    
    inet6.0: 2 destinations, 2 routes (2 active, 0 holddown, 0 hidden)
    + = Active Route, - = Last Active, * = Both
    
    fe80::e9f:4fff:fedf:0/128
                       *[Local/0] 02:51:14
                           Local via fxp0.0
    ff02::2/128        *[INET6/0] 02:51:14
                           MultiRecv
    
    [edit]
    vMX2# run ping 10.1.1.100 
    PING 10.1.1.100 (10.1.1.100): 56 data bytes
    64 bytes from 10.1.1.100: icmp_seq=0 ttl=64 time=1.601 ms
    64 bytes from 10.1.1.100: icmp_seq=1 ttl=64 time=1.175 ms
    ^C
    --- 10.1.1.100 ping statistics ---
    2 packets transmitted, 2 packets received, 0% packet loss
    round-trip min/avg/max/stddev = 1.175/1.388/1.601/0.213 ms
    
    
    
    vMX2> show bgp summary 
    Threading mode: BGP I/O
    Default eBGP mode: advertise - accept, receive - accept
    Groups: 1 Peers: 1 Down peers: 0
    Table          Tot Paths  Act Paths Suppressed    History Damp State    Pending
    inet.0               
                           0          0          0          0          0          0
    Peer                     AS      InPkt     OutPkt    OutQ   Flaps Last Up/Dwn State|#Active/Received/Accepted/Damped...
    192.1.1.2             25540        397        400       0       0     2:58:14 Establ
      inet.0: 0/0/0/0
    
    
    
    


    ------------------------------
    Christopher Gerard
    ------------------------------


  • 2.  RE: GNS3: BGP established, was exchanging routes with vMX but not to vCisco3725

    Posted 09-07-2022 10:32
    It's not clear where some of the output you posted is from since the router hostname isn't listed.

    But my guess:
    To advertise the 192.0.0.0/24 subnet on vMX1 to other BGP speakers, you'll need to change your policy. vMX1 will know 192..0.0.0/24 via protocol Direct, not BGP. So the current policy applied won't advertise to other BGP peers, since you're matching on "bgp", and that route isn't in the forwarding table from BGP - it's in the routing table learned from "Direct".

    ------------------------------
    BENJAMIN GAMBLE
    ------------------------------



  • 3.  RE: GNS3: BGP established, was exchanging routes with vMX but not to vCisco3725

    Posted 09-08-2022 02:24
    I got it working, then I blew it away. It was like you said, policy. and also policy from the FRR

    ------------------------------
    Christopher Gerard
    ------------------------------