Screen OS

 View Only
last person joined: 9 months ago 

This is a legacy community with limited Juniper monitoring.
  • 1.  Bridge Mode Connection problem

    Posted 04-23-2008 23:43

    Hi, 

     

    I am using 3 adsl lines on bridge mode. 1 adsl line is failed working on bridge mode. The line has connection I tested adsl router in router mode. It was working in bridge mode but it disconnected yesterday and not connecting again now. Every configuration is right but my ssg-5 don't connecting now.

     

     

    I have this log.

    Point-to-Point Protocol over Ethernet (PPPoE) connection failed to establish a session. Timeout PADI

     

     I use 5.4.0.r9. Why this disconnected when it is working? Thanks

     

    P.s.: Adsl Rouer is Zyxel 661 Hw. I am using this problems often in zyxel.

    Message Edited by Nevermore on 04-24-2008 12:33 AM

    #problem
    #bridge
    #connection
    #Mode


  • 2.  RE: Bridge Mode Connection problem

    Posted 04-24-2008 05:51

    I ordered  a new adsl router.

     

    Thanks



  • 3.  RE: Bridge Mode Connection problem

    Posted 04-28-2008 07:47

    Hi,

     

    Bridge Mode is working on my interface 0/5 now but  It is not working on 0/0 and 0/2 interfaces. What cause this problem? Is tehre a config left on these interfaces?

     

    Thanks 



  • 4.  RE: Bridge Mode Connection problem

    Posted 04-29-2008 08:03

    Can you clarify what you mean by "it's not working on eth0/0 and eth0/2"?
    What is your ultimate goal?

    Can you include this part of your config:
    get config | inc interface
    get config | inc adsl

    FYI: This is a good thread on bridge groups:
    http://forums.juniper.net/jnet/board/message?board.id=Firewalls&message.id=163&query.id=1355#M163

    --Josine

     



  • 5.  RE: Bridge Mode Connection problem

    Posted 04-29-2008 23:35

    Hi Josine,

     

    If I start the problem from the beginning:

     

    I have 3 adsl lines working on bridge mode. 1 line has disconnected (interface 0/2) suddenly and giving Timeout PADI error. I reset the interface settings to null and tried to reconnect to it again  and same PADI error I recieved. I changed to interface 0/0 and retried everything (Reseting zone to null) and same PADI error I recieved. Then I thought that it was caused the bridge router and baught a new one. When I tried to reconnect that the new adsl router on the bridge mode same things happened. Then I tried the port 0/5 which was I never used  before and it connected succesfully and working succesfull now. But if I connect to interfaces 0/0 and 0/2 on bridge mode I am recieving PADI error.  Here is the configs for you:

     

    set interface "ethernet0/0" zone "Null"

    set interface "ethernet0/1" zone "Untrust"

    set interface "ethernet0/4" zone "Untrust"

    set interface "ethernet0/5" zone "Untrust"

    set interface "bgroup0" zone "Trust"

    set interface "bgroup1" zone "DMZ"

    set interface "bgroup2" zone "Trust"

    set interface bgroup0 port ethernet0/3

    set interface bgroup1 port ethernet0/6

    unset interface vlan1 ip

    set interface ethernet0/1 ip 88.xx.xx.xx/32

    set interface ethernet0/1 route

    set interface ethernet0/4 ip 88.xx.xx.xx/32

    set interface ethernet0/4 route

    set interface ethernet0/5 ip 88.xx.xx.xx/32

    set interface ethernet0/5 route

    set interface bgroup0 ip 192.168.1.254/24

    set interface bgroup0 nat

    set interface bgroup1 ip 192.168.3.254/24

    set interface bgroup1 route

    unset interface vlan1 bypass-others-ipsec

    unset interface vlan1 bypass-non-ip

    set interface ethernet0/1 ip manageable

    set interface ethernet0/4 ip manageable

    set interface ethernet0/5 ip manageable

    set interface bgroup0 ip manageable

    set interface bgroup1 ip manageable

    set interface ethernet0/4 manage ssh

    set interface ethernet0/4 manage ssl

    set interface ethernet0/4 manage web

    set interface ethernet0/5 manage ssh

    set interface ethernet0/5 manage ssl

    set interface ethernet0/5 manage web

    unset interface bgroup0 manage telnet

    unset interface bgroup0 manage snmp

    unset interface bgroup0 manage web

    set interface bgroup0 manage mtrace

    unset interface bgroup2 manage ping

    unset interface bgroup2 manage ssh

    unset interface bgroup2 manage telnet

    unset interface bgroup2 manage snmp

    unset interface bgroup2 manage ssl

    unset interface bgroup2 manage web

    set interface bgroup2 dhcp client enable

    unset interface bgroup2 dhcp client settings update-dhcpserver

    set interface "ethernet0/4" mip 88.xx.xx.xxhost 192.168.1.1 netmask 255.255.255.255 vr "trust-vr"

    set interface "serial0/0" modem settings "USR" init "AT&F"

    set interface "serial0/0" modem settings "USR" active

    set interface "serial0/0" modem speed 115200

    set interface "serial0/0" modem retry 3

    set interface "serial0/0" modem interval 10

    set interface "serial0/0" modem idle-time 10

    set l2tp "Vpn2" id 2 outgoing-interface ethernet0/4 keepalive 60

    set pppoe name "eth0/0" interface ethernet0/4

    set pppoe name "isp3" interface ethernet0/5

    set pppoe name "isp2" interface ethernet0/1

    set route 192.168.3.0/24 interface bgroup1 preference 20

    set route 0.0.0.0/0 interface ethernet0/4

    set route 0.0.0.0/0 interface ethernet0/5 metric 2

    set route source 192.168.1.10/32 interface ethernet0/1

    set route source 192.168.1.0/24 interface ethernet0/1 metric 3

     



  • 6.  RE: Bridge Mode Connection problem
    Best Answer

    Posted 04-30-2008 08:21

    Thank you for clarifying.  

    If your event log has not been overwritten, can you run the command 'get event inc adsl'?  Are the events during the problematic time still there?   If so, do you see a clue to the problem there?

     

     

    If you want to troubleshoot on eth0/0 or eth0/2 again, can you capture the following after you move the line:

     

    undebug all     (turn off any debugs)

    get pppoe all

    debug pppoe basic

    exec pppoe name (name) disc

    clear db         (clear debug buffer)

    exec pppoe name (name) con

    undebug all        (stop debugs)

    get db stream     (view debug buffer)

     

    get event inc adsl

    get adsl basic

    get adsl stat

     

     

    You can do this for the working and non-working condition and compare the debug buffer.  That should give the clue.  

    Let us know how that goes.

    --Josine 

     

     



  • 7.  RE: Bridge Mode Connection problem

    Posted 04-30-2008 08:45
    Thanks for your reply. I will degug toomorrow and let you know


  • 8.  RE: Bridge Mode Connection problem

    Posted 05-01-2008 23:37

    Hi Josine,

     

    I run the debugging on the interface 0/5 1st and then I plugged to interface 0/0 and it connected succesfull :). 

     

    Thanks for your helps.

     

     



  • 9.  RE: Bridge Mode Connection problem

    Posted 05-02-2008 16:44

    Thank you for the update.

    Running the debugs should not have corrected the problem.  Perhaps the 'exec pppoe disconnect' and 'exec pppoe connect' as part of the steps reset something? 

    If the problem happens again, at least you'll have a working set of debugs to compare it to.

    --Josine