vMX

 View Only
last person joined: 3 days ago 

Ask questions and share experiences about vMX.
  • 1.  BNG

    Posted 12-27-2022 04:49

    Hi guys. Recently i learning about BNG (myself interesting) and i don't can get found the problem. Customer CPE don't get connect. Looking em captured packets, i can see the message in PADS "no resources".  I try everithing than found about it.

    Thanks :)

    root> show configuration | display set
    set version 19.4R3.11
    set system root-authentication encrypted-password "$6$RpOw/Frc$izqjIcqEIjVB7SYdmcsDIDNnTw4weLHe9Z5FlfXNJOOfKlG9a9WI2XVzixrJZgAdcYb4Ig6N2iGRAa8Axr3XK1"
    set system configuration-database max-db-size 104857600
    set system login user guilherme uid 2000
    set system login user guilherme class super-user
    set system login user guilherme authentication encrypted-password "$6$P5TJu2/t$t4aQOkasRpxNEHAek9bjYK76MqUi5JUSwvzjXOtffAcEqXdCDX0KwgivchIchVJg2SfNEPP4pLQgI0use64ew0"
    set system services subscriber-management enable
    set system dynamic-profile-options versioning
    set system syslog user * any emergency
    set system syslog file messages any notice
    set system syslog file messages authorization info
    set system syslog file interactive-commands interactive-commands any
    set system processes dhcp-service traceoptions file dhcp_logfile
    set system processes dhcp-service traceoptions file size 10m
    set system processes dhcp-service traceoptions level all
    set system processes dhcp-service traceoptions flag packet
    set chassis network-services enhanced-ip
    set access-profile PPPOE-MAINPROFILE
    set interfaces ge-0/0/0 mtu 9200
    set interfaces ge-0/0/0 unit 0 family pppoe access-concentrator BNG-VMX
    set interfaces ge-0/0/0 unit 0 family pppoe direct-connect
    set interfaces ge-0/0/0 unit 0 family pppoe duplicate-protection
    set interfaces ge-0/0/0 unit 0 family pppoe dynamic-profile PPPOE-MAINPROFILE
    set interfaces fxp0 unit 0 family inet dhcp vendor-id Juniper-vmx-VM63A99058F6
    set interfaces lo0 unit 0 family inet address 1.1.1.1/32
    set interfaces pp0 unit 0 ppp-options dynamic-profile PPPOE-MAINPROFILE
    set policy-options prefix-list pool-pppoe-v4 100.66.0.0/19
    set access profile PPPOE-MAINPROFILE authentication-order none
    set access profile PPPOE-MAINPROFILE authorization-order none
    set access profile PPPOE-MAINPROFILE domain-name-server 1.1.1.1
    set access profile PPPOE-MAINPROFILE address-assignment pool pool-cgnat
    set access profile PPPOE-MAINPROFILE subscriber teste password "$9$u8T/0EyMWxdwgX7wg"
    set access address-assignment pool pool-cgnat link pool-cgnat-1
    set access address-assignment pool pool-cgnat family inet network 100.66.0.0/19
    set access address-assignment pool pool-cgnat family inet range pool-cgnat-1 low 100.66.0.0
    set access address-assignment pool pool-cgnat family inet range pool-cgnat-1 high 100.66.31.255
    set access address-assignment pool pool-cgnat-1 family inet network 100.66.32.0/19
    set access address-assignment pool pool-cgnat-1 family inet range pool-cgnat-1 low 100.66.32.0
    set access address-assignment pool pool-cgnat-1 family inet range pool-cgnat-1 high 100.66.63.255
    set access domain map none address-pool pool-pppoe
    set routing-options static route 100.66.0.0/19 discard
    set routing-options aggregate route 100.64.64.0/20
    set dynamic-profiles PPPOE-MAINPROFILE variables POLICER-IN uid
    set dynamic-profiles PPPOE-MAINPROFILE variables POLICER-OUT uid
    set dynamic-profiles PPPOE-MAINPROFILE variables FILTER-IN uid
    set dynamic-profiles PPPOE-MAINPROFILE variables FILTER-OUT uid
    set dynamic-profiles PPPOE-MAINPROFILE variables BANDWIDTH-OUT default-value 32k
    set dynamic-profiles PPPOE-MAINPROFILE variables BANDWIDTH-OUT mandatory
    set dynamic-profiles PPPOE-MAINPROFILE variables BURST-IN default-value 2m
    set dynamic-profiles PPPOE-MAINPROFILE variables BURST-OUT default-value 2m
    set dynamic-profiles PPPOE-MAINPROFILE variables BANDWIDTH-IN default-value 32k
    set dynamic-profiles PPPOE-MAINPROFILE variables BANDWIDTH-IN mandatory
    set dynamic-profiles PPPOE-MAINPROFILE routing-instances "$junos-routing-instance" interface "$junos-interface-name"
    set dynamic-profiles PPPOE-MAINPROFILE routing-instances "$junos-routing-instance" routing-options access route $junos-framed-route-ip-address-prefix next-hop "$junos-framed-route-nexthop"
    set dynamic-profiles PPPOE-MAINPROFILE routing-instances "$junos-routing-instance" routing-options access route $junos-framed-route-ip-address-prefix metric "$junos-framed-route-cost"
    set dynamic-profiles PPPOE-MAINPROFILE routing-instances "$junos-routing-instance" routing-options access route $junos-framed-route-ip-address-prefix preference "$junos-framed-route-distance"
    set dynamic-profiles PPPOE-MAINPROFILE routing-instances "$junos-routing-instance" routing-options access route $junos-framed-route-ip-address-prefix tag "$junos-framed-route-tag"
    set dynamic-profiles PPPOE-MAINPROFILE routing-instances "$junos-routing-instance" routing-options access-internal route $junos-subscriber-ip-address qualified-next-hop "$junos-interface-name"
    set dynamic-profiles PPPOE-MAINPROFILE interfaces pp0 interface-mib
    set dynamic-profiles PPPOE-MAINPROFILE interfaces pp0 unit "$junos-interface-unit" no-traps
    set dynamic-profiles PPPOE-MAINPROFILE interfaces pp0 unit "$junos-interface-unit" ppp-options chap
    set dynamic-profiles PPPOE-MAINPROFILE interfaces pp0 unit "$junos-interface-unit" ppp-options pap
    set dynamic-profiles PPPOE-MAINPROFILE interfaces pp0 unit "$junos-interface-unit" ppp-options authentication chap
    set dynamic-profiles PPPOE-MAINPROFILE interfaces pp0 unit "$junos-interface-unit" ppp-options mru 1492
    set dynamic-profiles PPPOE-MAINPROFILE interfaces pp0 unit "$junos-interface-unit" ppp-options mtu 1492
    set dynamic-profiles PPPOE-MAINPROFILE interfaces pp0 unit "$junos-interface-unit" ppp-options ignore-magic-number-mismatch
    set dynamic-profiles PPPOE-MAINPROFILE interfaces pp0 unit "$junos-interface-unit" pppoe-options underlying-interface "$junos-underlying-interface"
    set dynamic-profiles PPPOE-MAINPROFILE interfaces pp0 unit "$junos-interface-unit" pppoe-options server
    set dynamic-profiles PPPOE-MAINPROFILE interfaces pp0 unit "$junos-interface-unit" keepalives interval 1
    set dynamic-profiles PPPOE-MAINPROFILE interfaces pp0 unit "$junos-interface-unit" family inet filter input "$FILTER-IN"
    set dynamic-profiles PPPOE-MAINPROFILE interfaces pp0 unit "$junos-interface-unit" family inet filter output "$FILTER-OUT"
    set dynamic-profiles PPPOE-MAINPROFILE interfaces pp0 unit "$junos-interface-unit" family inet unnumbered-address lo0.0
    set dynamic-profiles PPPOE-MAINPROFILE firewall family inet filter "$FILTER-IN" term SHAPERUP then policer "$POLICER-IN"
    set dynamic-profiles PPPOE-MAINPROFILE firewall family inet filter "$FILTER-IN" term SHAPERUP then service-filter-hit
    set dynamic-profiles PPPOE-MAINPROFILE firewall family inet filter "$FILTER-IN" term SHAPERUP then accept
    set dynamic-profiles PPPOE-MAINPROFILE firewall family inet filter "$FILTER-OUT" term SHAPERDOWN then policer "$POLICER-OUT"
    set dynamic-profiles PPPOE-MAINPROFILE firewall family inet filter "$FILTER-OUT" term SHAPERDOWN then service-filter-hit
    set dynamic-profiles PPPOE-MAINPROFILE firewall family inet filter "$FILTER-OUT" term SHAPERDOWN then accept
    set dynamic-profiles PPPOE-MAINPROFILE firewall policer "$POLICER-OUT" filter-specific
    set dynamic-profiles PPPOE-MAINPROFILE firewall policer "$POLICER-OUT" logical-interface-policer
    set dynamic-profiles PPPOE-MAINPROFILE firewall policer "$POLICER-OUT" if-exceeding bandwidth-limit "$BANDWIDTH-OUT"
    set dynamic-profiles PPPOE-MAINPROFILE firewall policer "$POLICER-OUT" if-exceeding burst-size-limit "$BURST-OUT"
    set dynamic-profiles PPPOE-MAINPROFILE firewall policer "$POLICER-OUT" then discard
    set dynamic-profiles PPPOE-MAINPROFILE firewall policer "$POLICER-IN" filter-specific
    set dynamic-profiles PPPOE-MAINPROFILE firewall policer "$POLICER-IN" logical-interface-policer
    set dynamic-profiles PPPOE-MAINPROFILE firewall policer "$POLICER-IN" if-exceeding bandwidth-limit "$BANDWIDTH-IN"
    set dynamic-profiles PPPOE-MAINPROFILE firewall policer "$POLICER-IN" if-exceeding burst-size-limit "$BURST-IN"
    set dynamic-profiles PPPOE-MAINPROFILE firewall policer "$POLICER-IN" then discard



    ------------------------------
    Guilherme Rigueti
    ------------------------------