SRX

Expand all | Collapse all

JUNOS recovery on SRX210HE2

  • 1.  JUNOS recovery on SRX210HE2

    Posted 04-02-2014 23:39

    Hi all,

    my first approach with an SRX router was very unlucky.

    Probably due to a power outage, my SRX210HE2 with JUNOS 12.1X44-D15.5 now shows the following prompt:

     

    =>

     

    I'm not familiar with SRX, so the the first attempts was an help from prompt:

     

    => ?
    ? - alias for 'help'
    askenv - get environment variables from stdin
    base - print or set address offset
    boot - boot default, i.e., run 'bootcmd'
    bootd - boot default, i.e., run 'bootcmd'
    bootelf - Boot from an ELF image in memory
    bootloader - upgrade u-boot
    bootloader - upgrade loader
    bootloader - upgrade ushell
    bootloader - check u-boot
    bootloader - check loader
    bootm - boot application image from memory
    bootoct - Boot from an Octeon Executive ELF image in memory
    bootoctelf - Boot a generic ELF image in memory. NOTE: This command does not sup
    port
    simple executive applications, use bootoct for those.
    bootoctlinux - Boot from a linux ELF image in memory
    bootp - boot image via network using BootP/TFTP protocol
    bootvx - Boot vxWorks from an ELF image
    cmp - memory compare
    cp - memory copy
    cpld - peek/poke CPLD
    crc32 - checksum calculation
    dhcp - invoke DHCP client to obtain IP/boot params
    dumpoct - dump octeon regs
    dumpstats - dump cavium stats
    echo - echo args to console
    erase - erase FLASH memory
    fatinfo - print information about filesystem
    fatload - load binary file from a dos filesystem
    fatls - list files in a directory (default /)
    flinfo - print FLASH memory information
    go - start application at address 'addr'
    gpio - read/write on gpio pins
    help - print online help
    i2c - read/write on i2c bus
    id_eeprom - peek/poke EEPROM
    ide - IDE sub-system
    iminfo - print header information for application image
    imls - list all images found in flash
    loop - infinite loop on address range
    ls609x_read_reg - Read 88E6097 register
    md - memory display
    mdkinit - start MDK
    mm - memory modify (auto-incrementing)
    mtest - simple RAM test
    mw - memory write (fill)
    nand_format - format nand flash
    nand_patch_verify - verifies patch in nand flash
    nfs - boot image via network using NFS protocol
    nm - memory modify (constant address)
    pci - list and access PCI Configuration Space
    pciemd - pcie memory display
    pciemw - pcie memory write
    pciereset - do PCIE reset
    ping - send ICMP ECHO_REQUEST to network host
    printenv- print environment variables
    protect - enable or disable FLASH write protection
    rarpboot- boot image via network using RARP/TFTP protocol
    read64 - read 64 bit word from 64 bit address
    read64b - read 8 bit word from 64 bit address
    read64l - read 32 bit word from 64 bit address
    read_cmp - read and compare memory to val
    reset - Perform RESET of the CPU
    run - run commands in an environment variable
    saveenv - save environment variables to persistent storage
    setenv - set environment variables
    sleep - delay execution for some time
    smi - peek/poke SMI devices
    tftpboot- boot image via network using TFTP protocol
    usb - USB sub-system
    usbboot - boot from USB device
    version - print monitor version
    watchdog <start | stop | show | pat>
    write64 - write 64 bit word to 64 bit address
    write64b - write 8 bit word to 64 bit address
    write64l - write 32 bit word to 64 bit address
    =>

     

    Then tried the bootm command. The result was disappointing:


    => bootm
    ## Booting image at 20000000 ...
    Bad Magic Number
    =>

     

    So, I tried to look something on Junos documentation but did not find any help.

    Any suggestion to "resurrect" my SRX ?

    Thanks a lot in advance to anybody will help me.

    Tiziano



  • 2.  RE: JUNOS recovery on SRX210HE2

    Posted 04-02-2014 23:51

    Hi Tiziano,

     

     You can try the steps mentioned below to restore the device.

     

    http://www.juniper.net/techpubs/en_US/junos13.3/topics/topic-map/security-software-installation-boot-loader-usb-srx.html

     

    Thanks,

    SHKM



  • 3.  RE: JUNOS recovery on SRX210HE2

    Posted 04-03-2014 01:37

    Thanks a lot SHKM.

    Big question: can I use another SRX as TFTP server, as I usually do with Cisco routers ?

    Which commands do I need to enable TFTP server on the router ?



  • 4.  RE: JUNOS recovery on SRX210HE2

    Posted 04-03-2014 02:27

    No, SRX we can't use it as TFTP server however, I see that SRX stops in U-boot prompt

     

    =>

    if you do reset to reboot the system. Does it go beyond U-boot prompt or again it stops at same => prompt?

     

    If it stops at same => prompt then we need to process RMA. If it goes beyond and gets to "loader >" prompt then we can install Junos using tftp or usb.

     

    Thanks,

    SHKM

     

     

     



  • 5.  RE: JUNOS recovery on SRX210HE2

    Posted 04-03-2014 17:59

    I was stuck with an SRX550 looping with U-boot exceptions on start up for the past couple of days. I was able to recover it using the following steps. I'm not sure if it will help you, but give it a try. I am assuming that you've got a spare working SRX210HE2 lying aroud because the following steps require you to take a snapshot from it on a USB.

     

    Boot up the working SRX210HE. Once you are in the operator mode, plug in a USB (4GB+ I think), and perform the following steps:

     

    1. Run request system snapshot media usb factory partitionThis will copy a snapshot of the working SRX210 to your USB drive.
    2. Now plug in the USB to the faulty SRX and power it on. At the u-boot prompt ('=>'), type in setenv boot.current alternate.
    3. Enter saveenv
    4. Enter boot
    5. Now wait for a bit till you get the message asking you for an input to enter the loader prompt.

    => boot

    Press Enter to stop auto bootsequencing and to enter loader prompt.


    Type '?' for a list of commands, 'help' for more detailed help.
    loader>

     

    6. At the loader prompt, enter nextboot usb

    7. Plug in the USB with the snapshot on to the faulty SRX210 and then enter reboot.

    8. Now your faulty SRX210 should boot up from the USB. If it does boot up completely and you are able to enter the operator mode, enter the following command to copy the snapshot over to your faulty SRX.

    request system snapshot media internal factory partition


    9. Then enter request system reboot media internal to reboot the SRX from the internal media. You unplug the USB from the SRX now.

     

    Your SRX should be able to boot up now (hopefully). The commands are from memory, so there might be mistakes. Let me know if it woked. 🙂

     

    Got these steps from here... http://forums.juniper.net/t5/SRX-Services-Gateway/can-t-load-kernel-and-can-t-load-kernel-old/td-p/64491

     

     



  • 6.  RE: JUNOS recovery on SRX210HE2

    Posted 04-04-2014 13:57

    Thanks a lot Juno-AU. I will try it, even if t looks a bit complex. 

    I'm wondering why those guys designing routers get simple things as a recovery of Junos so complex. It's a little bit disappointing to tell the truth.

     



  • 7.  RE: JUNOS recovery on SRX210HE2

     
    Posted 04-05-2014 23:06

    Hello Tiziano

     

    If you are not getting loader prompt, it is quite possible that compact flash has gone faulty.

    You will have to oepn up a ticket with JTAC for troubleshooting/RMA.

     

    Regards,

    Raveen



  • 8.  RE: JUNOS recovery on SRX210HE2

    Posted 04-06-2014 12:31

    Very bad stuff, Raveen. Tomorrow I will try to do something. If unsuccessful I will contact some friend in Juniper.

    By the way, what did it happen in your opinion ? 

    Thanks a lot.

    Tiziano



  • 9.  RE: JUNOS recovery on SRX210HE2

    Posted 04-04-2014 13:55

    As a matter of fact I can't get the loader> prompt. Tried it but was unsuccessful.

     



  • 10.  RE: JUNOS recovery on SRX210HE2

    Posted 04-06-2014 12:36

    Sorry SHKM, being new to JUNOS, I'm not aware of the meaning "we need to process RMA". What does it mean ?

    Thanks a lot.

    Tiziano



  • 11.  RE: JUNOS recovery on SRX210HE2

    Posted 04-06-2014 16:54

    RMA stands for Return Material Authorization.  If a hardware failure is determined by the JTAC engineer and repair/replacement is needed, an RMA will be raised.

     

    http://kb.juniper.net/InfoCenter/index?page=content&id=KB9866



  • 12.  RE: JUNOS recovery on SRX210HE2

     
    Posted 04-06-2014 18:56

    Processing RMA means if JTAC deduce the problem to be with hardware, you would be provided with replacement device.

     

    Regards,

    Raveen