Hey Daryll,
It's been a really long time since I've had to deal with ADSL, we are mostly fibre to the home here in NZ.
Below is a snippet of the configuration I used to use on an old SRX110 back in the day.
Note the "encapsulation atm-ppp-vc-mux", this will be specific to your country and ISP setup, check your ISP's doc's for the encap type you should be setting.
interfaces {
at-1/0/0 {
traceoptions {
flag all;
}
encapsulation atm-pvc;
atm-options {
vpi 0;
}
dsl-options {
operating-mode auto;
}
unit 0 {
encapsulation atm-ppp-vc-mux;
vci 0.100;
ppp-options {
pap {
access-profile pppoa-client;
local-name "test@lab.net";
local-password "blah"; ## SECRET-DATA
passive;
}
}
keepalives;
family inet {
negotiate-address;
}
}
}
Cheers
Dave
Original Message:
Sent: 05-16-2024 07:14
From: DARYLL SMITH
Subject: ADSL - VDSL PPPoA config help
I have an old config from a Cisco ASA which is here:
interface Dialer1
ip address negotiated
ip mtu 1452
encapsulation ppp
ip tcp adjust-mss 1412
dialer pool 1
dialer-group 1
ppp mtu adaptive
ppp authentication chap callin
ppp chap hostname email@email
ppp chap password 7 password
ppp ipcp dns request
no cdp enable
I've configured this on my Juniper SRX-340:
set interfaces at-1/0/0 encapsulation atm-pvc
set interfaces at-1/0/0 atm-options vpi 0
set interfaces at-1/0/0 dsl-options operating-mode auto
set interfaces at-1/0/0 unit 0 encapsulation atm-ppp-llc
set interfaces at-1/0/0 unit 0 vci 35
set interfaces at-1/0/0 unit 0 ppp-options chap default-chap-secret password
set interfaces at-1/0/0 unit 0 ppp-options chap local-nameemail@email
set interfaces at-1/0/0 unit 0 ppp-options chap passive
set interfaces at-1/0/0 unit 0 family inet negotiate-address
Which has raised the interface but logical and routing remains down:
Interface Admin Link Proto Local Remote
at-1/0/0 up up
at-1/0/0.0 up down inet
at-1/0/0.32767 up up
I've found and followed the below guide:
SRX
But can't manage to get routing or the logical interface to show as up and I don't know where to begin if I'm honest.
Can anyone help here please?
------------------------------
DARYLL SMITH
------------------------------