vMX

Expand all | Collapse all

LACP on vMX

  • 1.  LACP on vMX

    Posted 08-12-2015 02:18

    hi team,

     

    I am able to connect two vMX with LAG without using LACP. Once I enable the LACP, the ae interface status change to down.

     

    Anybody can suggest if LACP is supported on vMX or not?

     

    my vMX version 14.1R1.10

     



  • 2.  RE: LACP on vMX

    Posted 08-12-2015 02:38

    Just found something

    Problem Report

    NumberPR1059231
    TitleLACP is not supported with virtIO
    Release Note
    LACP is not supported with virtIO.
    SeverityMajor
    StatusClosed
    Last Modified2015-07-01 06:55:25 PDT
    Resolved In 
    Operating SystemJunos
    ProductMX-series
    Functional Areasoftware


  • 3.  RE: LACP on vMX

    Posted 08-12-2015 02:44

    You are not running the proper code for vMX, the code you have is from an internal engineering program.  please download the production code from: https://www.juniper.net/support/downloads/?p=vmx#sw

     

    the proper code version fro vMX is 14.1R5

     

    That defect applies to the production code fro vMX. 

     

    Thanks



  • 4.  RE: LACP on vMX

    Posted 08-12-2015 04:00

    Hi,

     

    Thank you very much for your reply.

     

    Any ETA for the fix for this LACP defect?

     

     



  • 5.  RE: LACP on vMX

    Posted 08-20-2015 13:35

    The reason why LACP does not work in virtio mode is due to the fact that we use linux bridges to steer traffic to vmx. The inbuilt behavior of linux bridge is to consume (and not forward) all link-local multicast packets (like LACP). You can workaround the problem by 2 ways:

     

    1) use SRIOV instead of virtio

    2) use OVS instead of linux bridges in case of virtio



  • 6.  RE: LACP on vMX

    Posted 02-24-2017 00:43

    Hello,

     

    Did anyone managed to configure vMX with lacp and OVS?

    I tried but the bond interface will never come up.

     

    Thanks.



  • 7.  RE: LACP on vMX

    Posted 02-25-2017 05:38

    I managed to configure LACP using virtio interfaces and linux bridge.

    You have to patch the linux kernel and modify the BR_GROUPFWD_RESTRICTED from net/bridge/br_private.h in order to allow you to set /sys/class/net/<bridge iface>/bridge/group_fwd_mask.



  • 8.  RE: LACP on vMX

    Posted 05-30-2018 19:00

    like this.

     

    /usr/src/linux/net/bridge # more patch.br_private.h
    --- br_private.h	2018-05-29 17:18:19.408679820 +0900
    +++ br_private.h	2018-05-29 17:19:31.177539982 +0900
    @@ -35,7 +35,7 @@
     /* Control of forwarding link local multicast */
     #define BR_GROUPFWD_DEFAULT	0
     /* Don't allow forwarding of control protocols like STP, MAC PAUSE and LACP */
    -#define BR_GROUPFWD_RESTRICTED	0x0007u
    +#define BR_GROUPFWD_RESTRICTED	0x0000u
     /* The Nearest Customer Bridge Group Address, 01-80-C2-00-00-[00,0B,0C,0D,0F] */
     #define BR_GROUPFWD_8021AD	0xB801u

     but this way is out of linux  specification. 

     After modify br_private.h. it need to compile kernel.

     

    After restart system. then give following command.

    echo 255 > /sys/class/net/t1_br1/bridge/group_fwd_mask

     you can see this.

    cat /sys/class/net/t1_br1/bridge/group_fwd_mask
    0xff

     



  • 9.  RE: LACP on vMX

    Posted 06-14-2020 10:17

    Hi All,

     

    Could anybody suggest why lacp enabled interfaces are not coming up in Juniper Virtual lab and Juniper cloud lab vMX device.

     

    FYI, I am using Juniper virtual lab and Juniper cloud lab to build LACP for MC-LAG but here lacp enabled interfaces are not coming up. However, i used "force-up" command to make the lacp enabled interface up but its not communicating each other for which the IRB vlan is passing over the lacp interface. If "force-up" command is not used then interface will not come up.

     

    Please let me know if anybody overcome this issue in juniper virtual/ Cloud lab.

     

    Below is the vMX config:

    vMX1:-

    jcluser@Core-A> show configuration |display set | match ae0
    set interfaces ge-0/0/0 gigether-options 802.3ad ae0
    set interfaces ae0 description "ICL-LINK b/w Core A & B"
    set interfaces ae0 flexible-vlan-tagging
    set interfaces ae0 encapsulation flexible-ethernet-services
    set interfaces ae0 aggregated-ether-options minimum-links 1
    set interfaces ae0 aggregated-ether-options link-speed 1g
    set interfaces ae0 aggregated-ether-options lacp active
    set interfaces ae0 aggregated-ether-options lacp periodic fast
    set interfaces ae0 aggregated-ether-options lacp force-up
    set interfaces ae0 unit 0 family bridge interface-mode trunk
    set interfaces ae0 unit 0 family bridge vlan-id-list 1-4094

    jcluser@Core-A> show interfaces terse |match ae0
    ge-0/0/0.0 up up aenet --> ae0.0
    ge-0/0/0.32767 up up aenet --> ae0.32767
    ae0 up up
    ae0.0 up up bridge
    ae0.32767 up up multiservice

     

    jcluser@Core-A> show bridge domain

    Routing instance Bridge domain VLAN ID Interfaces
    default-switch ICCP 1
    ae0.0--->> This interface should be indicated as ae0.0* if the lacp ineterface working properly, Here no * indication even after configured the "force-up" command on ae0.

    jcluser@Core-A>

     

    vMX2:-

    jcluser@Core-B# show |display set |match ae0
    set interfaces ge-0/0/0 gigether-options 802.3ad ae0
    set interfaces ae0 description "ICL-LINK b/w Core A & B"
    set interfaces ae0 flexible-vlan-tagging
    set interfaces ae0 encapsulation flexible-ethernet-services
    set interfaces ae0 aggregated-ether-options minimum-links 1
    set interfaces ae0 aggregated-ether-options link-speed 1g
    set interfaces ae0 aggregated-ether-options lacp active
    set interfaces ae0 aggregated-ether-options lacp periodic fast
    set interfaces ae0 aggregated-ether-options lacp force-up
    set interfaces ae0 unit 0 family bridge interface-mode trunk
    set interfaces ae0 unit 0 family bridge vlan-id-list 1-4094

    [edit]
    jcluser@Core-B# run show interfaces terse |match ae0
    ge-0/0/0.0 up up aenet --> ae0.0
    ge-0/0/0.32767 up up aenet --> ae0.32767
    ae0 up up
    ae0.0 up up bridge
    ae0.32767 up up multiservice

    [edit]
    jcluser@Core-B# run show bridge domain

    Routing instance Bridge domain VLAN ID Interfaces
    default-switch ICCP 1
    ae0.0----->Here also ae0 interface is not indicated by start (*).

    [edit]
    jcluser@Core-B#

     



  • 10.  Re: LACP on vMX

    Posted 11-03-2020 18:32

    Iam_Chethan,

    Did you initialize the aggregated-devices?

    "set chassis aggregated-devices ethernet device-count ‘number’"