SRX

Expand all | Collapse all

SRX220 not recovering connection after link goes down

Jump to Best Answer
  • 1.  SRX220 not recovering connection after link goes down

    Posted 07-05-2018 18:23

    Hi All

     

    We have a client using a SRX220H with JUNOS 12.1X46-D65.4. Their external data link comes onto their premises through a OneAccess 1424 (internet provider supplied) that then is ethernet patched to the SRX220H through Port 0.

     

    When their link goes down ie issues with provider etc and then is restored, the SRX and the OneAccess don't start talking again until one of them is rebooted. Is there a setting or something that I can do to make the SRX realise that the link it active again without needed to reboot?

     

    Thanks

    Steve


    #recovery
    #SRX220
    #OneAccess


  • 2.  RE: SRX220 not recovering connection after link goes down

     
    Posted 07-06-2018 01:40

    an you try connecting a laptop to port 0 on srx and then start restarting the laptop or any other device and see if you get same behavior? Ideally the physical link should be up without any config changes/reboot.

     

    You may also tryusing a different port on SRX?peer and check the issue.



  • 3.  RE: SRX220 not recovering connection after link goes down

     
    Posted 07-06-2018 04:00

    As Suraj says, a link flap should not cause this behavior.  But there is an option that can be configured on the RPM probe that will down an interface if problems are connected and then the interface must be manually brought up or the device rebooted to recover.

     

    You can see if rpm is configured at all by

    show configuration | display set | match rpm

     



  • 4.  RE: SRX220 not recovering connection after link goes down

    Posted 07-09-2018 22:29

    Thanks for the information. RPM is not configured "No RPM probes are configured or active."



  • 5.  RE: SRX220 not recovering connection after link goes down

     
    Posted 07-10-2018 02:47

    Is the ISP interface static or dhcp address?

    There is a limit to the number of times the SRX will request a dhcp address before giving up.  Maybe this is reached during the outage so a link flap is needed to get the requests going again.

     



  • 6.  RE: SRX220 not recovering connection after link goes down

    Posted 07-10-2018 18:02

    It's a static interface.



  • 7.  RE: SRX220 not recovering connection after link goes down

    Posted 07-11-2018 01:05

    Hello,


    @Steven T Eam wrote:

    Hi All

     

    We have a client using a SRX220H with JUNOS 12.1X46-D65.4. Their external data link comes onto their premises through a OneAccess 1424 (internet provider supplied) that then is ethernet patched to the SRX220H through Port 0.

     

    When their link goes down ie issues with provider etc and then is restored, the SRX and the OneAccess don't start talking again until one of them is rebooted. Is there a setting or something that I can do to make the SRX realise that the link it active again without needed to reboot?

      


     Sounds like a L1 issue, perhaps Ethernet autonegotiation not complete.

    Would You please be able to supply following printout from SRX when the issue hits?

     

    show interfaces ge-0/x/y media detail | no-more
    show interfaces ge-0/x/y extensive | no-more

    Also, You could try either disabling autonegotiation ON BOTH SIDES, or executing the below JUNOS command when the issue hits:

    test interface ge-0/x/y restart-auto-negotiation 

    HTH

    Thx

    Alex

    P.S. Please don't forget to replace ge-0/x/y above with actual SRX interface id that is connected to OneAccess 1424 box!



  • 8.  RE: SRX220 not recovering connection after link goes down

    Posted 07-16-2018 18:38

    Thank you for the information. I will try this next time I am at the client's site.

     

    In the meantime, they have told me that when the link goes down, they have found that they can unplug the OneAccess 1424 ethernet from the ge-0/0/0 port and then plug it back in, the link becomes active again.



  • 9.  RE: SRX220 not recovering connection after link goes down

     
    Posted 07-17-2018 03:00

    https://www.oneaccess-net.com/pcpe/ethernet-access/item/125-1424

     

    Looking at the model datasheet I see all the ports are fast ethernet.  See if setting the port explicity to 100 full and no auto neg fixes the problem.  Ideally you would set this on both sides but it might work just on the SRX side.

     

    set interfaces ge-0/0/0 ether-options no-auto-negotiation
    set interfaces ge-0/0/0 ether-options speed 100m

    set interfaces ge-0/0/0 ether-options link-mode full-duplex

     

    This will bounce the port and potentially not come up if it also needs to be set on the other side.  So use commit confirmed to auto rollback  in case it drops or do from on site.



  • 10.  RE: SRX220 not recovering connection after link goes down
    Best Answer

    Posted 08-19-2018 20:49

    The Client no longer needs to use the OneAccess so problem not longer valid.