SRX

 View Only

IMPORTANT MODERATION NOTICE

This community is currently under full moderation, meaning  all posts will be reviewed before appearing in the community. Please expect a brief delay—there is no need to post multiple times. If your post is rejected, you'll receive an email outlining the reason(s). We've implemented full moderation to control spam. Thank you for your patience and participation.



  • 1.  SRX220 Trying to setup a second internet port

    Posted 12-29-2015 11:44

    Help please -

    Using Jweb:

    My first port is ge-0/0/0.0 and has a working inet connection, static IP connected to the untrust I Net Zone.

    I'm trying to expose a system connected to port 0/0/3  - 0/0/3.0 with a different ISP assigned internet routable IP subnet and went to the setup and added the new routable (internet) IP subnet to the interface bypassing on purpose the switching tab -

    The ge-0/0/3.0 port too is setup for the untrust I net Zone

    After I add my ipv4 address and mask and trying to commit,  it fails with:

     

    There were error(s) delivering the configuration.

    Error(s):
    'interface ge-0/0/3.0'

    1) Interface ge-0/0/3.0 not enabled for switching
    2) configuration check-out failed


    Pending Changes from Compare:

    [edit interfaces ge-0/0/3 unit 0]
    +      family inet {
    +          address 38.x.x.x/29;
    +      }
    -      family ethernet-switching {
    -          port-mode access;
    -      }
    

     

    I don't want the switching as it is...even if I enable that - then I can't get it to take either because it says switching is enabled??

     

    So what am I doing wrong please?  What if I had actually wanted another ISP connection here? It seems that's doable from other posts...Thank you in advance

     

    PSS> I cancel the commit and my interface config is thus:

    show interfaces terse
    Interface Admin Link Proto Local Remote
    ge-0/0/0 up up
    ge-0/0/0.0 up up inet 38.x.x.x/30
    gr-0/0/0 up up
    ip-0/0/0 up up
    lsq-0/0/0 up up
    lt-0/0/0 up up
    mt-0/0/0 up up
    sp-0/0/0 up up
    sp-0/0/0.0 up up inet
    inet6
    sp-0/0/0.16383 up up inet 10.0.0.1 --> 10.0.0.16
    10.0.0.6 --> 0/0
    128.0.0.1 --> 128.0.1.16
    128.0.0.6 --> 0/0
    ge-0/0/1 up down
    ge-0/0/2 up up
    ge-0/0/2.0 up up inet 192.168.66.1/24
    ge-0/0/3 up down
    ge-0/0/3.0 up down eth-switch

     

     **UPDATE - I have another Juniper SRX220 and tried my config. on the same open port there and it took. Both have the same OS version - I wonder if I have to reboot this one...urgh? ** Deleted the sub interface - saved the config. Tried again adding it anew, same issue squawking about ethernet switching although I wasn't using it. had to delete the sub again just to get back to a working config. due to commit staring at me. Added a sub int. to 0/0/4 just like before and it worked. Dunno if I'll ever be able to use 0/0/3...no biggie for now.
     

     

     



  • 2.  RE: SRX220 Trying to setup a second internet port
    Best Answer

     
    Posted 12-30-2015 00:22

    Hello ,

     

    What you can try doing is to delete the complete interface and commit it . And then reconfigure it .

     

    # delete interface ge-0/0/3

    # commit

     

     

    # set interafce ge-0/0/3 unit 0 family inet address XXXX/X

    # commit



  • 3.  RE: SRX220 Trying to setup a second internet port

    Posted 12-30-2015 08:10

    Joses,

    Thank you for the reply - It seems very logical that your answer will work for me.

    I have it working on int g0/0/0/4 for now -

    Thank you so much and indeed Kudos to you and everyone else here that helps one another!

     



  • 4.  RE: SRX220 Trying to setup a second internet port

     
    Posted 12-30-2015 23:01

    Hello Scott ,

     

    Glad it helped .  Smiley Wink


    #accepted