SRX

Expand all | Collapse all

Cannot get PXE boot working with DHCP on SRX

  • 1.  Cannot get PXE boot working with DHCP on SRX

    Posted 07-14-2014 15:16

    I have problems getting PXE boot to work.

    My configuration:

    [edit access address-assignment pool Lokaal family inet dhcp-attributes]
    onno@router# show
    maximum-lease-time 14400;
    next-server 10.0.2.250;
    name-server {
        10.0.2.1;
        208.67.220.220;
        208.67.220.222;
    }
    router {
        10.0.2.1;
    }
    boot-file pxelinux.0;
    boot-server 10.0.2.250;

     

    The problem (I think) is the fact that the router is not sending the next-server address. The client connects to the router itself because the next-server field is empty.

    Bootp flags: 0x8000 (Broadcast)
    Client IP address: 0.0.0.0 (0.0.0.0)
    Your (client) IP address: 10.0.2.120 (10.0.2.120)
    Next server IP address: 0.0.0.0 (0.0.0.0)
    Relay agent IP address: 0.0.0.0 (0.0.0.0)
    Client MAC address: WistronI_36:80:08 (20:6a:8a:36:80:08)
    Client hardware address padding: 00000000000000000000
    Server host name: 10.0.2.250
    Boot file name: pxelinux.0
    Magic cookie: DHCP
    <snip>
    Option: (66) TFTP Server Name
    TFTP Server Name: 10.0.2.250
    Option: (67) Bootfile name
    Bootfile name: pxelinux.0

     

    Why is it not sending the next-router address? Is this a bug,one that's present for serveral versions?

    I'm running JUNOS Software Release [12.1X46-D20.5] on Model: srx210he2.



  • 2.  RE: Cannot get PXE boot working with DHCP on SRX

    Posted 07-18-2014 07:26

    Am I the only one with this problem?



  • 3.  RE: Cannot get PXE boot working with DHCP on SRX

    Posted 07-23-2014 02:17

    Hi OnnoO,

     

    To be honest, I haven't tried yet but did you want to try to configure the next-server (and the rest of the related configuration) parameters under the [edit system services dhcp pool Lokaal] instead?

     

    Cheers,



  • 4.  RE: Cannot get PXE boot working with DHCP on SRX

    Posted 07-23-2014 12:53

    When I configure DHCP under system services it works fine, but then I lose my DHCPv6-PD functionality.



  • 5.  RE: Cannot get PXE boot working with DHCP on SRX

    Posted 07-27-2017 17:44

    I had the exact same issue. jdhcpd sets next server in DHCP Offer packet to 0.0.0.0 even though next-server is configured. I was able to fix it because this PXE client had another way to determine the boot server IP, which may or may not work for you:

    option 43 hex-string 06010f08070000xxxxxxxx01ff;
    option 60 string PXEClient;

     

    Where xxxxxxxx is the hex-encoded version of the IP address. This corresponds to the following PXE options:

     

    PXE_DISCOVERY_CONTROL : DISABLE_BCAST_DISCOVER | DISABLE_MCAST_DISCOVER | ENABLE_USE_SERVER_LIST | DISABLE_PROMPT_MENU
    06 01 0f

    PXE_BOOT_SERVERS : type = 0, IPs = [ a.b.c.d ]
    08 07 00 00 xx xx xx xx 01

    PXE_END
    ff

    Edit: this is not sufficient for some clients. Another thing you can try is overriding the server address:

    option 54 ip-address a.b.c.d;