SRX

Expand all | Collapse all

DHCP Client not working?

  • 1.  DHCP Client not working?

    Posted 04-29-2016 21:20
    Software Version:   JUNOS Software Release [12.1X46-D35.1]
    Bios Version:   1.9

     

    I have configured dhcp client on ge-0/0/0.0 as described on this site.  I have also troubleshooted using all tips on this site.

     

    Basically adding dhcp to the interface and adding dhcp to the trust zone.

     

    My interface does not get an IP address, and using monitor does not ever appear to put out a discover.  Renew command does not help.  Is DHCP client broken in this release or am I missing something?

     

    admin# run show system services dhcp client

    Logical Interface name ge-0/0/0.0
    Hardware address 00:24:dc:df:81:40
    Client status init
    Address obtained 0.0.0.0
    Update server enabled



  • 2.  RE: DHCP Client not working?

    Posted 05-01-2016 07:32

    Hello,

     

     

    As per your description of the issue it seems that you are trying to setup SRX as a DHCP client on the interface ge-0/0/0.

     

    Please let me know if you have everything configured as per the below document on the SRX for the same to work and if not then please make the necessary changes and see if it works.

     

    http://www.juniper.net/documentation/en_US/junos12.1x46/topics/example/security-device-dhcp-client-configuring.html

     

    Thanks,
    Pulkit Bhandari

    Please mark my response as Solution Accepted if it Helps, Kudos are Appreciated too. 🙂

     



  • 3.  RE: DHCP Client not working?

     
    Posted 05-01-2016 09:22

    this is the minimum configuration I've used for the SRX and sometimes this has required a reboot for the successful attainment of an address on the interface.

     

    set interfaces ge-0/0/0 unit 0 family inet dhcp retransmission-attempt 6
    set interfaces ge-0/0/0 unit 0 family inet dhcp retransmission-interval 5
    set interfaces ge-0/0/0 unit 0 family inet dhcp update-server


    set security zones security-zone untrust interfaces ge-0/0/0.0 host-inbound-traffic system-services dhcp



  • 4.  RE: DHCP Client not working?

    Posted 02-04-2019 05:24

    I am facing the same problem, can anyone help me with it?
    I followed the link and configured my vsrx but I keep getting this message in the log file

    1.PNG



  • 5.  RE: DHCP Client not working?

     
    Posted 02-04-2019 21:31

    Can you post your DHCP config and the complete logs please?

     

    Anand



  • 6.  RE: DHCP Client not working?

    Posted 02-04-2019 23:35

    Here is the configuration I used, and parts of the log file ( the log file is to big and repeatitive so I screenshoted the new messages)

     

    DHCP configurationDHCP configuration

    dhcp log 1dhcp log 1dhcp log 2dhcp log 2