SRX

 View Only

IMPORTANT MODERATION NOTICE

This community is currently under full moderation, meaning  all posts will be reviewed before appearing in the community. Please expect a brief delay—there is no need to post multiple times. If your post is rejected, you'll receive an email outlining the reason(s). We've implemented full moderation to control spam. Thank you for your patience and participation.



  • 1.  Cannot login to SRX100

    Posted 02-02-2016 09:19

    Hello,

     

    I just used the wizard to setup my brand new SRX100.  Using the web wizard I set my root password to:

     

    g$SY~THD=^8xK)/Q

     

    [yes, that is the actual password]

     

    After reboot, I cannot login using that password.

     

    Is there something invalid about that password?

     

    Did the "wizard" silently remove some of those characters before actually setting my password?

     

    What did the "wizard" actually set my password to?

     

    Are there characters that I am not allowed to use?

     

    Chris

     



  • 2.  RE: Cannot login to SRX100
    Best Answer

    Posted 02-02-2016 10:23

    Hello Chris,

     

    There are few things you may like to check :-

     

    1. Was it a plain text password?

    2. As per my understanding ")" symbol may not be supported in the password field. 

     

    Check this out.

     

    http://www.juniper.net/techpubs/en_US/junos15.1/topics/concept/authentication-plain-text-password-requirements.html

     

    In order to recover the device , you can try this :-

     

    http://www.juniper.net/documentation/en_US/junos15.1x49/topics/task/operational/security-root-password-srx-series-device-recovering.html

     

    Hope this is helpful.

     

    Thanks


    #specialcharactersinpassword
    #plaintextpasswordSRX
    #rootpasswordrecovery


  • 3.  RE: Cannot login to SRX100

    Posted 02-02-2016 11:06

    Hi  chrisstankevitz,

     

    The = character is not supported .

     

    Please type your password this way :

     

    g$SY~THD^8xK)/Q

     

    I just tested this out on my SRX210HE lab device .



  • 4.  RE: Cannot login to SRX100

    Posted 02-02-2016 11:49
    And just to be clear , my answer is regarding the wizard . I haven't tested the CLI mode .

    HTH


  • 5.  RE: Cannot login to SRX100

    Posted 02-02-2016 12:02

    Thank you both for your replies.

     

    Juniper: please don't accept "invalid" passwords and silently change them. Instead tell the user that the password is not valid.  Please contact me directly for more UI tips.

     

    Chris

     

     



  • 6.  RE: Cannot login to SRX100

    Posted 02-03-2016 05:54

    Hello,

    I just tested setting up Your password via JUNOS CLI and it is perfectly accepted.

    JUNOS 12.1X46-D30, SRX210.

    Please open a JTAC case with regards to Jweb not being able to encode/decode Your password as entered/verbatim.

    In the meantime You can use another trick to further increase Your password strength  -  space is also accepted in JUNOS CLI for user passwords.

    HTH

    Thx

    Alex