View Only
last person joined: 17 hours ago 

Ask questions and share experiences about the SRX Series, vSRX, and cSRX.
  • 1.  vSRX Hosted on ESXI remote serial issues via network

    Posted 09-15-2023 10:56

    Hi All

    I've had this issue for the last few days and i am now officially stumped!!!

    I have a Dell R620 blade server running ESXI 6.7 with the enterprise plus license.

    I have a number of  vSRXs spun up  on my ESXI host and would like to telnet to each node using the REMOTE SERIAL PORT via NETWORK feature but this doesnt seem to be working when i attempt to connect to any of my vSRX nodes. Just to be clear, I am also hosting Cisco CSR1000v images where this feature works fine. However before it started to work, i had to connect to the device using the vmware web console and add the following command - 'platform console serial' and then i had to reload the VM. Maybe I have to do something similar on the vSRX??? Any idea how?

    I have tried different vSRX.ova versions which i have downloaded from the Juniper download portal myself. Versions are - junos-media-vsrx-x86-64-vmdisk-22.4R2.8.ide.ova & junos-media-vsrx-x86-64-vmdisk-19.4R3.11.scsi.ova.

    VSRX VM Settings on ESXI:

    vSRX1 is the IP configured on my ESXI host

    When booting the vSRX, the only output I see from the remote serial session  is the GRUB menu where you have 3 options to select what you want to boot into, and then the last thing i see is the output  'linux loading' - then nothing happens and just hangs...  The vSRX  does boot correctly without errors as verified by me connecting via the basic  VMWARE web console - from here i can log into the vSRX and make whatever changes i want.  

    Under the networking>firewall rules section, the  allowed default  TCP inbound rules are 23, 1024-65535. I have been using 2201 ----> 2206 for my test nodes


    SRX1 - Remote Serial via telnet - 

    There is a green tick which suggests it is connected but not seeing any output.

    vSRX1 - via VMWARE Web console

    CSR1000V - Connected via the remote serial connection

    as you can see it is working fine.

    I have tried removing the enterprise plus license and tried using the 60 day EVAL license - made no difference. I have also tried deleting the security config on the vSRX and made the device into a router in case some rule/ security feature was preventing this from working.. Made no difference. I have also tried under the VM settings removing the IP of the ESXI host and just using the syntax telnet://:<tcp port number> and that also didnt work.

    A beer for anyone that can help resolve this. :D

    Thanks for any advice in advance.

    Cheers James

  • 2.  RE: vSRX Hosted on ESXI remote serial issues via network

    Posted 09-25-2023 10:08

    Just bumping this ..

  • 3.  RE: vSRX Hosted on ESXI remote serial issues via network

    Posted 01-18-2024 13:19

    Hello!, did you fix it? I have the same issue!

    Kevin Morales

  • 4.  RE: vSRX Hosted on ESXI remote serial issues via network

    Posted 01-18-2024 14:32

    Hi Kevin

    Unfortunately i did not solve this - after fighting with it for about 6 weeks i gave up and just SSHd to the management interface. 

    On the Cisco CSR1000V images, to get this working i had to run the 'platform console serial' which changes the console port access to the router.. I think there might be a Juniper equivalent command but no idea what it is :(

    Any ideas welcome.. :)

    Cheers James