Labs

 View Only
last person joined: 11 days ago 

Discover how to get the most of Juniper labs and share what you've built.
  • 1.  vJunos Rate Limiting Issues

    Posted 04-19-2024 17:36

    Hello, 

    I have a vJunos switch (version 23.2R1.14-1) running in GNS3. I am trying to test rate-limiting right now. I have two linux VMs in the GNS3 topology I'm working on. When I connect the two VMs directly to each other, iperf3 results show the bitrate as 1G. 

    When I connect the two VMs to the vJunos switch, and then run iperf3, I get bitrate as 100m. 

    I have tried setting the speed at the port, I have tried to create a filter, I have tried using class-of-service and no matter what config I give the switch, the iperf3 results still show 100m. 

    I don't believe the problem is with GNS3, because like I said, I can get 1G connection when the VMs are directly connected, but once the switch is introduced, it stays at 100m. Any help on this would be greatly appreciated. 



    ------------------------------
    James Joseph
    ------------------------------


  • 2.  RE: vJunos Rate Limiting Issues

    Posted 04-19-2024 17:55

    We capped the bandwidth of vJunos-switch and vJunos-router at 100mbps for this lab use:

    https://www.juniper.net/documentation/us/en/software/vJunos/release-notes/23.1/vjunos-switch-release-notes-23.1r1/topics/known-limitations/vjunos-switch-kl-23.1r1.html

    "Supports a maximum bandwidth of 100 Mbps over all the interfaces."

    They are not intended to be used at performance /scale that could support commercial services.

    Art



    ------------------------------
    Art Stine
    ------------------------------



  • 3.  RE: vJunos Rate Limiting Issues

    Posted 04-19-2024 19:16

    Thank you for your response Art. I guess I didn't exactly state what I was trying to do before. This is strictly for lab purposes. I am not trying to get speeds higher than 100Mbps. I am just trying to set some kind of rate limiting on this vJunos switch. If I could set a port to 5Mbps, that would be awesome. I am trying to test something out here so I can apply it in a production environment on some real switches, NOT the vJunos switch. 

    How can I set the speed of a port on a vJunos switch to 10mbps? Like I said in my original message. I have tried setting the speed at the interface level. I have tried setting class-of-service on an interface. I have tried to create a firewall filter and apply it to a vlan.  Either I am not configuring this right, or the switch is not fully taking the config. Because when I have any of the three configs applied that I just mentioned, I still get speeds at 100Mbps, even when I thought I set it to 10Mbps. 



    ------------------------------
    James Joseph
    ------------------------------



  • 4.  RE: vJunos Rate Limiting Issues

    Posted 04-20-2024 01:13

    Ah ok, I understand now. I suspect given the way we are  pinning the PFE rate policer for lab purposes at 100Mbit, it likely doesn't accept overriding it in any direction. Have a look at the chassisd logs and see if it's barking about it. If you have some configs you can share, we can have a look more closely.

    Art



    ------------------------------
    Art Stine
    ------------------------------



  • 5.  RE: vJunos Rate Limiting Issues

    Posted 04-20-2024 18:29

    Ok, I hope that I am able to set something other then 100m, if not, oh well. I ran 'monitor start chassisd' and ran the iperf3 test and I didn't see any logs pop up in the terminal. I also checked the log file and don't see anything that looks like it is relevant, but I could be wrong. Here is a snippet of my chassisd logs. Also, the timestamps are not correct so disregard that. 

    Apr 20 20:12:01  pic_update_ifdev_tlvs: ge-0/0/7 setting ifdm flag to trap l2 protocols
    Apr 20 20:12:01 CHASSISD_IFDEV_CREATE_NOTICE: create_pics: created interface device for ge-0/0/8
    Apr 20 20:12:01  ifdev_create entered ge-0/0/8
    Apr 20 20:12:01  ge-0/0/8: large delay buffer cleared
    Apr 20 20:12:01  pic_update_ifdev_cos_info: Remaining stats flag set on interface ge-0/0/8
    Apr 20 20:12:01  ge-0/0/8: ingress queueing cleared for QDPC
    Apr 20 20:12:01  l2, l3 and bypass = 4096, 16384, iface:ge-0/0/8 for port:8, hier:0, l2:0, l3:0,is0
    Apr 20 20:12:01  ge-0/0/8: queue capable cleared, virtual_tunnel:0, port:8, flexQ:0
    Apr 20 20:12:01  pic_update_ifdev_cos_info: remaining stats flag not set for ge-0/0/8
    Apr 20 20:12:01  fpc_is_synce_cap: FPC i2c: 0xbaa, PIC type: 0xa7d

    Apr 20 20:12:01  pic_update_ifdev_tlvs: ge-0/0/8 Not SyncE capable

    Apr 20 20:12:01  pic_update_ifdev_tlvs: ge-0/0/8 IFM type is Ether, SyncE TLV is added

    Apr 20 20:12:01  pic_update_ifdev_tlvs: ge-0/0/8 setting ifdm flag to trap l2 protocols
    Apr 20 20:12:01 CHASSISD_IFDEV_CREATE_NOTICE: create_pics: created interface device for ge-0/0/9
    Apr 20 20:12:01  ifdev_create entered ge-0/0/9
    Apr 20 20:12:01  ge-0/0/9: large delay buffer cleared
    Apr 20 20:12:01  pic_update_ifdev_cos_info: Remaining stats flag set on interface ge-0/0/9
    Apr 20 20:12:01  ge-0/0/9: ingress queueing cleared for QDPC
    Apr 20 20:12:01  l2, l3 and bypass = 4096, 16384, iface:ge-0/0/9 for port:9, hier:0, l2:0, l3:0,is0
    Apr 20 20:12:01  ge-0/0/9: queue capable cleared, virtual_tunnel:0, port:9, flexQ:0
    Apr 20 20:12:01  pic_update_ifdev_cos_info: remaining stats flag not set for ge-0/0/9
    Apr 20 20:12:01  fpc_is_synce_cap: FPC i2c: 0xbaa, PIC type: 0xa7d

    Apr 20 20:12:01  pic_update_ifdev_tlvs: ge-0/0/9 Not SyncE capable

    Apr 20 20:12:01  pic_update_ifdev_tlvs: ge-0/0/9 IFM type is Ether, SyncE TLV is added

    Apr 20 20:12:01  pic_update_ifdev_tlvs: ge-0/0/9 setting ifdm flag to trap l2 protocols
    Apr 20 20:12:01  mic_set_online: fpc 0 mic 0 (state Ready) pic 0 (state Online)
    Apr 20 20:12:01 CHASSISD_SNMP_TRAP10: SNMP trap generated: FRU power on (jnxFruContentsIndex 20, j)
    Apr 20 20:12:01  hwdb: entry for mic a7d at slot 0 in fpc 0 inserted
    Apr 20 20:12:01  PIC (fpc 0 pic 0) message operation: add. ifd count 10, flags 0x3 in mesg
    Apr 20 20:12:46  Acknowledgement received 0 1
    Apr 20 20:12:53 CHASSISD_MASTER_THREAD_SHC_SLIP: mcontrol hipri thread scheduling slip 4 sec, 9498c

    Also, here is my current config on the switch. Please let me know if there are any issues with any of the config relevant to trying to set a rate limit. I have the speed set at the interface level, I have class of service set for the interface and I believe I have a filter applied to the vlan as well. 

    set version 23.2R1.14
    set system host-name Lab-Switch-1
    set system root-authentication encrypted-password "$6$dEHKC5um$JGB0fYp4szl1ucesmSNtEaHy3hvTWnp/XNi"
    set system arp aging-timer 5
    set system syslog file interactive-commands interactive-commands any
    set system syslog file messages any notice
    set system syslog file messages authorization info
    set system processes dhcp-service traceoptions file dhcp_logfile
    set system processes dhcp-service traceoptions file size 10m
    set system processes dhcp-service traceoptions level all
    set system processes dhcp-service traceoptions flag packet
    set interfaces ge-0/0/1 description "Link to LabServer"
    set interfaces ge-0/0/1 speed 10m
    set interfaces ge-0/0/1 unit 0 family ethernet-switching interface-mode access
    set interfaces ge-0/0/1 unit 0 family ethernet-switching vlan members Vlan10
    set interfaces ge-0/0/2 description "Link to LabPC"
    set interfaces ge-0/0/2 speed 10m
    set interfaces ge-0/0/2 unit 0 family ethernet-switching interface-mode access
    set interfaces ge-0/0/2 unit 0 family ethernet-switching vlan members Vlan10
    set interfaces ge-0/0/3 description "Link to Fortigate"
    set interfaces ge-0/0/3 unit 0 family ethernet-switching interface-mode access
    set interfaces ge-0/0/3 unit 0 family ethernet-switching vlan members Vlan10
    set interfaces fxp0 unit 0 family inet address 10.0.0.1/24
    set interfaces fxp0 unit 0 family inet6 dhcpv6-client client-type stateful
    set interfaces fxp0 unit 0 family inet6 dhcpv6-client client-ia-type ia-na
    set interfaces fxp0 unit 0 family inet6 dhcpv6-client client-identifier duid-type duid-ll
    set interfaces fxp0 unit 0 family inet6 dhcpv6-client vendor-id Juniper:ex9214:VM660F03B891
    set interfaces irb unit 10 family inet filter input filter1
    set interfaces irb unit 10 family inet filter output filter1
    set interfaces irb unit 10 family inet address 10.10.10.1/24
    set multi-chassis mc-lag consistency-check
    set class-of-service interfaces ge-0/0/1 shaping-rate 10m
    set class-of-service interfaces ge-0/0/2 shaping-rate 10m
    set firewall family inet filter filter1 term 0 from source-address 10.10.10.0/24
    set firewall family inet filter filter1 term 0 then policer policer-2mb
    set firewall family inet filter filter1 term 0 then accept
    set firewall policer policer-2mb if-exceeding bandwidth-limit 2m
    set firewall policer policer-2mb if-exceeding burst-size-limit 625k
    set firewall policer policer-2mb then discard
    set protocols router-advertisement interface fxp0.0 managed-configuration
    set protocols lldp interface all
    set protocols lldp-med interface all
    set vlans Vlan10 vlan-id 10
    set vlans Vlan10 l3-interface irb.10
    set vlans Vlan20 vlan-id 20
    set vlans Vlan30 vlan-id 30
    set vlans Vlan40 vlan-id 40
    set vlans Vlan50 vlan-id 50
    set vlans Vlan60 vlan-id 60

    root@Lab-Switch-1>



    ------------------------------
    James Joseph
    ------------------------------