Labs

 View Only
last person joined: 3 days ago 

Discover how to get the most of Juniper labs and share what you've built.
  • 1.  vEX ae interface not working

    Posted 10-02-2023 07:11

    After configure ae0 interface by following command, I cannot see ae0 in >show interface terse output. And I use >show interface ae0 will get "error: device ae0 not found" error message.

    Does aggregated ethernet interface not support in vEX? ( I've been try 23.1R1.8 and 23.3R1.14 )

    I hope someone can help me experiment with this issue. If successful, could you please let me know how you configured it?

    Thank you!

    AE0 interface Configuration: 

    set interface ge-0/0/0 ether-options 802.3ad ae0
    set interface ge-0/0/1 ether-options 802.3ad ae0
    set interfaces ae0 native-vlan-id 33
    set interfaces ae0 aggregated-ether-options lacp active
    set interfaces ae0 unit 0 family ethernet-switching interface-mode trunk
    set interfaces ae0 unit 0 family ethernet-switching vlan members vTest-100



    ------------------------------
    CSIT NETTA
    ------------------------------


  • 2.  RE: vEX ae interface not working
    Best Answer

    Posted 10-02-2023 09:56
    Please try adding the following to your config.
    set chassis aggregated-devices ethernet device-count 6


    TJ Panesar
    Solutions Architect | JNCIE-DC #506    
    713-906-8571 mobile
    TJ.Panesar@gdt.com



    GDT Innovation Campus, 999 Metromedia Place Dallas, TX 75247
     
    Facebook | Twitter | LinkedIn


    NOTICE: This email and any attachments are for the exclusive and confidential use of the intended recipient(s). If you are not an intended recipient, please do not read, distribute, or take action in reliance upon this message. If you have received this in error, please notify me immediately by return email and promptly delete this message and its attachments from your computer.




  • 3.  RE: vEX ae interface not working

    Posted 10-02-2023 15:24
    Edited by spuluka 10-02-2023 19:39

    I see, I apologize for my oversight. This configuration indeed resolved my issue! Thank you very much!!!

    I also have another question need help which is that I change one vEX to Cisco Nexus NXOSv 9300 9.3.9 and I found trunk on ae0 is not work between NXOSv and vEX trunk port.
    I use an PC which connect to vEX and ping NXOSv SVI ip address will say not reachable.
    Is there any issue existing or unsupport between the Cisco NXOSv and Juniper vEX ?  (There's no problem when two device is vEX)

    Two Devices Configuration:
    Juniper vEX: (default MTU is 1514, I'm not sure if having different MTU might cause any issues )
    set chassis aggregated-devices ethernet device-count 6
    set chassis fpc 0 pic 0 number-of-ports 52
    set vlans vTest-100 vlan-id 100
    set vlans vTest-100 switch-options mac-move-limit 2
    set vlans vTest-100 switch-options mac-move-limit packet-action log
    set interfaces ae0 native-vlan-id 33
    set interfaces ae0 mtu 1500
    set interfaces ae0 aggregated-ether-options lacp active
    set interfaces ae0 unit 0 family ethernet-switching interface-mode trunk
    set interfaces ae0 unit 0 family ethernet-switching vlan members vTest-100
    set interfaces ge-0/0/48 ether-options 802.3ad ae0
    set interfaces ge-0/0/49 ether-options 802.3ad ae0
    set interfaces interface-range TEST-range member ge-0/0/3
    set interfaces interface-range TEST-range unit 0 family ethernet-switching interface-mode acces

    set interfaces interface-range TEST-range unit 0 family ethernet-switching vlan members vTest-100

    Nexus: (po2 include eth1/3 and eth1/4)
    interface Vlan100
      ip address 10.1.100.0/24
    interface port-channel2
      switchport mode trunk
      switchport trunk native vlan 33
      switchport trunk allowed vlan 100



    ------------------------------
    CSIT NETTA
    ------------------------------



  • 4.  RE: vEX ae interface not working

    Posted 10-02-2023 19:39
    Change the Juniper MTU to 1514
    https://irfansalam.wordpress.com/2013/12/19/mtu-difference-between-cisco-and-juniper/




  • 5.  RE: vEX ae interface not working

    Posted 10-04-2023 04:58
    Edited by CSIT NETTA 10-04-2023 04:59

    I create a new vEX and everything is work fine.
    Thank you very much for your assistance, all of my problems have been resolved!



    ------------------------------
    CSIT NETTA
    ------------------------------