Switching

 View Only
last person joined: 14 hours ago 

Ask questions and share experiences about EX and QFX portfolios and all switching solutions across your data center, campus, and branch locations.
  • 1.  Trunking to Cisco

    Posted 6 days ago
    Have a Trunk port between Cisco and Juniper.   Only the Native VLAN seems to be working.  Native is set to VLAN3  my other VLANS 5, 10 do not work.

    ------------------------------
    STEPHEN BAUER
    ------------------------------


  • 2.  RE: Trunking to Cisco

     
    Posted 6 days ago
    Relevant configs from both sides would be helpful.


  • 3.  RE: Trunking to Cisco

    Posted 6 days ago
    Juniper Trunk port
    interfaces {
    ge-0/0/0 {
    apply-macro juniper-port-profile {
    "Layer 2 Uplink";
    }
    native-vlan-id 3;
    unit 0 {
    family ethernet-switching {
    interface-mode trunk;
    vlan {
    members [ FirstFL VLAN10 VOIP WIFI default all ]

    Cisco side
    interface GigabitEthernet4/0/44
    switchport access vlan 3
    switchport trunk encapsulation dot1q
    switchport mode trunk
    speed 1000
    duplex full
    service-policy input TONH

    ------------------------------
    STEPHEN BAUER
    ------------------------------



  • 4.  RE: Trunking to Cisco

    Posted 5 days ago
    Here are the correct port configs

    Juniper

    interfaces {
    ge-0/0/0 {
    native-vlan-id 3;
    unit 0 {
    family ethernet-switching {
    interface-mode trunk;
    vlan {
    members [ FirstFL VLAN10 VOIP WIFI ];

    Cisco
    interface GigabitEthernet0/2
    switchport trunk native vlan 3
    switchport trunk allowed vlan 3,5,10
    switchport mode trunk
    service-policy input TONH

    ------------------------------
    STEPHEN BAUER
    ------------------------------



  • 5.  RE: Trunking to Cisco

    Posted 2 hours ago
    Hi, 

    Please review KB below, and proceed to change the configuration as needed depending on switch platform. (ELS / non-ELS).  

    ELS: https://supportportal.juniper.net/s/article/EX-QFX-Native-VLAN-behavior-on-ELS-JUNOS-OS-versions?language=en_US 
    Non-ELS: https://supportportal.juniper.net/s/article/EX-Native-VLAN-ID-and-tagged-behavior-in-EX-series-switches?language=en_US 

    non-ELS: EX2200 /EX3300/EX4200/EX4500/EX4550 ...
    ELS: EX2300/EX3400/EX4300/EX4600/QFX ....  

    PD:  check STP interoperability as well.  
    [EX] VSTP and RPVST+ convergence on native-vlan 1 - https://supportportal.juniper.net/s/article/EX-VSTP-and-RPVST-convergence-on-native-vlan-1?language=en_US


    I hope this helps!  

    Esteban