Switching

 View Only
last person joined: 4 days ago 

Ask questions and share experiences about EX and QFX portfolios and all switching solutions across your data center, campus, and branch locations.
  • 1.  No other ABR information found in multi area ospf

    Posted 14 days ago

    Dear Team

    Please assist me in pinpointing the precise reason for the failure to identify all ABR (Area Border Router) information for area 6.6.6.6 in the attached multi-area OSPF scenario. In the database of Router 5 (R5), only one ABR (itself) is listed for area 6.6.6.6. However, upon inspection of the OSPF database on all other routers, I can observe that four ABRs are listed. I have provided the router configuration for clarity, and please let me know if additional information from the router configuration is required.

    Thanks...

    Configuration :

    R3
    set protocols ospf area 6.6.6.6 stub default-metric 67
    set protocols ospf area 6.6.6.6 stub no-summaries
    set protocols ospf area 6.6.6.6 network-summary-export OSPF-To-customer
     
    set policy-options policy-statement OSPF-To-customer term A from route-filter 0.0.0.0/0 exact
    set policy-options policy-statement OSPF-To-customer term A then accept
    set policy-options policy-statement OSPF-To-customer term B then reject
    set policy-options policy-statement OSPF-To-customer term else then reject
     
    set interfaces irb unit 1455 family inet address 10.51.25.217/30
    set protocols ospf area 0.0.0.0 interface irb.1455 priority 129
    set vlans ospf-with-r5 vlan-id 1455
    set vlans ospf-with-r5 l3-interface irb.1455
     
    show ospf database area 6.6.6.6 summary :
    Area 6.6.6.6:
       165 Router LSAs
       262 Network LSAs
       4 Summary LSAs
     
     
     
    R5
    set interfaces xe-0/2/0 unit 0 family inet address 10.51.25.218/30
    set protocols ospf area 0.0.0.0 interface xe-0/2/0.0 priority 1
     
    set protocols ospf area 6.6.6.6 stub default-metric 100
    set protocols ospf area 6.6.6.6 stub no-summaries
    set protocols ospf area 6.6.6.6 network-summary-export OSPF-To-customer
     
    set policy-options policy-statement OSPF-To-customer term A from route-filter 0.0.0.0/0 exact
    set policy-options policy-statement OSPF-To-customer term A then accept
    set policy-options policy-statement OSPF-To-customer term B then reject
    set policy-options policy-statement OSPF-To-customer term else then reject
     
     
    show ospf database area 6.6.6.6 summary
    Area 6.6.6.6:
       28 Router LSAs
       29 Network LSAs
       1 Summary LSAs


    ------------------------------
    SOUMEN GHOSH
    ------------------------------


  • 2.  RE: No other ABR information found in multi area ospf

    Posted 13 days ago

    In your diagram you actually have five different «areas 6», which is not expected to work (you are expected to have five different identifiers for the five current «areas 6»).



    ------------------------------
    Olivier Benghozi
    ------------------------------