View Only
last person joined: yesterday 

Ask questions and share experiences about EX and QFX portfolios and all switching solutions across your data center, campus, and branch locations.
  • 1.  New EX2300 Switch Can't Reach Internet (and Mist)

    Posted 09-11-2023 16:39
      |   view attached

    We recently purchased new Juniper EX2300 switches. They are a little more difficult than I was expecting to get set-up. 

    I am trying to get them connected to the internet and then to Mist to manage them. After following the instructions that I could find and understand, I was not closer to connecting, so I tried factory-resetting the switch. I am still not able to connect. Juniper support has not been very helpful and has chosen to send me off to KB articles I do not understand.

    If anyone could take the time to help me out, you would be really cool! I don't mind setting up the management interface or one of the switchports to connect.

    Attached is:
    show route
    show interfaces terse | match inet
    show interfaces terse | match irb
    show vlans

    Ping to



  • 2.  RE: New EX2300 Switch Can't Reach Internet (and Mist)

    Posted 09-12-2023 01:52


    In the "show route" output, there is no default-route. It has a valid route to the network via the me0 interfaces. The other interfaces are down. The switch can't reach the internet because of this.     *[Direct/0] 01:59:16
                        >  via me0.0     *[Local/0] 01:59:16
                           Local via me0.0

    Which interface do you intend to use to reach the internet? If it is me0.0, then you need to have a default-route configured pointing out of the me0.0 interfaces. The other physical interface ge-0/0/0.0 is down, and the irb interface is not assigned to any vlan, thus it is down as well.

    To reach Mist, you will also need to configure a DNS server on the switch.


    Sheetanshu Shekhar

  • 3.  RE: New EX2300 Switch Can't Reach Internet (and Mist)

    Posted 09-12-2023 10:43

    I don't see a default route nor DNS server configured, you need,

    set routing-options static route next-hop  #(or whatever you're gateway is)
    set system name-server
    Where are you trying to get access from, ge-0/0 or mgmt or the irb?
    What is your gateway/NAT device?