Junos OS

 View Only
last person joined: 2 days ago 

Ask questions and share experiences about Junos OS.
  • 1.  Nat Multicast

    This message was posted by a user wishing to remain anonymous
    Posted 06-15-2024 20:16
    This message was posted by a user wishing to remain anonymous

    Dear wonderful team,

    I have a cisco 7200 as src Mcast 239.16.1.1. it is running sparse mode with SRX 340. I have setup destination nat on ge-0/0/1 to nat mcast from 239.16.1.1 to 239.141.1.10.

    destination nat on SRX:

    set security nat destination pool NAT_Mcast address 239.141.1.10/32

    set security nat destination rule-set NAT_Mcast_1 from interface ge-0/0/1.0

    set security nat destination rule-set NAT_Mcast_1 rule R1 match destination-address 239.16.1.1/32

    set security nat destination rule-set NAT_Mcast_1 rule R1 then destination-nat pool NAT_Mcast

    with sparse mode, it does not nat and does not NAT. when I switch to dense-mode, it works as expected.

    PIM neighbor is up on both side (SRX and Src Mcast)

    rp on SRX:

    set protocols pim rp static address 192.168.0.1 group-ranges 239.141.1.10/32

    set protocols pim rp static address 192.168.1.1 group-ranges 239.16.1.1/32

    rp on src Mcast cisco:

    ip pim rp-add 192.168.1.1 239.16.1.1

    I changed the RP address for 239.16.1.1 to 192.168.1.2, but no luck

    however, when I replace src Mcast cisco router with a PC, it nats properly.

    unicast routing is good.

    SRX interface:

    set interfaces ge-0/0/1 unit 0 family inet address 192.168.1.1/24

    set protocols ospf area 0.0.0.0 interface ge-0/0/1.0

    set protocols igmp interface ge-0/0/1.0 static group 239.16.1.1

    set protocols pim interface ge-0/0/1.0 mode sparse

    Cisco interface:

    interface FastEthernet0/0

    ip address 192.168.1.2 255.255.255.0

    ip pim sparse-mode

    ip igmp join-group 239.16.1.1

    duplex half

    any idea why sparse mode does make SRX not to nat?

    thanks in advance