Hello. Coming from a Cisco environment, Juniper is really throwing me off. It's my first time doing this on Juniper and the legacy or extended commands is confusing me because different things keep coming up when I search this topic online. I just need this switch to have a local DHCP server, at the moment I want it to hand an IP to the PC connected to ge-0/0/6 and I just can't get it to happen, always shows no bindings when I verify. I followed these instructions:
DHCP for Switches - TechLibrary - Juniper Networks at the "configuring the switch as a local DHCP server" section.
root@LakeLA_Switch# run show configuration
## Last commit: 2021-12-29 00:46:26 UTC by root
version 20.2R3.9;
system {
host-name LakeLA_Switch;
root-authentication {
encrypted-password "$6$x5N3k3nC$2UdfmaWz7eMx9BD8YDcjlF6mKaop0HPliTalaIS2Vf7OFnwjhhzvyb07VoXDL9yQIe1cTqsj35vDBcHDm2mWS."; ## SECRET-DATA
}
services {
dhcp-local-server {
traceoptions { ## Warning: 'traceoptions' is deprecated
file jdhcplog;
flag all;
}
group ezsetup-ge0 {
interface ge-0/0/0.0;
}
group ezsetup-me0 {
interface me0.0;
}
group WorkstationGroup {
interface ge-0/0/6.0;
interface irb.180;
}
}
web-management {
http;
}
}
syslog {
user * {
any emergency;
}
file messages {
any notice;
authorization info;
}
}
ntp {
server 162.159.200.1;
}
}
interfaces {
ge-0/0/0 {
unit 0 {
description Link_To_Firewall;
family inet;
}
}
ge-0/0/6 {
description Link_To_Workstation;
unit 0 {
family inet {
address 10.92.180.5/24;
}
}
}
irb {
unit 180 {
family inet {
address 10.92.180.2/24;
}
}
}
me0 {
unit 0 {
family inet {
address 192.168.2.1/24 {
primary;
}
}
}
}
}
access {
address-assignment {
pool ezsetup-ge0 {
family inet {
network 192.168.1.0/24;
range limited {
low 192.168.1.2;
high 192.168.1.253;
}
}
}
pool ezsetup-me0 {
family inet {
network 192.168.2.0/24;
range limited {
low 192.168.2.2;
high 192.168.2.253;
}
}
}
pool WorkstationPool {
family inet {
network 10.92.180.0/24;
range WorkstationRange {
low 10.92.180.5;
high 10.92.180.150;
}
dhcp-attributes {
router {
10.92.180.1;
}
}
}
}
}
}
routing-options {
static {
route 0.0.0.0/0 next-hop [ 10.92.180.1 98.152.137.66 ];
}
}
vlans {
Workstations {
vlan-id 180;
l3-interface irb.180;
}
}
root@LakeLA_Switch# run show dhcp server binding
{master:0}[edit]