Junos OS

 View Only
last person joined: 22 hours ago 

Ask questions and share experiences about Junos OS.
Expand all | Collapse all

"load override terminal" not correct

  • 1.  "load override terminal" not correct

    Posted 05-02-2008 08:50
    Hi Group,

    On one of our M120 router in version 8.4R3.3 I see a strange behavior.

    When I load a new configuration, with the command "load override terminal", the router give me an error even if there is no problem in my configuration. If I test to load my configuration on an other router (the same model) it works. This is what I see:

    toto@MY_ROUTER# load override terminal
    ...
    load complete

    [edit]
    toto@MY_ROUTER# commit check
    /var/run/db/private/juniper-4917.patch:818:(0) syntax error
      [edit]
        'prefix-list external-project { ... }'
          syntax error

    To give you an other example, always with the same router, if I load the "factory-default" configuration this is the error:

    [edit]
    toto@MY_ROUTER# load factory-default
    warning: activating factory configuration

    [edit]
    toto@MY_ROUTER# ...ication plain-text-password                         
    New password:
    Retype new password:

    [edit]
    toto@MY_ROUTER# show
    ## Last changed: 2008-05-02 16:16:17 CEST
    system {
        root-authentication {
            encrypted-password "$1$pkIpJBkH$dzGoRuNXMX/g30jdlsfs00"; ## SECRET-DATA
        }
        syslog {
            user * {
                any emergency;
            }
            file messages {
                any notice;
                authorization info;
            }
            file interactive-commands {
                interactive-commands any;
            }
        }
    }

    [edit]
    toto@MY_ROUTER# commit synchronize
    [edit system login]
      'user'
        patch removes statement that is not empty

    Have you already seen this problem? On my side I have already seen this issue with a T640 in version 8.5V2.10.

    Do you think there is a problem with the database?

    Thanks for your help and your tricks.

    Regards,
    Samuel


  • 2.  RE: "load override terminal" not correct

    Posted 05-03-2008 01:33

    Hi,

     

    Just for my curiosity, does 'commit full' change anything? 

     

    Have a nice day,

    G. 



  • 3.  RE: "load override terminal" not correct

    Posted 05-05-2008 00:40

    "commit", "commit synchronise", "commit full", the problem is always the same.

     

     

    [edit]
    toto@MY_ROUTER# load factory-default
    warning: activating factory configuration

    [edit]
    toto@MY_ROUTER# set system root-authentication plain-text-password
    New password:
    Retype new password:


    [edit]
    toto@MY_ROUTER# show
    ## Last changed: 2008-05-05 09:33:03 CEST
    system {
        root-authentication {
            encrypted-password "$1$0n633nCZ$loMRjS4VTc.dV.QCQAMIu."; ## SECRET-DATA
        }
        syslog {
            user * {
                any emergency;
            }
            file messages {
                any notice;
                authorization info;
            }
            file interactive-commands {
                interactive-commands any;
            }
        }
    }


    [edit]
    toto@MY_ROUTER# commit
    [edit system login]
      'user'
        patch removes statement that is not empty

    [edit]
    toto@MY_ROUTER# commit synchronize
    [edit system login]
      'user'
        patch removes statement that is not empty

    toto@MY_ROUTER# commit full  
    [edit system login]
      'user'
        patch removes statement that is not empty



  • 4.  RE: "load override terminal" not correct

    Posted 05-05-2008 02:13

    Hello again,

     

    I'm definitely not a wise man here :), but perhaps there is some file/statement left which is messing so much. I haven't seen M120 so this could be totally wrong, but is there a way to boot it from removable media? It should get Medieval on the router (incl. filesystem, afaik) make it fresh'n'clean and hopefully frag the bug. Sometime ago I heard about dangerous way to resolve some config locking problem. It was suggested to remove  /var/rundb/juniper* files, don't know is it relevant here.

     

    One more thing, could You please paste ' commit check | display detail' output here?

     

    PS: If You get any info from JTAC, it would be nice to share it with me 🙂

     

    Have a nice day,

    Gniewko

    Message Edited by Gniewko on 05-05-2008 12:17 PM
    Message Edited by Gniewko on 05-05-2008 12:39 PM


  • 5.  RE: "load override terminal" not correct
    Best Answer

    Posted 05-05-2008 02:55

    I have found a trick. Until now I did all my tests in "configure private" mode. In this mode there is the problem. If I use "configure" mode the problem disapear.

    Here is what I see:

    toto@MY_ROUTER> configure private
    warning: uncommitted changes will be discarded on exit
    Entering configuration mode

    [edit]
    toto@MY_ROUTER# load factory-default
    warning: activating factory configuration

    [edit]
    toto@MY_ROUTER# set system root-authentication plain-text-password
    New password:
    Retype new password:

    [edit]
    toto@MY_ROUTER# commit check
    [edit system login]
      'user'
        patch removes statement that is not empty

    [edit]
    toto@MY_ROUTER# rollback

    [edit]
    toto@MY_ROUTER# exit
    Exiting configuration mode



    toto@MY_ROUTER> configure
    Entering configuration mode

    [edit]
    toto@MY_ROUTER# load factory-default                                
    warning: activating factory configuration

    [edit]
    toto@MY_ROUTER# set system root-authentication plain-text-password   
    New password:
    Retype new password:

    [edit]
    toto@MY_ROUTER# commit check
    configuration check succeeds



    I see no public PR open about this issue.

    I have inform the JTAC about it. We will see their conclusion.

     

    Regards,
    Samuel



  • 6.  RE: "load override terminal" not correct

    Posted 05-22-2008 23:48
    PR #293207 has been openned.


  • 7.  RE: "load override terminal" not correct

    Posted 12-16-2014 11:41

    Thank you for describing the workaround for this problem.

     

    I just ran into this problem on an SRX240H2 running Junos 12.1X47-D15.4.

    Trying to commit while in "configure private" gives the error. Running a commit (Full) in "configure" solves it.



  • 8.  RE: "load override terminal" not correct

     
    Posted 04-27-2015 06:49
    I am experiencing the opposite problem. I have a SRX240H2 cluster running 12.1X44-D40.2 and if I edit with a simple "configure", i get the error on commit. If I edit with "configure exclusive", I don't get the error on commit... The config that I'm attempting to remove is an inactive 'groups' group that contains interfaces, security (nat, policies and zones) and applications.


  • 9.  RE: "load override terminal" not correct

     
    Posted 06-04-2024 02:52

    It's not the opposite: Clusters default to "configure private" (as the CLI should indicate).  Ulf




  • 10.  RE: "load override terminal" not correct

    Posted 06-03-2024 18:10

    I am having an issue using "load override terminal" as well. Does not matter what configure mode I am in, the first line (and doesn't matter what the set command is) always throws a syntax error. When CTRL+D to finish, it says there was 1 error. When I commit it, it says it can't commit an empty configuration.
    Specifics
    Model: ex4300-48p
    Junos: 21.4R3-S4.18

    JA1# load override terminal


    [Type ^D at a new line to end input]
    set groups phcd_vc_preprovision **DOES NOT MATTER WHAT COMMAND THIS IS, ALWAYS THROWS A SYNTAX ERROR**

    terminal:1:(3) syntax error: set
      [edit dynamic]
        'set groups phcd_vc_preprovision'
          syntax error

    set vlans default l3-interface irb.0

    ^D
    load complete (1 errors)

    JA1# commit


    error: cannot commit an empty configuration



    ------------------------------
    D WILLIAM MORTON
    ------------------------------



  • 11.  RE: "load override terminal" not correct

     
    Posted 06-04-2024 01:43

    Hi,

    please use 'load set ...' for configuration in "set ..."-format.

    Regards

    Ulf




  • 12.  RE: "load override terminal" not correct

     
    Posted 06-04-2024 04:01

    Like Ulf wrote below, the "load override" command takes input in the Juniper hierarchical configuration format, so similar to this for example:

    interfaces {
       ge-0/0/0 {
          disable;
       }
    }

    If you want to use "set" commands you'll need to use "load set" instead.
    Also note that if you use "load override" it will fully erase the config and replace it with the config you load in the terminal so you have to make sure it's a complete configuration there. You can replicate the same behavior in a "load set" format by having your first command just be "delete", not "delete <something>" but a flat and simple "delete" (note the risks, and be sure to do a "show | compare" after to ensure it didnt throw away anything you wanted to keep or forgot to re-add.

    Here is the Juniper reference for the "load" command outlining the different "load" options
    load | Junos OS | Juniper Networks

    There are essentially