Junos OS

 View Only
last person joined: 2 days ago 

Ask questions and share experiences about Junos OS.
Expand all | Collapse all

getting root@:~ # prompt

  • 1.  getting root@:~ # prompt

    Posted 01-18-2023 10:33
    Hello all,

    first time posting here. I have an EX3400/48 and I tried to upgrade the version to 20.4R3-S2.6 via a flash drive. I ran the 'request system reboot usb' and all seemed well but now I'm stuck at the 'root@:~#'...

    I tried rebooting with and without the flash, when I type cli I'm getting...root@:~ # cli
    Nov 18 09:38:13 cli: login_getclass: unknown class 'j-idle-timeout'
    could not open user interface connection: management daemon not responding
    Retry connection attempts ? [yes,no] (yes) 

    yes or no does nothing to fix it. I'm hoping someone on here has a solution. Thanks in advance!


  • 2.  RE: getting root@:~ # prompt

    Posted 01-19-2023 09:38

    U can do reformat method to make sure your switch back to normal.


  • 3.  RE: getting root@:~ # prompt

    Posted 01-19-2023 10:28
    Here is the process.  I have used it many times with great success.

    [EX] How to format install EX2300s and EX3400s via USB (juniper.net)


  • 4.  RE: getting root@:~ # prompt

    Posted 07-11-2023 12:53

    Late to the show but what if you cant get past the root@:~ # and there is no option on startup to do a CTRL-C to get to the boot menu. Mine only immediately boots to:

    In:    eserial1
    Out:   eserial1
    Err:   eserial1
    FreeBSD/arm (Amnesiac) (ttyu0)
    login: root
    Last login: Tue Jul 11 12:20:59 on ttyu0
    --- JUNOS 22.4R1.10 Kernel 32-bit  JNPR-12.1-20221121.c470123_buil
    root@:~ #


  • 5.  RE: getting root@:~ # prompt

    Posted 01-19-2023 10:44
    Hey kronicklez, thanks for the reply...it looks like i may have to. I normally do a 'request systemzeroize', what method are you talking about?


  • 6.  RE: getting root@:~ # prompt

    Posted 01-19-2023 11:02
    Hi teichi,

    I referring use USB install media method. So it will totally reformat the switch like coming from factory.


  • 7.  RE: getting root@:~ # prompt

    Posted 01-19-2023 11:47
    Ok so I followed the kb instructions and booted off a usb. All looked good and it said successful but it asked for the date to be fixed ??? What is the command to set the correct date at root@:~# prompt? there is a 'date' option but I can't get the correct format. 

    * I searched Google but came up empty


  • 8.  RE: getting root@:~ # prompt

    Posted 01-19-2023 16:36
    I think it is:
    date YYYYMMDDhhmmss

    I had the same issue with a switch where the date was set before the package was created causing the issue. You may only have to set the date and not the time.
    Once you set the date, reboot and start the format install again.

    Hope this helps.


  • 9.  RE: getting root@:~ # prompt

    Posted 01-19-2023 16:46
    Actually I just re-read your previous post.  If the format install did complete, you can use "set date".

    I also think if you plug the management port into your network and set system ntp server, it will update as well.


  • 10.  RE: getting root@:~ # prompt

    Posted 01-20-2023 08:51
    Hey Paul,

    Thanks for the reply, I tried 'set date 202301200845ss but I'm getting this error... I've tried using different date formats but still not accepting.

    root> set date 202301200843ss
    error: invalid time string: '202301200843ss'
    error: Time value format is '[[[[[CC]YY]MM]DD]hh]mm.[ss]'

  • 11.  RE: getting root@:~ # prompt

    Posted 01-20-2023 10:41
    To set the date you need to be in operational mode (ie: issue the 'cli' command ) - then enter the command 'set date <time>' where <time> is in the format YYYYMMDDhhmm.ss