Switching

 View Only
last person joined: 3 days ago 

Ask questions and share experiences about EX and QFX portfolios and all switching solutions across your data center, campus, and branch locations.
  • 1.  EX4600 - QinQ with ERPS

    Posted 06-08-2022 19:21

    I have this interface that S-tags ingress traffic (QnQ):

     

    interface ge-0/0/10
    flexible-vlan-tagging;
    native-vlan-id 2;
    mtu 9200;
    encapsulation extended-vlan-bridge;
    unit 148 {
        vlan-id-list 1-4094;
        input-vlan-map push;
        output-vlan-map pop;
    }

    set vlans v148T interface ge-0/0/10.148

     
    I have this switch interface, that is actually part of an ITU.8032 group: 

    interface xe-0/0/23                             
    enable;
    vlan-tagging;
    mtu 9200;
    encapsulation flexible-ethernet-services;
    unit 1 {
        family ethernet-switching {
            interface-mode trunk;
            vlan {
                members [ 36 ];
            }
        }
    }

     

     

    I cannot add v148T to the member list of xe-0/0/23.1, because v148T has no actual vlan-id.  And I cannot add a vlan-id to  v148T - it creates 3 config errors on ge-0/0/10.    

    So how does one get an SVID for QnQ into a switch list in Junos ?

     

    I also have to be able to add the vlan-id to the erps 8032 protection group data and tha list can only be vlan-id numbers. For example:

    set protocols protection-group ethernet-ring LA01-W12 data-channel vlan 148


    BTW the Cisco equivalent of this is:

     

    interface GigabitEthernet7/20

      switchport mode dot1q-tunnel

    switchport access vlan 148     ! vlan-id 148 can be added to any switching port list

     

    Do I have to trunk vlan v148T out of the switch and bring it back in again on vlan-id 148 ?

     

     

    Routing instance        VLAN name             Tag          Interfaces

    default-switch          v148T                 NA      

                                                               ge-0/0/10.148*



    ------------------------------
    M. Alex Herron
    ------------------------------


  • 2.  RE: EX4600 - QinQ with ERPS

    Posted 06-09-2022 05:47
    Hi Alex,  

    see this KB: https://supportportal.juniper.net/s/article/EX-QFX-How-to-configure-QinQ-using-ELS-on-Junos-OS?language=en_US  

    First option: 
    set interfaces xe-0/0/23 flexible-vlan-tagging
    set interfaces xe-0/0/23 encapsulation extended-vlan-bridge
    set interfaces xe-0/0/23 unit 148 vlan-id 148

    Second options: 
    root@c13-9# show | display set
    set interfaces xe-0/0/23 flexible-vlan-tagging
    set interfaces xe-0/0/23 encapsulation flexible-ethernet-services
    set interfaces xe-0/0/23 unit 36 encapsulation vlan-bridge
    set interfaces xe-0/0/23 unit 36 vlan-id 36
    set interfaces xe-0/0/23 unit 148 vlan-id 148

    {master:0}[edit interfaces xe-0/0/23]

    set interfaces xe-0/0/23 unit 0 vlan-id 36 ==== I will need to further test this in the lab and validate how we make this to work as you would like to use interface 23 under family ethernet-switching (trunk) as well, kind of using SP style of configuration combined with Enterprise style of config.  

    let me know how above configuration change goes and if it make any difference ...  

    Esteban