View Only
last person joined: 20 hours ago 

Ask questions and share experiences about EX and QFX portfolios and all switching solutions across your data center, campus, and branch locations.
  • 1.  EX2300 won't boot after "request system zeroize"

    Posted 08-04-2021 08:59

    After using a brand new EX2300 on a very simple Virtual Chassis (2 members) test scenario, I unmade the VC and then, via console, issued the command "request system zeroize", after that the switch was no longer able to boot.

    I've read all the available documentation regarding recovery methods but none of them apply to my case. Because I am unable to get any kind of prompt or shell. I have also prepared a recovery USB according to documentation/KB but the switch won't automatically boot from it.

    This is the output I always get from console:

    U-Boot 2016.01-rc1 (Nov 11 2016 - 14:26:00 -0800) VERSION=1.3.2
    U-Boot code: F0000000 -> F007C59C  BSS: -> F00DA238
    DRAM:  DEV ID = 0xb064
    SKU ID = 0xb064
    DDR type: DDR3
    MEMC 0 DDR speed = 800MHz
    PHY revision version: 0x00a1e003
    A Series - PHY Initialization (PHY index: 00)
    A01. Turn off CKE
    A02. Configure timing parameters
    A03. Configure PHY PLL
         PHY PLL Configuration
         Fref.............:   50 MHz
         Data rate........: 1600 Mbps
         PLL locked.
    A04. Configure reference voltage
    A05. Compute VDL step size
         VDL calibration complete.
         VDL step size....:   7.716 ps
         UI size..........:  81.000 steps
    A06. Configure ADDR/CTRL VDLs
    A07. Disable Virtual VTT
    A08. ZQ calibration
         P drive..........: 0x10
         N drive..........: 0x10
         P termination....: 0x06
         N termination....: 0x06
         P idle...........: 0x00
         N idle...........: 0x00
    A09. Configure Static Pad Control
    A10. Configure ODT
    A11. Configure Write Pre-/Post-amble
    A12. Configure Auto Idle
    A13. Release PHY control
    A Series - PHY Initialization complete (PHY index: 00)
    Programming controller register
    Validate Shmoo parameters stored in flash ..... OK
    DDR Tuning Complete
    Running simple memory test ..... OK
    DDR Interface Ready
    Monitor len: 000DA238
    Ram size: 80000000
    Ram top: E0000000
    TLB table from dfff0000 to dfff4000
    Reserving 872k for U-Boot at: dff15000
    Reserving 320k for malloc() at: dfec5000
    Reserving 80 Bytes for Board Info at: dfec4fb0
    Reserving 176 Bytes for Global Data at: dfec4f00
    RAM Configuration:
    Bank #0: 60000000
    DRAM:  New Stack Pointer is: dfec4ee0
    Relocation Offset is: eff15000
    Relocating to dff15000, new gd at dfec4f00, sp at dfec4ee0
     PCIe clk val:04
     PCIe clk val:00
    Now running in RAM - U-Boot at: dff15000
    SF: Detected MX25L6405D with page size 256 Bytes, erase size 64 KiB, total 8 MiB
    In:    eserial1
    Out:   eserial1
    Err:   eserial1​

    This output keeps being printed over and over again in a loop.
    I have issued the "request system zeroize" on other EX2300 switches before and they always booted normally after that.

    Is there any kind of recovery I can perform?

    Thanks in advance!


  • 2.  RE: EX2300 won't boot after "request system zeroize"

    Posted 08-04-2021 09:28
    EX2300 won't reboot automatically. Please follow below KB for recovery:


  • 3.  RE: EX2300 won't boot after "request system zeroize"

    Posted 08-04-2021 11:38
    Can you hard reboot the switch and with the console connected check if you see the loader prompt (Hit Space to enter loader) . If you see the loader prompt try to boot into Junos manually

    loader> set currdev=disk0p2
    loader> include /boot/loader.rc
    loader> boot


  • 4.  RE: EX2300 won't boot after "request system zeroize"

    Posted 08-04-2021 11:38
    Thanks for the feedback.

    I've already tried to follow that KB, unfortunatelly I'm unable to do that since I can't interrupt the boot sequence.
    Both up/down arrow and Ctrl+C do nothing and the switch keeps printing the output I sent before, in a loop.

    Despite that, I've also prepared the USB drive with the JUNOS image hoping that the switch would detect the USB and boot from it, but it does not...

    Is there any way to recover the switch in such a status?


  • 5.  RE: EX2300 won't boot after "request system zeroize"

    Posted 08-12-2021 14:20

    I had exactly the same issue, but in my case the console was simply switched to the mini-USB port on the front. As soon as I connected my console to that port instead I was able to perform the USB-boot recovery procedure.



  • 6.  RE: EX2300 won't boot after "request system zeroize"

    Posted 09-16-2021 11:22
    Hello Mario,

    Sorry for the late response.

    Your solution worked perfectly!!

    Thanks a lot for your feedback!


  • 7.  RE: EX2300 won't boot after "request system zeroize"

    Posted 09-17-2021 05:31
    Glad I could be of some help.
    The only thing I don't really understand is why it would switch the console port in the first place. Perhaps someone here knows?