Hello Sherif,
For a non-forwarding instance type, there is no "separate" forwarding table created, hence "All routes are installed into the default forwarding tables" as it says in the KB. In other words, forwarding information for a non-forwarding instance will be stored in the default forwarding tables (e.g. inet.0)
A separate forwarding table would be created for, say, a L3VPN. If you use virtual-router as the instance-type, a separate forwarding table is still created without the requirement for vrf-import|vrf-export, RT etc.
Take a look at the following example:
[edit routing-instances]
erdems@dogbert# show
NOFWD {
instance-type no-forwarding;
interface fe-0/0/3.40;
}
VROUTER {
instance-type virtual-router;
interface lo0.2;
}
VPN {
instance-type vrf;
interface lo0.1;
route-distinguisher 192.168.10.1:1001;
vrf-target target:65007:1001;
}
#
erdems@dogbert# show interfaces fe-0/0/3.40
vlan-id 40;
family inet {
address 172.16.5.5/30;
}
[edit]
erdems@dogbert# show interfaces lo0
unit 0 {
family inet {
address 192.168.10.1/32;
}
family iso {
address 49.0001.1921.6801.0001.00;
}
}
unit 1 {
family inet {
address 172.16.1.1/32;
}
}
unit 2 {
family inet {
address 172.16.2.2/32;
}
}
Now let's see how the forwarding tables look like:
erdems@dogbert# run show route forwarding-table summary | match table
Routing table: inet <<<<<<<<<< the default routing table for ipv4 prefixes
Routing table: __juniper_private1__.inet
Routing table: __juniper_private2__.inet
Routing table: VROUTER.inet <<<<<<<<<< the virtual-router instance type
Routing table: VPN.inet <<<<<<<<<< this is our vrf.
Routing table: iso
Routing table: VROUTER.iso <<<<<<<<<< the virtual-router instance type
Routing table: VPN.iso <<<<<<<<<<<<< this is our vrf.
Routing table: inet6 <<<<<<<<<< the default routing table for ipv6 prefixes
Routing table: __juniper_private1__.inet6
Routing table: VROUTER.inet6 <<<<<<<<<< the virtual-router instance type
Routing table: VPN.inet6 <<<<<<<<<<<<< this is our vrf.
Routing table: mpls
As you can see, there isn't a separate forwarding table created for routing-instance named NOFWD. In the output below, you can see that the forwarding information for fe-0/0/3.40 (172.16.5.5/30) is installed in inet.0's forwarding table, as the explanation suggests:
erdems@dogbert# run show route 172.16.5.5/30
NOFWD.inet.0: 2 destinations, 2 routes (2 active, 0 holddown, 0 hidden)
+ = Active Route, - = Last Active, * = Both
172.16.5.4/30 *[Direct/0] 00:01:53
> via fe-0/0/3.40
172.16.5.5/32 *[Local/0] 00:01:53
Local via fe-0/0/3.40
[edit interfaces lo0]
erdems@dogbert# run show route forwarding-table destination 172.16.5.5/30
Routing table: inet
Internet:
Destination Type RtRef Next hop Type Index NhRef Netif
172.16.5.4/30 intf 0 rslv 396 1 fe-0/0/3.40
Routing table: __juniper_private1__.inet
Internet:
Destination Type RtRef Next hop Type Index NhRef Netif
default perm 0 rjct 61 1
Routing table: __juniper_private2__.inet
Internet:
Destination Type RtRef Next hop Type Index NhRef Netif
default perm 0 rjct 101 1
Routing table: VROUTER.inet
Internet:
Destination Type RtRef Next hop Type Index NhRef Netif
default perm 0 rjct 462 1
Routing table: VPN.inet
Internet:
Destination Type RtRef Next hop Type Index NhRef Netif
default perm 0 rjct 435 1
I hope this clarifies it.
Thanks,
Erdem