View Only
last person joined: 6 days ago 

Ask questions and share experiences about ACX Series, CTP Series, MX Series, PTX Series, SSR Series, JRR Series, and all things routing, including portfolios and protocols.
  • 1.  DHCP Relay Not Working [ACX710]

    Posted 05-17-2023 14:29

    I have attempted to set up a DHCP relay on our Juniper ACX710. The DHCP server is a MikroTik Router. CLI below [IP Address is redacted for safety]:

    edit forwarding-options
    edit dhcp-relay
    set server-group DHCP_Server X.X.X.70
    set group DHCP11 active-server-group DHCP_Server
    set group DHCP11 interface ae0.11
    set group DHCP50 active-server-group DHCP_Server
    set group DHCP50 interface ae0.50

    ae0.11 is identified as the Data VLAN
    ae0.50 is identified as the VOIP VLAN
    ae0 aggregates xe-0/0/22 + xe-0/0/23
    MikroTik is connected to xe-0/0/0
    The IP subnet between the MikroTik and ACX710 is X.X.X.68/30 [first 3 octets redacted for safety].

    Our ACX710 currently runs as the DHCP server and this works fine. Problem is that the ACX710 is incapable of exporting DHCP Lease files so we're needing to offload DHCP Server duties to the adjacent MikroTik.

    I am 100% confident in the MikroTik's configuration. I am less familiar with Juniper. When the ACX710 is configured as a DHCP relay, and the MikroTik's DHCP Server enabled, we don't see lease requests making it to the MikroTik.

    Aaron Glowacki

  • 2.  RE: DHCP Relay Not Working [ACX710]

    Posted 05-18-2023 14:44


    I have not tried this on an ae setup but I have it working on an IRB very similarly.

    I would look at trying the following:

    set forwarding-options dhcp-relay overrides replace-ip-source-with giaddr

    Also, you should be able to pcap the relay packets pretty easy at the mtik level with the packet sniffer tool. You can get more information that way.


  • 3.  RE: DHCP Relay Not Working [ACX710]

    Posted 05-19-2023 11:01

    do you have the additional config for the interfaces??  can you verify code version as well....