SRX

 View Only
last person joined: 3 days ago 

Ask questions and share experiences about the SRX Series.
  • 1.  DHCP pool not working

    Posted 20 days ago
    Hi everyone,
    I have issue with two DHCP pools. here is only partial configuration example.

    If I am in vlan 31 I get IP address but in vlan 29 no.  I have more POOLS configured but only two give me no IP. has srx345 or junos version 19.4R3.11 some limits? or do I need somehow activate new pool? How can I do some reset of only this pool?, Thanks for answer.
    BR
    Tomas

    set system services dhcp-local-server group POOL18 interface reth2.29
    set system services dhcp-local-server group POOL7 interface reth2.31

    set access address-assignment pool POOL18 family inet network 192.168.37.64/26
    set access address-assignment pool POOL18 family inet range RANGE18 low 192.168.37.66
    set access address-assignment pool POOL18 family inet range RANGE18 high 192.168.37.100
    set access address-assignment pool POOL18 family inet dhcp-attributes name-server 192.168.5.5
    set access address-assignment pool POOL18 family inet dhcp-attributes name-server 192.168.21.21
    set access address-assignment pool POOL18 family inet dhcp-attributes router 192.168.37.126
    set access address-assignment pool POOL18 family inet dhcp-attributes propagate-settings reth2.29
    set protocols ospf area 0.0.0.1 interface reth2.29 passive
    set access address-assignment pool POOL7 family inet network 192.168.31.0/26
    set access address-assignment pool POOL7 family inet range RANGE7 low 192.168.31.2
    set access address-assignment pool POOL7 family inet range RANGE7 high 192.168.31.55
    set access address-assignment pool POOL7 family inet dhcp-attributes name-server 192.168.5.5
    set access address-assignment pool POOL7 family inet dhcp-attributes name-server 192.168.21.21
    set access address-assignment pool POOL7 family inet dhcp-attributes router 192.168.31.62
    set access address-assignment pool POOL7 family inet dhcp-attributes propagate-settings reth2.31
    set protocols ospf area 0.0.0.1 interface reth2.31 passive
    set security zones security-zone MANAGEMENT-OFFICE interfaces reth2.29
    set security zones security-zone MEETING interfaces reth2.31
    set interfaces reth2 unit 29 vlan-id 29
    set interfaces reth2 unit 29 family inet address 192.168.37.126/26
    set interfaces reth2 unit 31 vlan-id 31
    set interfaces reth2 unit 31 family inet address 192.168.31.62/26
    
    show dhcp statistics interface reth2.29
    Packets dropped:
    Total 2118
    No available addresses 2118

    Messages received:
    BOOTREQUEST 4281
    DHCPDECLINE 0
    DHCPDISCOVER 4281
    DHCPINFORM 0
    DHCPRELEASE 0
    DHCPREQUEST 0
    DHCPLEASEACTIVE 0
    DHCPLEASEUNASSIGNED 0
    DHCPLEASEUNKNOWN 0
    DHCPLEASEQUERYDONE 0

    Messages sent:
    BOOTREPLY 0
    DHCPOFFER 0
    DHCPACK 0
    DHCPNAK 0
    DHCPFORCERENEW 0

    reth2.31 no packet drops


    ------------------------------
    TOMAS J.
    ------------------------------


  • 2.  RE: DHCP pool not working

     
    Posted 4 days ago
    Hi,

    I had a quick look at your attached "config" snippet. Did you allow incoming dhcp packets in to your zones ?

    set security zones security-zone MANAGEMENT-office interface reth2.29 host-inbound-traffic system-services dhcp
    set security zones security-zone MEETING interface reth2.31 host-inbound-traffic system-services dhcp
    as I am not seeing this in your config snippet.

    hope this helps

    ------------------------------
    Marcel ten Berg
    ------------------------------