Switching

 View Only
last person joined: 5 days ago 

Ask questions and share experiences about EX and QFX portfolios and all switching solutions across your data center, campus, and branch locations.
  • 1.  Cisco to Juniper trunk

    Posted 4 days ago
    Hello, 
    Juniper newbie here !  
    I have a cisco 4900m to juniper EX2300 trunked

    Cisco trunk 

    interface TenGigabitEthernet1/7
    description Juniper
    switchport trunk allowed vlan 6,51,90,100-110,115,301-312,322,410,510-512,598
    switchport trunk allowed vlan add 599,700,710-713,911,912
    switchport mode trunk
    end

    show interfaces te1/7 trunk

    Port Mode Encapsulation Status Native vlan
    Te1/7 on 802.1q trunking 1

    Port Vlans allowed on trunk
    Te1/7 6,51,90,100-110,115,301-312,322,410,510-512,598-599,700,710-713,911-912

    Port Vlans allowed and active in management domain
    Te1/7 6,51,90,100-107,109-110,115,301-306,312,322,410,510-512,599,700,710-713,911-912

    Port Vlans in spanning tree forwarding state and not pruned
    Te1/7 6,51,90,100-107,109-110,115,301-306,312,322,410,510-512,599,700,710-713,911-912

    Juniper

    {master:0}[edit]
    root@bob# show interfaces xe-0/1/0
    native-vlan-id 1;
    unit 0 {
    family ethernet-switching {
    interface-mode trunk;
    vlan {
    members [ wired1 wired2 wired3 cisco ];
    }
    storm-control default;
    }
    }

    {master:0}[edit]
    root@bob# show vlans
    cisco {
    vlan-id 911;
    }
    default {
    vlan-id 1;
    }
    wired1 {
    vlan-id 301;
    }
    wired2 {
    vlan-id 302;
    }
    wired3 {
    vlan-id 303;
    }

    root@bob# run show interfaces xe-0/1/0 terse
    Interface Admin Link Proto Local Remote
    xe-0/1/0 up up
    xe-0/1/0.0 up up eth-switch

    {master:0}[edit]
    root@bob# run show interfaces vme terse
    Interface Admin Link Proto Local Remote
    vme up down
    vme.0 up down inet 172.22.74.21/27

    I can't even get the vme to come up !  

    {master:0}[edit]
    root@bob# show interfaces vme
    unit 0 {
    family inet {
    address 172.22.74.21/27;
    }
    }

    Any help is really appreciated


    ------------------------------
    DARREN HITCHEN
    ------------------------------


  • 2.  RE: Cisco to Juniper trunk

    Posted 4 days ago
    You may be missing your STP protocol setup


    set protocols vstp interface xe-0/1/0 mode point-to-point
    set protocols vstp interface xe-0/1/0 bpdu-timeout-action block
    set protocols vstp interface xe-0/1/0 bpdu-timeout-action alarm
    set protocols vstp vlan all bridge-priority 32k


  • 3.  RE: Cisco to Juniper trunk

    Posted 4 days ago

    Presumably te1/7 is connected to xe-0/1/0.

    If you have a standalone switch then the VME is the out of band management interface. Do you have anything connected to this port as you have not mentioned it? 

     

     



    ------------------------------
    PAUL HERBERT
    ------------------------------



  • 4.  RE: Cisco to Juniper trunk

    Posted 3 days ago
    Yes what is your goal with the "vme" interface. You can't use it for switching (believe me I tried ;-)) it's directly attached to the control plane, not the data plane.

    ------------------------------
    Erik Slagter
    ------------------------------



  • 5.  RE: Cisco to Juniper trunk

    Posted 2 days ago
    Thank you all very much!
    vstp is definitely a point, I have links up up and packets to and from and the routing mac's for each vlan are from the uplink switch,  but no L2  routing. Native vlan and next hop applied. Vlan members in group. 

    The VME is a strange concept coming from cisco as the IP address is assigned to the switch in cisco and I manage the switch remotely. Me0 or (VMe)  seems from my knowledge a strange concept in that the traffic from the port on the back needs a separate physical network. How is the Me0 different from the console port?

    ------------------------------
    DARREN HITCHEN
    ------------------------------



  • 6.  RE: Cisco to Juniper trunk

    Posted 2 days ago
    Edited by Regalis1 2 days ago

    If you have two switches connected by a single link and therefore no loop, there is no requirement for spanningtree to pass traffic between them.

     

    The console port uses RS232 and not Ethernet and IP. To log in through a management port, you would need to know the IP address and use SSH or Telnet.

     

    I don't know Cisco that well but they have out of band management ports so I would assume the concept is the same. The management port is for traffic that accesses the device's control plane so is used for traffic to and from the router only and does not allow traffic to traverse the device through that port. If you are trying to ping across the link either to or from the VME interface it will fail as this would be considered transit traffic. You are correct that the use of the management port may require a separate out of band network and this is often the case with service provider networks. On enterprise networks it is quite common not to use this port and instead use an in band interface such as a VLAN L3 interface. You configure this as an IRB interface and associate it to the VLAN. Please see below.

     

    set interfaces irb unit 30 family inet address 192.168.10.5/24

    set routing-options static route 0.0.0.0/0 next-hop 192.168.10.1

    set vlans v-30 vlan-id 30

    set vlans v-30 l3-interface irb.30

    set interfaces ge-0/0/4 unit 0 family ethernet-switching vlan members v-30

     

    The Me0 and VME interface on a standalone switch are essentially the same thing. When you stack switches in a virtual chassis, you use the VME and this IP can be accessed through any one of the physical management ports.

     

    I am not sure what you mean by L2 routing.



    ------------------------------
    PAUL HERBERT
    ------------------------------



  • 7.  RE: Cisco to Juniper trunk

    Posted 14 hours ago
    Thank you for clarifying that. 
    I spent 3 full days on this one 
    I read that the native cisco vlan 1 needed to be untagged and hence the cisco mgmt vlan needs to be native and included as a member of the uplink 
    [EX] Native VLAN ID and tagged behavior in EX-series switches (juniper.net)
    The switch I assumed being new is ELS
    Tagging the vlan  contrary to advice solved this issue...

    ------------------------------
    DARREN HITCHEN
    ------------------------------