Automation

 View Only
last person joined: yesterday 

Ask questions and share experiences about Apstra, Paragon, and all things network automation.

If you have a question or a use case, likely there are others who are experiencing or worked through the same thing. Don't hesitate to jump in and ask or share your knowledge!

Need additional guidance?  Check out these Juniper Resources.

Knowledge Base Security Advisories Technical Bulletins

Latest Discussion Posts

  • Profile Picture

    Commit synchronize option in Ansible

    This message was posted by a user wishing to remain anonymous Hello, I'm using "juniper_junos_config" module for loading a config file onto MX series routers. Noticed that it just does "commit". Would like to know how to "commit Syncrhonize" using ...

  • Profile Picture

    commit sync using ansible

    This message was posted by a user wishing to remain anonymous Hello all, I'm using "juniper_junos_config" module and noticed that it does just commit and NOT commit-synchronize. Does anyone have done "commit synchronize" on a MX series router using ...

  • Hi dear community, While attempting to connect to SRX devices using Pyez with Ansible i get the following error : 'Connection' object has no attribute 'nonetype' Here is my playbook : --- - name: Get Device Information hosts: router_juniper ...

  • Hi Mark, I encountered issues when executing your script. System complained about line 14... Then, I changed script a little bit, based on some other public documentation, and it worked well. Here is my script, if anyone find issues with your: version ...

  • version 1.1; ns junos = "http://xml.juniper.net/junos/*/junos"; ns xnm = "http://xml.juniper.net/xnm/1.1/xnm"; ns jcs = "http://xml.juniper.net/junos/commit-scripts/1.0"; import "../import/junos.xsl"; /* Junos Space annotations */ /* @CONTEXT = "/device" ...

  • Hi Mark, would you be so kind to share your solution. Thanks, Milan ------------------------------ MILAN MARKOVIC ------------------------------

  • I tried and got the same issue with below message. " error: unknown command: xml-mode error: permission denied: netconf" Regards, Tayzar Lwin

Announcements

  • Elevate Community Updates

    We are making improvements to the Community based on your feedback. Keep an eye out for updates as they are implemented.

    Please give us feedback any time by posting in Community Talk.

Unanswered Posts

Top Contributors in the Community