Expand all | Collapse all

Juniper EX4200 - JWEB not working.

Jump to Best Answer
  • 1.  Juniper EX4200 - JWEB not working.

    Posted 01-15-2013 11:37
      |   view attached



    I apologize in advance for any stupid questions, I am a bit new.



    I recently set up my new ex4200 using the ezsetup through the browser. However Afterwards I have not been able to access J-web. This switch will not be used for networking, purely for testing SFPs and XFPs. I have the IP set as and the subnet mask as I am also unable to ping the ip address. However when I access the switch through CLI it displays the ip address I entered... Any care to help a newbie out?


    I have attached my current configuration.


    Juniper Configuration.txt   3 KB 1 version

  • 2.  RE: Juniper EX4200 - JWEB not working.
    Best Answer

    Posted 01-16-2013 08:45



    If you're directly connected to one of the gigabit Ethernet ports, I'd verify the link status. You could do this with the 'show interfaces <interface-name> terse' command, if you're connected to the CLI via the console port. If you're directly connected and the link status is up, you'll need to make sure your PC/laptop is on the same subnet as the switch's vlan interface. If you're not directly connected and attempting to ping or web manage the device through an intermediary device, such as a router, you'll also need to ensure that the proper routing is in place through the entire path. As I see in your configuration, you have a default static route pointing to I'm guessing this is likely the problem since I doubt the switch knows how to get to The next hop for the default route should probably be on the same subnet as the vlan interface. I hope this all makes sense and that you find it helpful.



  • 3.  RE: Juniper EX4200 - JWEB not working.

    Posted 01-16-2013 10:23

    You my friend are awesome! Thank you for your help. I have everything up and running now. 

  • 4.  RE: Juniper EX4200 - JWEB not working.

    Posted 01-16-2013 10:27


    2 things to check:

    1/ you assigned IP address to a vlan.0 interface and there is no IP address on Ethernet management port (me0). This means if you are connecting to Ethernet management port, you'll get no telnet/ping/http access. Please configure an IP address on me0 interface.

    2/ if you are indeed trying to connect via revenue port (ge-*) then make sure the port isn't blocked by RSTP.



    By default, RSTP is enabled on all Ethernet switching enabled ports on the Juniper Networks EX series Switches

     Please configure the ge-* port You are connecting to as "edge" (spanning-tree portfast CSCO equivalent).