Switching

Expand all | Collapse all

Lost SSHD daemon on virtual chassis ! help !

Jump to Best Answer
  • 1.  Lost SSHD daemon on virtual chassis ! help !

    Posted 01-15-2012 20:07

    Dear all, 

     

    My customer has an virtual chassis, and They use ssh for management, but recently they can not connect to virtual chassis using ssh tool (currently they use telnet to access to this virtual chasssis). 

     

    When I tried to check sshd daemon using the following command : 

     

    jsupport@CORE_VC01> show system processes extensive | match sshd 

     

    It did not show anything, It means sshd daemon failed to start. 

     

    In normal operation sshd daemon should like this (I showed on other Virtual chassis) : 

     

    juniper@HAN-EX4200-01> show system processes extensive | match sshd
    6409 root 1 96 0 7084K 2388K select 0:00 0.00% sshd

     

    I also try to remove ssh configuration and re-configure but no luck. The sshd daemon could not start. 

     

     

    Any idea for my problem ? 

     

    Thanks you all. 




  • 2.  RE: Lost SSHD daemon on virtual chassis ! help !

    Posted 01-16-2012 00:50

    can you post the output of 

    "show configuration system services" ?

     

    maybe they removed ssh? 🙂



  • 3.  RE: Lost SSHD daemon on virtual chassis ! help !

    Posted 01-16-2012 02:24

    Hi,

     

    If you can break routing and switching, run "commit full" statement. This can prevent sshd from thrashing process and restart sshd and also other processes.

     

    some further explanation

    http://www.juniper.net/techpubs/en_US/release-independent/junos/topics/concept/ex-series-software-infrastructure.html

     



  • 4.  RE: Lost SSHD daemon on virtual chassis ! help !
    Best Answer

    Posted 01-16-2012 07:29

    Thanks you all for your reply.

     

    I finally found out the solution, sshd daemon could not start due to missing a directory. After re-create the directory, the sshd daemon work fines. 

     

    Thanks again. 

     



  • 5.  RE: Lost SSHD daemon on virtual chassis ! help !

    Posted 01-20-2012 18:28

    Did someone try a 'request system zeroize'? 

     

    That wipes out a lot of stuff, including ssh keys and sshd itself.

     

     



  • 6.  RE: Lost SSHD daemon on virtual chassis ! help !

    Posted 01-21-2012 07:02

    My customer is providing services to users so I could not use this command !!! 



  • 7.  RE: Lost SSHD daemon on virtual chassis ! help !

    Posted 01-21-2012 16:23

    err... to clarify, I was not suggesting running that command; I was asking if someone else used it to create the problem.

     

    I had a customer who used it to try and 'fix' an EX-4200  VC issue, and it wiped out the virtual chassis settings, ssh keys, and the sshd binary.



  • 8.  RE: Lost SSHD daemon on virtual chassis ! help !

    Posted 02-01-2012 14:01

    For anyone else who comes across this issue here is a detailed explanation of the solution:

     

    From the shell:

     

    type: /usr/sbin/sshd (if you are not missing any folders it will start, otherwise it will come back with a path of the missing folder)

     

    In my case we were missing a 'permissions separation' folder located in /var named empty

     

    create the directory and run the /usr/sbin/sshd command again.

     



  • 9.  RE: Lost SSHD daemon on virtual chassis ! help !

    Posted 12-06-2013 08:03

    JArner - Thanks for your follow-up. This problam had afflicted one of my EX switches and your notes here helped me resolve the problem!



  • 10.  RE: Lost SSHD daemon on virtual chassis ! help !

    Posted 03-30-2015 20:33

    Thx for this tip



  • 11.  RE: Lost SSHD daemon on virtual chassis ! help !

    Posted 05-22-2016 14:26

    Thank you for the tip. This is exactly what happened to me and the fix worked. Thanks again.