vMX

 View Only
last person joined: one month ago 

Ask questions and share experiences about vMX.
Expand all | Collapse all

vMX in vLabs and VLANs

  • 1.  vMX in vLabs and VLANs

    Posted 03-18-2020 18:39

    Hi,

     

    I've been playing with the vMX in vLabs, just trying to get some subinterfaces working (I'm more familiar with the EX series).

    However, I can't create any VLANs. Is this normal for MX/vMX, or is it a limitation with vLabs?

     

    Just trying to work out if I'm doing something wrong here.

     

    Thanks



  • 2.  RE: vMX in vLabs and VLANs

    Posted 03-18-2020 19:38

    FYI, I've now also tried this with vSRX.

    I have two vSRX connected directly together on ge-0/0/1.

    I've then added this config to make two subinterfaces:

     

    jcluser@vSRX1# show interfaces ge-0/0/1    
    vlan-tagging;
    unit 100 {
        vlan-id 100;
        family inet {
            address 192.168.100.1/24;
        }
    }
    unit 200 {
        vlan-id 200;
        family inet {
            address 192.168.200.1/24;
        }
    }

     

    Each srx can ping their own IP's, but not the neighbour IP's.

    Any ideas where I'm going wrong?

     

     

     



  • 3.  RE: vMX in vLabs and VLANs

    Posted 03-25-2020 00:22

    Hi,

     

    Same configuration as configured on SRX should work on vMX.

     

    Can you share the vMX interface config.

     

    Also share output of "show chassis hardware"



  • 4.  RE: vMX in vLabs and VLANs

    Posted 02-27-2021 03:31
    Hello Luke,

    You are not doing something wrong. The configuration is fine.
    The Problem is with the vLabs. The devices are most probably connected through some VMs, and they don't allow  you to send tagged traffic.
    I've observed the same problem on the vMX. And I just cannot ping a directly connected neighbor.

    The config from R1:
    set interfaces ge-0/0/0 per-unit-scheduler
    set interfaces ge-0/0/0 flexible-vlan-tagging
    set interfaces ge-0/0/0 unit 10 vlan-id 10
    set interfaces ge-0/0/0 unit 10 family inet address 172.16.10.1/24
    set interfaces ge-0/0/0 unit 20 vlan-id 20
    set interfaces ge-0/0/0 unit 20 family inet address 172.16.20.1/24

    The config from R2:
    set interfaces ge-0/0/0 per-unit-scheduler
    set interfaces ge-0/0/0 flexible-vlan-tagging
    set interfaces ge-0/0/0 unit 10 vlan-id 10
    set interfaces ge-0/0/0 unit 10 family inet address 172.16.10.2/24
    set interfaces ge-0/0/0 unit 20 vlan-id 20
    set interfaces ge-0/0/0 unit 20 family inet address 172.16.20.2/24

    This config works perfectly in GNS3 and on real devices, but not on the vLabs devices. I used the "vLab Sandbox: JET for Junos - Automation and Programmability".


  • 5.  RE: vMX in vLabs and VLANs

    Posted 08-22-2021 13:05
    Luke, if you are using ESXi please set the vSwitch port group to VLAN ID 4095.  This will set the port group into trunk mode which stops the VLAN tag from being manipulated.    You can then use VLANs inside of the vMX or vSRX.     Ref: https://kb.vmware.com/s/article/1004252


    ------------------------------
    SEAN MATHERSON
    ------------------------------



  • 6.  RE: vMX in vLabs and VLANs
    Best Answer

    Posted 03-25-2020 05:11

    Hi Luke Robertson, 

     

    In my knowledge, on the MX/vMX devices we have bridge domains instead of vlan. The below configuration might help you in understanding the steps to establish reachability between different VLANs (bridge domain) :

    set interfaces ge-0/0/0 unit 0 family bridge interface-mode access
    set interfaces ge-0/0/0 unit 0 family bridge vlan-id 10
    set interfaces ge-0/0/1 unit 0 family bridge interface-mode access

    set interfaces ge-0/0/1 unit 0 family bridge vlan-id 20
    set bridge-domains vlan-a vlan-id 10
    set bridge-domains vlan-b vlan-id 20

    set interfaces irb unit 10 family inet address 10.10.10.1/24
    set interfaces irb unit 20 family inet address 20.20.20.1/24
    set bridge-domains vlan-a routing-interface irb.10
    set bridge-domains vlan-b routing-interface irb.20

     

    Please mark "accept as solution" if this answers your query. Kudos are appreciated too ! 

     

    Regards,
    Sharat



  • 7.  RE: vMX in vLabs and VLANs

    Posted 03-29-2020 14:41

    Thanks. I have found that the vMX (vlabs or otherwise) do not support VLANs in the way I'm attempting.

     

    I will have a look at bridge domains instead. Thanks.

     

     



  • 8.  RE: vMX in vLabs and VLANs

    Posted 03-30-2020 04:07

    Hi Luke, 

     

    Please explore and do let me know if you have any further queries on this. 


    Regards,
    Sharat



  • 9.  RE: vMX in vLabs and VLANs

    Posted 03-03-2021 08:47
    Hi guys,

    I faced the same problem, and resolved it by help of Juniper VLAB team.
    As mcraiu mentioned, Juniper labs uses ESXi hypervisor in JCL, and ESXi drops frames with standard VLAN tag (TPID = 0x8100). The workaround is to use another TPID value (not 0x8100), for example:
    set interfaces ge-0/0/0 flexible-vlan-tagging
    set interfaces ge-0/0/0 gigether-options ethernet-switch-profile tag-protocol-id 0x9100
    set interfaces ge-0/0/0 unit 100 vlan-tags outer 0x9100.100
    set interfaces ge-0/0/0 unit 100 family inet address 192.85.1.1/24

    This problem is described here:
    https://services.jlabs.juniper.net/kb?id=kb_article_view&sysparm_article=KB0010179&sys_kb_id=5600efc9dbe81010cccf9ec6db961971&spa=1​

    ------------------------------
    VLADISLAV KARPOV
    ------------------------------



  • 10.  RE: vMX in vLabs and VLANs

    Posted 04-27-2021 04:02
    Link is dead. This didn't work for me in ipsec lab

    ------------------------------
    DMITRY DUMSKY
    ------------------------------



  • 11.  RE: vMX in vLabs and VLANs

    Posted 04-27-2021 04:13
    Hello Dmitry,

    for some reason the link really opens kinda strange.
    Anyway, you can find this article by opening the link https://services.jlabs.juniper.net/kb?id=kb_home
    then Juniper Cloud Labs FAQ  and here you will find the article named "How to use VLAN tagging?"

    By the way, it is mentioned that it works only for vMX, not for vSRX.

    ------------------------------
    VLADISLAV KARPOV
    ------------------------------



  • 12.  RE: vMX in vLabs and VLANs

    Posted 04-29-2021 07:11
    Hello,

    This link shows me
    • 0 Knowledge Bases
    • 0 Articles
    • 0 Q&A
      And search doesn't work. May be my account  don't have some permissions for it.


    ------------------------------
    DMITRY DUMSKY
    ------------------------------