Switching

 View Only
last person joined: 6 days ago 

Ask questions and share experiences about EX and QFX portfolios and all switching solutions across your data center, campus, and branch locations.
  • 1.  Extended DHCP Server Config

    This message was posted by a user wishing to remain anonymous
    Posted 10-03-2022 15:47
    This message was posted by a user wishing to remain anonymous

    Hello,

    I'm having some issues getting a DHCP server setup for my VLANs. I keep receiving the following error: " 'dhcp'
    Incompatible with 'set system services dhcp-local-server'."

    Here is my config:
    [edit access]
    address-assignment {
    pool dhcp-pool1 {
    family inet {
    network 192.168.99.0/24;
    dhcp-attributes {
    name-server {
    8.8.8.8;
    8.8.4.4;
    }
    router {
    192.168.99.1;
    }
    }
    }
    }

    [edit system services dhcp-local-server]
    group internal-dhcp {
    interface vlan.100;
    }

    Is anyone more versed in the juniper world  able to spot anything that could be causing this error? Or is this just an unsupported feature on my switch? I'm using juniper ex4200.

    Side Note:
    I also want to setup DHCP server for two different VLANs that I plan to have put in a virtual-router routing instance; I assume I'd do that under the [edit routing-instances { instance } access address-assignment] hierarchies.

    Thanks


  • 2.  RE: Extended DHCP Server Config

    Posted 10-03-2022 16:21
    Hi  .

    Here is the DHCP server  config for ELS platforms as Ex4200.
    Hope this helps you.


    [EOE/EOL] How to configure the Legacy EX-series switch as a DHCP server (juniper.net)

    The following steps are used to configure the EX-Series switch as a DHCP server:

    1. Create DHCP services on the EX switch by creating a DHCP pool:
      juniper@EX# set system services dhcp pool 10.0.0.0/24
    2. Add the lowest IP address and highest IP address in DHCP pool address-range (optional):
      juniper@EX# set system services dhcp pool 10.0.0.0/24 address-range low 10.0.0.2 high 10.0.0.252
    3. Add the router IP address to be supplied with the IP address (optional):
      juniper@EX# set system services dhcp pool 10.0.0.0/24 router 10.0.0.1
    4. Create a virtual interface associated to the DHCP pool:
      Juniper@EX# set interface vlan unit 0 family inet address 10.0.0.1/24
    5. Associate virtual interface to a VLAN where DHCP client's machines will be connected
      Juniper@EX> set vlan default l3-interface vlan.0
      Command List Summary:
      set system services dhcp pool 10.0.0.0/24 address-range low 10.0.0.2
      set system services dhcp pool 10.0.0.0/24 address-range high 10.0.0.252
      set system services dhcp pool 10.0.0.0/24 router 10.0.0.1
      set interfaces vlan unit 0 family inet address 10.0.0.1/24
      set vlans default l3-interface vlan.0
    6. Repeat steps 1 to 3 to add more DHCP pools for different subnets.