View Only
last person joined: 16 hours ago 

Ask questions and share experiences about EX and QFX portfolios and all switching solutions across your data center, campus, and branch locations.
  • 1.  VXLAN Manual configuration not working (EX4600)

    Posted 07-28-2020 05:54



    I'm fairly new to Juniper (a few weeks since I started working with it) and I'm currently trying to manually configure a VXLAN tunnel between 2 EX4600 switches.


    I started from the bottom, trying a basic configuration to see how it should be configured (used this tutorial: https://www.juniper.net/documentation/en_US/junos/topics/topic-map/vxlan-qfx-series.html#id-example-configuring-a-vxlan-layer-2-gateway), but sadly the vxlan tunnel between my switches doesn't come up. When I check everything that the tutorial says to look at to make sure the tunnel is working, nothing shows up, so the tunnel doesn't work (my configurations and outputs are at the end of this post).


    I have read most of the forum posts regarding vxlan and all the tutorials possible, but nothing is helping. Can anyone, please, help me out and tell me what I do wrong or why isn't my tunnel coming up? 


    Thank you!


    Best regards,





    EX4600 switch A configurations:


    L3 interface: show interfaces et-0/0/24
    unit 0 {
         family inet {


    Loopback interface (VTEP): show interfaces lo0
    unit 0 {
         family inet {


    L2 interface: show interfaces ge-0/0/0
    unit 0 {

            family ethernet-switching {
               interface-mode trunk;
               vlan {
                  members v100;
                storm-control default;


    v100 {
            vlan-id 100;
            vxlan {
               vni 100;
               unreachable-vtep-aging-timer 600;


    VTEP: show switch-options
    vtep-source-interface lo0.0;


    PIM: show protocols pim
    rp {
       static {
    interface lo0.0;
    interface et-0/0/24.0;


    OSPF: show protocols ospf
    area {
         interface lo0.0;
         interface et-0/0/24.0;


    Same configurations on Switch B with

    • L3 interface: et-0/0/26 - @
    • Loopback interface (VTEP): lo0 - @
    • L2 interface: ge-0/0/20 





    show ethernet-switching table

    I have nothing, no VTEP interface to direct to my vlan. 


    show ethernet-switching vxlan-tunnel-end-point source

    Logical      System Name     Id    SVTEP-IP     IFL        L3-Idx
    <default>                              0     lo0.0         0
            L2-RTT              Bridge Domain       VNID       MC-Group-IP
            default-switch        100+100            100


    show ethernet-switching vxlan-tunnel-end-point remote
    Logical        System Name      Id          SVTEP-IP      IFL      L3-Idx
    <default>                                 0        lo0.0       0


    show interfaces vtep

    Physical interface: vtep, Enabled, Physical link is Up
         Interface index: 641, SNMP ifIndex: 506
         Type: Software-Pseudo, Link-level type: VxLAN-Tunnel-Endpoint, MTU: Unlimited,
         Speed: Unlimited 
         Device flags : Present Running
         Link type : Full-Duplex
         Link flags : None
         Last flapped : Never
            Input packets : 0
            Output packets: 0

    Logical interface vtep.32768 (Index 557) (SNMP ifIndex 515)

          Flags: Up SNMP-Traps Encapsulation: ENET2

          VXLAN Endpoint Type: Source, VXLAN Endpoint Address:, L2 Routing Instance: default-switch, L3 Routing Instance: default

         Input packets : 0
         Output packets: 0


    show ospf neighbor
    Address            Interface       State        ID           Pri        Dead   et-0/0/24.0   Full    128         37

  • 2.  RE: VXLAN Manual configuration not working (EX4600)
    Best Answer

    Posted 07-29-2020 02:34


    I would suggest to check if the PIM neighborship is working fine and multicast is working on both the devices.

    If pim/multicast is working then once you learn the mac address locally will be seen learned via vtep on the other side.


    Hope this helps


  • 3.  RE: VXLAN Manual configuration not working (EX4600)

    Posted 07-29-2020 04:27



    Thank you very much for your reply. 


    I have verified if my PIM is working on both devices and I can see their neighbors and the multicast group and rp are correctly configured on both of them...




    show arp
    MAC Address              Address            Name              Interface           Flags
    3c:8c:93:60:a0:83     em2.32768       none
    3c:8c:93:60:d2:a3   et-0/0/24.0      none


    show pim neighbors

    Instance: PIM.master

    Interface         IP    V       Mode          Option        Uptime        Neighbor addr
    et-0/0/24.0    4     2      HPLGT                           21:41:52


    show pim join
    Instance: PIM.master Family: INET


    Source: *
    Flags: sparse,rptree,wildcard
    Upstream interface: unknown (no nexthop)


    show pim interfaces


    Name            Stat         Mode         IP         V        State                       NbrCnt        JoinCnt(sg/*g)       DR address
    et-0/0/24.0  Up              S              4         2         NotDR,NotCap           1                   0/0        
    lo0.0              Up              S              4         2         DR,NotCap                 0                    0/0        
    pime.32769 Down          S             4          2         P2P,NotCap               0                     0/0


    show pim source
    Instance: PIM.master Family: INET

    Prefix unknown
    Upstream interface unknown
    Upstream neighbor unknown


    The statistics for pim show they have sent each other Hello messages, but that it is, the rest is at 0. I was thinking that might be the problem, since there is no other communication done between the 2. What I don't understand is what could cause this? 


    PIM Message type            Received            Sent             Rx errors
    V2 Hello                               2759                2765                 0

  • 4.  RE: VXLAN Manual configuration not working (EX4600)

    Posted 07-30-2020 04:54

    Hi Raualex,


    Please check out the below KB which has a little more details regarding the pim outputs to check and compare




    Hope this helps.

  • 5.  RE: VXLAN Manual configuration not working (EX4600)

    Posted 07-30-2020 05:50

    Hello raviky, 


    Thank you once again for replying. 


    I have tried this exact configuration and it worked, some configurations had to be changed in order for the VXLAN and PIM to work though. I changed the configuration for PIM interfaces and instead of only adding the interfaces I use, I added all the interfaces. Having only the interfaces I use in PIM wasn't working. 


    Thank you for your help. I spent a few days on VXLAN and had no idea where to look, so thank you for telling me to check PIM and multicast. 


    Kudos to you ! 


    Best regards,


  • 6.  RE: VXLAN Manual configuration not working (EX4600)

    Posted 07-30-2020 06:06

    Glad to know that the issue is resolved.

    If possible please share the exact config change that you did in your setup with respect to multicast so that we can update the KB article accordingly.

  • 7.  RE: VXLAN Manual configuration not working (EX4600)

    Posted 07-30-2020 06:33

    Sure, no problem.


    All that I changed was in PIM regarding the interfaces. 


    Instead of having:


    set protocols pim interface xe-0/0/2.0 mode sparse


    I added:


    set protocols pim interface all mode sparse 


    I also tried to add only the L3 and the loopback interfaces to PIM and it seems to work too: 


    set protocols pim interface xe-0/0/2.0 mode sparse

    set protocols pim interface lo0.0 mode sparse


    The problem was that one of the interfaces was missing from the PIM configuration.