Hi all,
I'm trying to get an EX4500s to talk L2 trunk to a Cisco 6506 over a pair of 1G Ethernet optics via a port-channel (po10) and LAG (ae1) so that I have redundancy and more bandwidth. I have locked down the negotiation, as seems prudent when dealing with two vendors. The inertfaces on both sides come up and seem to pass traffic. The LAG (ae1) comes up as well, but the Cisco port-channel does not. Snips of the code and status follows. Can someone help or point me at a best practice guide on inter-vendor LAG connectivity?
Tx!
-Chuck
=====================================
Juniper code:
ge-0/0/1 {
description "ae1 LAG member - L2 to SCH6506R (East)";
ether-options {
no-auto-negotiation;
link-mode full-duplex;
speed {
1g;
}
802.3ad ae1;
}
}
ge-0/0/2 {
description "ae1 LAG member - L2 to SCH6506R (East)";
ether-options {
no-auto-negotiation;
link-mode full-duplex;
speed {
1g;
}
802.3ad ae1;
}
}
ae1 {
description "L2 LAG to SCH6506R (East)";
unit 0 {
family ethernet-switching {
port-mode trunk;
vlan {
members all;
}
native-vlan-id 1;
}
}
}
Juniper status:
Interface Admin Link Description
ge-0/0/1 up up ae1 LAG member - L2 to SCH6506R (East)
ge-0/0/2 up up ae1 LAG member - L2 to SCH6506R (East)
ae1 up up L2 LAG to SCH6506R (East)
Cisco code:
!
interface GigabitEthernet4/1
description HOLD - L2 to Juniper EX4500 (to OLV DC)
switchport
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 1000
switchport mode trunk
logging event link-status
logging event trunk-status
speed nonegotiate
channel-group 10 mode desirable
end
!
interface GigabitEthernet4/2
description HOLD - L2 to Juniper EX4500 (to OLV DC)
switchport
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 1000
switchport mode trunk
logging event link-status
logging event trunk-status
speed nonegotiate
channel-group 10 mode desirable
end
!
interface Port-channel10
description L2 to Juniper EX4500 (to OLV DC)
switchport
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 1000
switchport mode trunk
logging event link-status
logging event trunk-status
speed nonegotiate
mls qos trust cos
end
Cisco status:
Port Name Status Vlan Duplex Speed Type
Gi4/1 HOLD - L2 to Junip connected trunk full 1000 1000BaseSX
Gi4/2 HOLD - L2 to Junip connected trunk full 1000 1000BaseSX
Po10 L2 to Juniper EX45 notconnect unassigned auto auto
#ex4500#Juniper#LAG#port-channel#cisco#6506#trunk