Switching

 View Only

IMPORTANT MODERATION NOTICE

This community is currently under full moderation, meaning  all posts will be reviewed before appearing in the community. Please expect a brief delay—there is no need to post multiple times. If your post is rejected, you'll receive an email outlining the reason(s). We've implemented full moderation to control spam. Thank you for your patience and participation.



  • 1.  Trunking between 2 EX2300

    Posted 05-16-2022 05:25


    Hello. I am new to juniper switch programming and I need help connecting the Vlans of the two ex2300 switches I have. I have followed several tutorials, but surely I am doing something wrong, since I can't get it to work.
    I have created the 2 vlans with Id-100 and id-200 (the same in both switches) and I have assigned them to the ports that appear in the image, in addition to the two ports that are in trunk mode, but I can't get it to work , since when I connect a computer to port 2 of switch 1 and connect another to port 2 of switch 2, it does not respond to ping

    Connecting the computers to the same switch does work and they respond to ping when they are in the same vlan, so I guess the fault has to be in the configuration of the trunk ports.

    Excuse my English, I use google translator.


  • 2.  RE: Trunking between 2 EX2300

     
    Posted 05-16-2022 06:06
    The basic configuration would be as follows.
    set interfaces ge-0/0/1 unit 0 family ethernet-switching interface-mode trunk
    
    set interfaces ge-0/0/1 unit 0 family ethernet-switching vlan members vlan1
    set interfaces ge-0/0/1 unit 0 family ethernet-switching vlan members vlan2​


    the labels vlan1 and vlan2 need to match what you have called the vlans under the vlan section.

    set vlans vlan1 vlan-id 1
    set vlans vlan2 vlan-id 2



    ------------------------------
    Steve Puluka BSEET - Juniper Ambassador
    IP Architect - DQE Communications Pittsburgh, PA (Metro Ethernet & ISP)
    http://puluka.com/home
    ------------------------------



  • 3.  RE: Trunking between 2 EX2300

    Posted 05-16-2022 07:30

    Thanks for your reply.
    This is how I did it before but on ge-0/0/0 but it still doesn't work (Is it necessary to be on interface ge-0/0/1?).
    I enclose the code that appears when I use the "show interfaces" command

    Grupo1 is vlan1 with id- 100
    Grupo2 is vlan2 with id-200

    Both switches are configured the same.



    root# show interfaces
    ge-0/0/0 {
        unit 0 {
            family ethernet-switching {
                interface-mode trunk;
                vlan {
                    members [ Grupo1 Grupo2 ];
                }
                storm-control default;
            }
        }
    }
    ge-0/0/1 {
        unit 0 {
            family ethernet-switching {
                vlan {
                    members Grupo1;
                }
                storm-control default;
            }
        }
    }
    ge-0/0/2 {
        unit 0 {
            family ethernet-switching {
                vlan {
                    members Grupo1;
                }
                storm-control default;
            }
        }
    }
    ge-0/0/3 {
        unit 0 {
            family ethernet-switching {
                vlan {
                    members Grupo1;
                }
                storm-control default;
            }
        }
    }
    ge-0/0/4 {
        unit 0 {
            family ethernet-switching {
                vlan {
                    members Grupo2;
                }
                storm-control default;
            }
        }
    }
    ge-0/0/5 {
        unit 0 {
            family ethernet-switching {
                vlan {
                    members Grupo2;
                }
                storm-control default;
            }
    

     



    ------------------------------
    ADRIAN FERNANDEZ MANUEL
    ------------------------------



  • 4.  RE: Trunking between 2 EX2300

     
    Posted 05-16-2022 07:32
    That all looks correct.  Please supply the vlan configuration too.
    vlans Grupo1​
    vlans Grupo2


    ------------------------------
    Steve Puluka BSEET - Juniper Ambassador
    IP Architect - DQE Communications Pittsburgh, PA (Metro Ethernet & ISP)
    http://puluka.com/home
    ------------------------------



  • 5.  RE: Trunking between 2 EX2300

    Posted 05-16-2022 07:58
    Are you referring to the "Set vlans" command?

    Attached is a summary of the Vlans configuration
    .
    root# show vlans
    Grupo1 {
        vlan-id 100;
    }
    Grupo2 {
        vlan-id 200;
    }
    default {
        vlan-id 1;
        l3-interface irb.0;
    }
    ​

    I don't know what could be wrong. I've followed different tutorials, including the one on juniper website, but I can't get it to work.



    ------------------------------
    ADRIAN FERNANDEZ MANUEL
    ------------------------------



  • 6.  RE: Trunking between 2 EX2300

     
    Posted 05-16-2022 08:04
    There is a mismatch between the configurations and your visual port assignments in the first post.

    ge-0/0/0 is the physical top port which your diagram shows to be red vlan 1

    the port counting starts with 0 and goes top to bottom and left to right.

    Thus the trunk port is ge-0/0/1 in you physical diagram

    red vlan 1
    ge-0/0/0
    ge-0/0/2
    ge-0/0/3

    blue vlan 2
    ge-0/0/4
    ge-0/0/5
    ge-0/0/6
    ge-0/0/7

    ------------------------------
    Steve Puluka BSEET - Juniper Ambassador
    IP Architect - DQE Communications Pittsburgh, PA (Metro Ethernet & ISP)
    http://puluka.com/home
    ------------------------------



  • 7.  RE: Trunking between 2 EX2300

    Posted 05-16-2022 09:04
    You are right. I just checked and it works. I had been trying to solve the problem for 3 weeks and in the end it was my mistake. I thought ports were read from bottom to top. Thank you very much for your help.

    ------------------------------
    ADRIAN FERNANDEZ MANUEL
    ------------------------------