Security Management

 View Only

IMPORTANT MODERATION NOTICE

This community is currently under full moderation, meaning  all posts will be reviewed before appearing in the community. Please expect a brief delay—there is no need to post multiple times. If your post is rejected, you'll receive an email outlining the reason(s). We've implemented full moderation to control spam. Thank you for your patience and participation.



  • 1.  NSM on Dell T310 X86_64 - RHEL 5.x

    Posted 03-15-2011 21:26

    Your CPU architecture x86_64 is not supported by NSM   ...    getting this message on the install

     

    is this correct or have I done something wrong.? It's hard to believe that the software will not run 64 bit ....



  • 2.  RE: NSM on Dell T310 X86_64 - RHEL 5.x

    Posted 03-16-2011 10:42

    See: http://www.juniper.net/techpubs/software/management/security-manager/nsm2010_4/nsm-installer-guide.pdf

     

    Searching "32 bit" yields several hits. Searching "64 bit"...not so much :(\

     

    HTH,

     

    -Keith



  • 3.  RE: NSM on Dell T310 X86_64 - RHEL 5.x
    Best Answer

    Posted 03-16-2011 10:47

    While it's not supported by Juniper, I have found a trick to work around this.  I've been running NSM on 64-bit RHEL 5 for about 3 years now.

     

    You can private message me and I can share it with you there.  If the Juniper folks don't mind too much, I could post it here for everyone to see, with the understanding that it's my hack, and not supported in any way by Juniper.


    #64-bit
    #NSM
    #rhel


  • 4.  RE: NSM on Dell T310 X86_64 - RHEL 5.x

    Posted 03-16-2011 21:51

    thanks



  • 5.  RE: NSM on Dell T310 X86_64 - RHEL 5.x

    Posted 03-18-2011 20:09

    works great for me!



  • 6.  RE: NSM on Dell T310 X86_64 - RHEL 5.x

    Posted 03-25-2011 22:42

    Dear Sir,

     

    How to solves the problem ? Thanks!



  • 7.  RE: NSM on Dell T310 X86_64 - RHEL 5.x

    Posted 03-28-2011 16:00

    I've received a few requests via private messages for how to fix this, so I'm going to go ahead and post my solution here.

    First, I will make the disclaimer that this is not supported by Juniper.  This fix is my own work, it was not suggested by JTAC nor is running NSM on a 64-bit platform endorsed or supported by JTAC.

    That being said, it's really quite an easy fix and I have not had any problems running on RHEL 5.x x86_64 for over 3 years.  The fix is to basically lie to the installer script.  At a bash command prompt on any linux/unix workstation, this should work.  The source file is the NSM installer script for the version you're installing.  I'm going to use nsm2010.4 as an example.

     

     

    [keithr@nsm ~]$ sed 's/ARCH=`\/bin\/uname -m`/ARCH="i686"/' nsm2010.4_servers_linux_x86.sh > my-nsm.sh

     

    Note that the above command is all one line, in case the format is affected by the forum posting.

    Simply then install NSM from the new "my-nsm.sh" script.

    I also keep my system updated via RHN and yum, which again is not supported by Juniper.  I feel, though, that keeping my system patched with security-related updates from RHN is essential for a server that has master control of all my firewall devices.  I do not use the systemupdate scripts, instead I extract the systemupdate zip and tar files, then go into the es5 directory that is created. I find the rhes5.sh script to be naive and clunky, since all it really does is this:

     

     

    rpm -Uvh --force --nodeps *.rpm

    That can be damaging to your system if you have run any security updates or patches on it.

    For a fresh install, I catalog the RPMs that are in the systemupdate (es5) directory and make sure that the same or newer versions are installed on my system using yum.  Some of the supplied packages in the systemupdate tar file won't install because they aren't targeted for the x86_64 platform, so you may have to do a little homework and find the correct packages and install them with yum.

    Your mileage may vary, don't try this at home, professional driver - closed course... etc.

     

     



  • 8.  RE: NSM on Dell T310 X86_64 - RHEL 5.x

    Posted 07-08-2011 04:23

    Hi all,

     

    update for NSM server 2011.1

     

    sed '/"i686"/ s//"i686" -o "" = "x86_64"/g' nsm2011.1_servers_linux_x86.sh > my_nsm.sh
    chmod 744 my_nsm.sh
    ./my_nsm.sh

     my HW is Dell PowerEdge 190 and system is "RHEL branded" Centos 5.6

     

    Best Regards

    --

    mf



  • 9.  RE: NSM on Dell T310 X86_64 - RHEL 5.x

    Posted 11-23-2011 11:12

    Really good post. Thank you both for the info. Sadly I still get , Your CPU architecture X86_64 is not supported by NSM.

     

     



  • 10.  RE: NSM on Dell T310 X86_64 - RHEL 5.x

    Posted 11-23-2011 11:35

    Nevermind.. I got it to go. Had to use Keith's instructions. They didnt work the first time, must have fat fingered. Anyway, thanks, saved me a ton of work reimaging.

     

    Robot Happy



  • 11.  RE: NSM on Dell T310 X86_64 - RHEL 5.x

    Posted 11-30-2011 07:59

    +1. Thanks for taking the time to post this. I found it very helpful and on a stock rhel 5 box and 2011.1, and it's already using 30Gb of memory. Not sure why this isn't supported, but already way more productive than x86.



  • 12.  RE: NSM on Dell T310 X86_64 - RHEL 5.x

    Posted 09-11-2013 06:13

    Just to keep this thread alive (because I think its a good one), I have a new issue when trying to upgrade to 2012.2.

     

    Please install the system update utility before continuing.
    compat-libstdc++-296-2.96-138

     

    but here's the rub, I cant install that on RHE4. It's part of the RHE5 upgrade utility. I tried to run that but it said it conflicted with a current version of compat-libstdc.

     

    Justin