Junos OS

Expand all | Collapse all

SRX300 DHCP not working. Cannot ping other clients

Jump to Best Answer
  • 1.  SRX300 DHCP not working. Cannot ping other clients

    Posted 10-01-2019 15:01

    Hello,

    I hope this is just a simple syntax issue. 

    I have setup 2 DHCP pools that should propagate through 2 seperate vlans. 

    set system services dhcp pool 10.255.7.0/27 address-range low 10.255.7.10
    set system services dhcp pool 10.255.7.0/27 address-range high 10.255.7.25
    set system services dhcp pool 10.255.7.0/27 default-lease-time 28800
    set system services dhcp pool 10.255.7.0/27 name-server 10.110.2.20
    set system services dhcp pool 10.255.7.0/27 router 10.255.7.1
    set system services dhcp pool 10.255.7.0/27 propagate-settings irb.1 set system services dhcp pool 10.255.7.64/27 address-range low 10.255.7.70 set system services dhcp pool 10.255.7.64/27 address-range high 10.255.7.94 set system services dhcp pool 10.255.7.64/27 default-lease-time 28800 set system services dhcp pool 10.255.7.64/27 name-server 8.8.8.8 set system services dhcp pool 10.255.7.64/27 router 10.255.7.65 set system services dhcp pool 10.255.7.64/27 propagate-settings irb.64
    set security zones security-zone trust host-inbound-traffic system-services all
    set security zones security-zone trust host-inbound-traffic protocols all
    set security zones security-zone trust interfaces irb.1
    set security zones security-zone untrust screen untrust-screen
    set security zones security-zone untrust interfaces ge-0/0/5.0 host-inbound-traffic system-services dhcp
    set security zones security-zone untrust interfaces ge-0/0/5.0 host-inbound-traffic system-services ike
    set security zones security-zone untrust interfaces ge-0/0/5.0 host-inbound-traffic system-services ssh
    set security zones security-zone GuestiNet address-book address Guest-Network 10.255.7.64/27
    set security zones security-zone GuestiNet interfaces irb.64 host-inbound-traffic system-services dhcp
    set security zones security-zone GuestiNet interfaces irb.64 host-inbound-traffic system-services traceroute

    Whether i plug a laptop into interface ge-0/0/1 or ge-0/0/2 it will not get DHCP.

    set interfaces ge-0/0/1 unit 0 family ethernet-switching interface-mode access
    set interfaces ge-0/0/1 unit 0 family ethernet-switching vlan members Workstation
    set interfaces ge-0/0/2 unit 0 family ethernet-switching interface-mode access
    set interfaces ge-0/0/2 unit 0 family ethernet-switching vlan members Guest
    
    set interfaces irb unit 1 family inet address 10.255.7.1/27
    set interfaces irb unit 64 family inet address 10.255.7.65/27
    
    set routing-options router-id 10.255.7.1
    set vlans Guest vlan-id 64
    set vlans Guest l3-interface irb.64
    set vlans Workstation vlan-id 1
    set vlans Workstation l3-interface irb.1

    Any help would be great.

     

     



  • 2.  RE: SRX300 DHCP not working. Cannot ping other clients

     
    Posted 10-01-2019 16:45

    The configuration looks correct but this is the deprecated method for dhcp.

    Give this one a try.

    https://www.juniper.net/documentation/en_US/junos/topics/topic-map/dhcp-server-security-devices.html#id-minimum-dhcp-local-server-configuration

     



  • 3.  RE: SRX300 DHCP not working. Cannot ping other clients
    Best Answer

    Posted 10-07-2019 06:17

    Thank you for responding.

    Update the firmware, again, resolved the issue.