Junos OS

Expand all | Collapse all

Pulse Secure for macOS High Sierra

  • 1.  Pulse Secure for macOS High Sierra

    Posted 01-07-2020 09:01

    Hello,

     

    I am at wits end here.  Does anyone know which version of Pulse Secure works with the macOS High Sierra?  I have tried several 5.x and 9.x, but none of it works.  My SRX550 is using OS 12.44 or something to this effect.

     

    Just need a working version of of Pulse Secure...have not been able to VPN into my SRX.

     

    Any insight would be great!

     

    Thank you!

     

    John



  • 2.  RE: Pulse Secure for macOS High Sierra

    Posted 01-07-2020 09:23

    Pulse Secure used to be a part of Juniper but was seperated and became it's own company many moons ago. So offical support for Pulse Secure products is more a Pulse themselves issue to be fair. Pulsesecure.net is the website.

    That said, this should help - https://kb.pulsesecure.net/articles/Pulse_Secure_Article/KB40752

    If not then their KB base search is at https://kb.pulsesecure.net/pkb_Home?q=high%20sierra&l=en_US

    KR
    Adam



  • 3.  RE: Pulse Secure for macOS High Sierra

    Posted 01-07-2020 09:58

    Thanks Adam.

     

    I did review the juniper.net documents and I do not have either of those versions of Pulse secure.

     

    I also tried calling Junos Pulse Support, and they referred me to contact Juniper.Net as Juniper would have the correct version of the software.  Do you know where I can find the versions in the articles?

     

    I downloaded and tried the following:

     

    ps-pulse-mac-5.1r10.0-b61733-installer.dmg

    ps-pulse-mac-5.1r5.0-b60701-installer.dmg

    ps-pulse-mac-5.1r5.1-b61437-installer.dmg

    ps-pulse-mac-5.2r1.0-b227-installer.dmg

    ps-pulse-mac-5.2r3.0-b537-installer.dmg

    ps-pulse-mac-5.2r4.1-b787-installer.dmg

    ps-pulse-mac-5.2r5.0-b869-installer.dmg

    ps-pulse-mac-5.2r6.0-b977-installer.dmg

    ps-pulse-mac-5.2r8.0-b1075-installer.dmg

    ps-pulse-mac-5.3r1.1-b755-installer.dmg

    ps-pulse-mac-5.3r2.0-b853-installer.dmg

    ps-pulse-mac-5.3r5.0-b1491-installer.dmg

    ps-pulse-mac-9.0r1.0-b571-installer.dmg

    ps-pulse-mac-9.0r2.0-b1151-installer.dmg

    ps-pulse-mac-9.0r3.0-b1599-installer.dmg

    ps-pulse-mac-9.0r3.2-b1667-installer.dmg

    ps-pulse-mac-9.0r4.0-b1731-installer.dmg

    ps-pulse-mac-9.1r2.0-b1181-installer.dmg

    ps-pulse-mac-9.1r3.1-b1413-installer.dmg



  • 4.  RE: Pulse Secure for macOS High Sierra

     
    Posted 01-07-2020 16:24

    Since the divestiture the software can't be publicly distributed but has to be accessed via JTAC support for the versions that Juniper is allowed to provide to licensed users.  You will need to open a case to get the downloads or convert to the new vendor NCP.

     



  • 5.  RE: Pulse Secure for macOS High Sierra

    Posted 01-07-2020 18:21

    Thank you Steve.

     

    I wasn't asking for the software.  I was just asking for the correct version of the software that would work on macOS.

     

    I will reach out to Juniper and\or Pulse Secure to buy it.  Just needed a working version.

     

    If you do not know which version would work then I understand.

     

     



  • 6.  RE: Pulse Secure for macOS High Sierra

     
    Posted 01-08-2020 03:06

    The current situation is problematic.   I don't use SRX remote access but the pulse secure products so I can't say for certain.  But I do know that each of the last three MacOS upgrades all required an upgrade of the pulse secure client to continue to function.

     

    And after High Sierra launch there were reports on both Pulse forums and here of issues connecting to SRX with that client.  It appears that both Pulse and Juniper feel the fix is with the other company.  I am not certain there is a fix as I don't use the system and have not seen a post confirming a working setup.

     

    The launch of High Sierra was also shortly after Juniper announced their new deal with NCP as the exclusive remote access client for SRX.  But unfortunately they don't offer a OSX client. 

    https://www.ncp-e.com/en/exclusive-remote-access-solution/

     

    So I'm not sure there will be a good solution here.