Junos OS

Expand all | Collapse all

EVPN - IP address not included in Type 2 route

Jump to Best Answer
  • 1.  EVPN - IP address not included in Type 2 route

    Posted 04-28-2020 07:59

    Hi all,

    I have configured a rather straightforward EVPN/VXLAN implementation in EVE. 2 spine and 4 leaf switches. 

    EBGP underlay and MP-IBGP\VXLAN overlay. I am successfully pinging between two hosts on different leaf switches at L2, however I noticed that ARP requests were being sent between the PE routers. The PE isn't doing proxy arp because it is not learning the IP address of the remote host, just the MAC address. 

     

    root@vqfx-re> show evpn database
    Instance: default-switch
    VLAN DomainId MAC address Active source Timestamp IP address
    10 00:05:86:71:26:01 172.16.50.3 Apr 28 13:55:18
    10 00:05:86:71:b8:00 xe-0/0/0.0 Apr 28 13:44:54

     

    If I do a wireshark capture to view the route being advertised it shows no "IP address : Not included". I understand this is an optional field but i don't know how to turn it on. Without it I am not getting the benefits of the reduced BUM traffic expected with EVPN. I've pasted the relevant config from a leaf switch below. Any help greatly appreciated with allowing the IP/MAC learning

     

    root@vqfx-re> show configuration protocols evpn
    vni-options {
    vni 10 {
    vrf-target export target:1:10; ## Warning: 'export' is deprecated
    }
    }
    encapsulation vxlan;
    multicast-mode ingress-replication;
    extended-vni-list 10;

    {master:0}
    root@vqfx-re> show configuration switch-options
    vtep-source-interface lo0.0;
    route-distinguisher 172.16.50.6:1;
    vrf-import LEAF-IN;
    vrf-target target:9999:9999;

     

    root@vqfx-re> show configuration interfaces xe-0/0/1
    encapsulation ethernet-bridge;

    Description "Client facing interface"
    unit 0 {
    family ethernet-switching {
    vlan {
    members vlan10;
    }
    }
    }

     

     

    root@vqfx-re> show configuration vlans
    default {
    vlan-id 1;
    }
    vlan10 {
    vlan-id 10;
    vxlan {
    vni 10;
    ingress-node-replication;
    }
    }

     


    #vxlan
    #EVPN


  • 2.  RE: EVPN - IP address not included in Type 2 route
    Best Answer

     
    Posted 04-28-2020 22:04

    Hi Alkavana

     

    It seems like you are using the bridged overlay architecture for the EVPN VXLAN.

    https://www.juniper.net/documentation/en_US/release-independent/solutions/topics/task/configuration/bridged-overlay-cloud-dc-configuring.html

     

    In the bridged overlay scenario the type-2 route will only carry the mac-address. 

    The PE leaf will only have the mac address in the evpn database.

     

    The scenario where you will get both MAC and IP in the type-2 route of evpn would be when you have the default gateway is on the leaf itself for the hosts. In that case you will have the arp entry on the Leaf itself and MAC/IP advertisement will be sent across by Type-2 routes.

     

    https://www.juniper.net/documentation/en_US/junos/topics/example/evpn-vxlan-collapsed-topology.html

     

     

    Hope this helps



  • 3.  RE: EVPN - IP address not included in Type 2 route

    Posted 04-29-2020 06:58

    Hi Raviky,

     

    Thanks for that, I have read both those articles and now have a much better grasp of what is happening.

     

    I set up edge-routed topology and it has worked as expected.

     

    Cheers



  • 4.  RE: EVPN - IP address not included in Type 2 route

     
    Posted 04-29-2020 21:09

    Glad that it helped. Keep posting questions and learning JUNOS.