Junos OS

Expand all | Collapse all

ipv6 static route

Jump to Best Answer
  • 1.  ipv6 static route

    Posted 07-04-2018 07:02

    Hello,

    I am trying to add a static default route on Ex-4500 with JunOS 12.3R3.4.

    I have executed the following command

    set routing-options rib inet6.0 static route ::/0 next-hop fe80::172:25:25:1

     but when I have tried to commit the configuration I got the following message

    RT: link-local next-hop must be configured with an interface using qualified-next-hop

    then I did

    set routing-options rib inet6.0 static route ::/0 qualified next-hop fe80::172:25:25:1 interface xe-0/0/37.0

     same error message with commit command

    The ipv6 route for the link-local address is

    fe80::172:25:25:0/126
                       *[Direct/0] 2w6d 00:20:37
                        > via xe-0/0/37.0
    fe80::172:25:25:2/128
                       *[Local/0] 2w6d 00:20:37
                          Local via xe-0/0/37.0

    Any suggestion to solve this issue is appreciated.

    Thanks and best regard

    Cristina

     

     

     

     

     

     

     



  • 2.  RE: ipv6 static route

     
    Posted 07-04-2018 08:18

    Can you try in higher release?

     

    test# set routing-options rib inet6.0 static route ::/0 next-hop fe80::172:25:25:2
    test# commit
    re0:
    [edit routing-options rib inet6.0 static route ::/0]
    'next-hop fe80::172:25:25:2'
    RT: link-local next-hop must be configured with an interface using qualified-next-hop
    error: configuration check-out failed

    set routing-options rib inet6.0 static route ::/0 qualified-next-hop fe80::172:25:25:2 interface ge-0/1/7.0

    #run show route table inet6.0

    inet6.0: 4 destinations, 4 routes (4 active, 0 holddown, 0 hidden)
    + = Active Route, - = Last Active, * = Both

    ::/0 *[Static/5] 00:08:44
    > to fe80::172:25:25:2 via ge-0/1/7.0
    fe80::172:25:25:0/126
    *[Direct/0] 00:09:59
    > via ge-0/1/7.0
    fe80::172:25:25:1/128
    *[Local/0] 00:09:59
    Local via ge-0/1/7.0
    ff02::2/128 *[INET6/0] 1w0d 03:11:04
    MultiRecv

     



  • 3.  RE: ipv6 static route
    Best Answer

    Posted 07-04-2018 22:14

    Thank you for the answer.

    The command with "qualified-next-hop" worked also for me.

    I guess, yesterday, I have executed the command in not clean configuration due to the previous "static route .... next-hop" command.

    cristina



  • 4.  RE: ipv6 static route

    Posted 07-04-2018 22:00
    Did you delete the earlier static route which you configured without qualified next-hop?




    root@PE1_re# set routing-options rib inet6.0 static route ::/0 qualified-next-hop fe80::5668:a3ff:fe1f:21c2 interface ge-0/0/3.0

    [edit]
    root@PE1_re# commit
    commit complete

    [edit]
    root@PE1_re# show routing-options
    rib inet6.0 {
    static {
    route ::/0 {
    qualified-next-hop fe80::5668:a3ff:fe1f:21b5 {
    interface ge-0/0/3.0;
    }
    }
    }
    }
    router-id 150.0.0.11;
    autonomous-system 100;

    [edit]
    root@PE1_re#

    [edit]
    root@PE1_re# run show route table inet6.0

    inet6.0: 7 destinations, 8 routes (7 active, 0 holddown, 0 hidden)
    + = Active Route, - = Last Active, * = Both

    ::/0 *[Static/5] 00:00:08
    > to fe80::5668:a3ff:fe1f:21b5 via ge-0/0/3.0