Junos OS

Expand all | Collapse all

EX4300 J-Web not working

  • 1.  EX4300 J-Web not working

    Posted 10-09-2018 15:19

    Good afternoon,

     

    I have been working on this issue for a few days now trying to get the  GUI interface to work. I would like to see if I could get some assistance on this. 

     

    I am using a EX4300 POE+ 48 Port switch.

    Current Junos OS is 18.3R1.9

    Current JWEB-ex is 18.3A1

     

    The switch has been zeroized and freshly installed with the 18.3R1.9 software.

    I performed an EZSETUP though the CLI:

     

    In-Band Management

    IP address 192.168.1.253

    Subnet: 255.255.255.0

    GW Address: 192.168.1.1

     

    I have configured a laptop to be in the same subnet (192.168.1.2) and currently connected to Gigabit port 0. On the same laptop, I am also SSHed via the console port. When I execute the Restart Web-Management command, I receive the error:

     

    error: Web management gatekeeper process is not running

    error: Web management gatekeeper process was not restarted.

     

    When I performed the command Show System Processes Extensive | Match http, no results would populate. I have tried installing a new jweb-ex package (18.3A1) , deleting system service web-management, perform a force commit than re-adding the system web-managment (set system service web-management http), but still cannot access the GUI via the IP address 192.168.1.253.

     

    Is there anything that someone would recommend? Thanks for your time.

     



  • 2.  RE: EX4300 J-Web not working

    Posted 01-18-2019 15:06

    I found this and it fixed the same problem for me...

     
     
    Solution
    Accepted by topic author jsishodia
    3 weeks ago

    Re: J-Web Access not working

    [ New ]
     
    3 weeks ago

    Hello Jenander,

     

    Thank you for the logs! The phone home feature is enabled and is causing the redirect to fail.

     

    Please try Jweb access after the following change:

     

    delete system phone-home

     

    Apparently the phone-home “feature” is somehow commandeering all web services, and will break JWEB.

     

    Hopefully this helps.

     

    Thanks,

    Pranita

     
     


  • 3.  Re: EX4300 J-Web not working

    Posted 10-05-2020 09:31

    Used console command line to delete the phone-home feature.  J-Web connection in browser worked immediately. 

    Problem fixed!  Thanks!



  • 4.  RE: EX4300 J-Web not working

     
    Posted 01-19-2019 09:09

    On the several models of the ex switch the jweb is now a separate additional install.  For the ex4300 18.1 and later the download is here.

    as you start typing j-web in the search box you can pick the full line for ex switches

    then change the Junos pull down to match your version.

     

    https://support.juniper.net/support/downloads/

     

    documentation is here

    https://www.juniper.net/documentation/en_US/junos/information-products/topic-collections/ex-series/release-notes/ex-j-web-181-A2/index.html