Junos OS

IMPORTANT MODERATION NOTICE

This community is currently under full moderation, meaning  all posts will be reviewed before appearing in the community. Please expect a brief delay—there is no need to post multiple times. If your post is rejected, you'll receive an email outlining the reason(s). We've implemented full moderation to control spam. Thank you for your patience and participation.



  • 1.  MC-LAG mcae config exchange error

    Posted 12-11-2015 04:49

    Hello All,

     

    I am trying to setup MC-LAG between tow MX104 .FOr the same status of ICCP is up but interface MC-AE state is "Current State Machine's State: mcae config exchange error"

    Below is snap of

    manager@MX1# run show interfaces mc-ae
    Member Link : ae1
    Current State Machine's State: mcae config exchange error
    Local Status : active
    Local State : down
    Peer Status : Unknown
    Peer State : down
    Logical Interface : ae1.0
    Topology Type : bridge
    Local State : up
    Peer State : Unknown
    Peer Ip/MCP/State : 10.8.0.2 ae0.0 up

    manager@MX1# run show iccp detail

    Redundancy Group Information for peer 10.8.0.2
    TCP Connection : Established
    Liveliness Detection : Up
    Redundancy Group ID Status
    1 Up

    Client Application: l2ald_iccpd_client
    Redundancy Group IDs Joined: 1

    Client Application: lacpd
    Redundancy Group IDs Joined: 1

     

    Any one has idea what could be reason for mcae config exchange error abd peer status is down.

     

    Many Thanks,

    Brijesh Patel


    #mc-lag
    #iccp
    #mc-ae


  • 2.  RE: MC-LAG mcae config exchange error

    Posted 01-13-2016 08:06

    I have also hit this issue, do you have a solution now? Thanks!



  • 3.  RE: MC-LAG mcae config exchange error

    Posted 01-13-2016 09:17

    Attached working configuration. I have not added diagram but interface connected like a like.

    Attachment(s)

    txt
    MX1 mc-lag config.txt   9 KB 1 version
    txt
    MX2 mc-lag config.txt   8 KB 1 version


  • 4.  RE: MC-LAG mcae config exchange error

    Posted 01-18-2016 05:08
    you can check config now
    #mclag
    #mc-lag


  • 5.  RE: MC-LAG mcae config exchange error

    Posted 01-19-2018 02:23

    Did you get any solution on this old topic ? I am facing the same error message.



  • 6.  RE: MC-LAG mcae config exchange error

    Posted 01-19-2018 03:12

    Config issues .WOrking config i attached same thread above.



  • 7.  RE: MC-LAG mcae config exchange error

    Posted 01-29-2018 13:05

    Hi Gaetan3810,

     

    If you are getting this error, please very your mc-ae config. Make sure each router must have a different chassis-id.

     

     

    mc-ae {
    mc-ae-id 1;
    redundancy-group 1;
    chassis-id 0;
    mode active-active;
    status-control active;
    }
    
    mc-ae {
    mc-ae-id 1;
    redundancy-group 1;
    chassis-id 1;
    mode active-active;
    status-control standby;
    }

     

    [KUDOS PLEASE! If you think I earned it!

    If this solution worked for you please flag my post as an "Accepted Solution" so others can benefit..]

     



  • 8.  RE: MC-LAG mcae config exchange error

    Posted 09-05-2018 00:51

    And different status-control.